Jump to content

Maxtor USB drive disappeared so 0 restore points

Recommended Posts

Maybe someone can help me.......crazy.gif

Recently fought some bad adware problems. Did lots of digging in areas I shouldn't be in. Finally got rid of it all (thanks to majorgeeks). In the middle of it all, I upgraded to Microsoft .NET 2.0.

Then noticed that Retrospect was loading very slowly and Searching status. Found this forum and found my answer to upgrade Retrospect to be compatible with .NET 2.0

Now it works, but my drive is gone, so I see "0 restore points available"

I look in My Computer and my Maxtor USB drive E: is not there. I look in Device Manager and it is there. In the past, when I saw "0 restore points available" I would just cycle power on/off on my drive or unplug/replug the USB cable and viola. But not this time.

In Device Manager, my Maxtor is "working properly" and "Enabled". My driver is from Maxtor dated Oct 7 2004 v signed by Microsoft.

If I run - diskmgmt, my E: drive is not listed.

I tried the drive on another computer and same results.

Any ideas?

Link to comment
Share on other sites



First try this:

Delete the Retrospect Express HD configuration folder located at c:\documents and settings\all users\application data\RetroExp . (delete or rename the RetroExp folder)


Then restart the machine and run setup again in Express HD.


If that fails try applying this update:





Link to comment
Share on other sites


I stumbled upon my problem. I was poking around in the Programs folder and in the Maxtor folder was OneTouch.exe I tried it and a Maxtor window opened and said my drive was locked and wanted a password to unlock. Viola!

I unlocked and I heard a bong like when you plug in a new device. I looked in My Computer and there it is! I opened Retrospect ExpressHD and it lists 132 restore points, so it is ready to go again. Yee haw.

Not sure how it got locked or even what it means to be locked. Do you know?

Also, I noticed that I only have 14gb free left on a 100gb drive. Should I keep adding restore points or somehow delete and start fresh.

Link to comment
Share on other sites



I have maybe the same problem. I start Retro Express HD and get 0 restore points - and the program says "updating status..." while no more happens (even over night).


When I try and push "setup" nothing happens. If I then start the One Touch software and select "restore and backup" the program simpy dies...




Should i install the update, delete the files as mentioned above or what? The restore points are still there on my disk - I can see that.




- or should I do like this guy http://forums.dantz.com/ubbthreads/showflat.php?Cat=0&Board=Windows&Number=65576&Forum=All_Forums&Words=lost%20restore%20points&Searchpage=0&Limit=25&Main=65576&Search=true&where=bodysub&Name=&daterange=1&newerval=1&newertype=w&olderval=&oldertype=&bodyprev=#Post65576





Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...