Jump to content

No backup devices found


Recommended Posts

Just encountered this 1 site where an installation of 6.5 professional was previously working, and just recently developed a problem.


All scheduled duplicate jobs and backup to file jobs continue to be error-free.


Manual backup to DVD disc fails due to No backup devices found.


I installed the latest 6.5 update. Tried uninstalling and reinstalling. Still not resolved.


Envionment tab, it shows:

dEVICES visible using ASPI


Any suggestions on what to try next?

Link to comment
Share on other sites

It's one of those not-so-frequently maintained client site.


Items remained unchanged:

Windows XP Professional Service Pack 2 (build 2600)

Retrospect Professional 6.5 w/ RDU54 update


Intel® 82801EB Ultra ATA Storage Controllers

WinXP Promise FastTrak TX4000 Controller

2x 200G HD mirrored (hardware)


Recent changes (2 months):

joining domain

windows updates (the usual)

removal of mbsa 1.x

shavlik hfnetchk 4.3 (at server) agentless on client side


Nero continues to work ok, tested erase disc (DVD+RW) and burning data disc.


The problems appears to be Retrospect somehow fails to recognize the device. ASPI issues? NT device drivers issues?


All tests performed on domain admins account, which is given local administrators group.

Link to comment
Share on other sites



That is likely the problem.

Retrospect uses the information listed there to determine which driver to load for the device. That item is called the "inquiry string" and is obtained directly from the device. If Retrospect doesn't recieve a valid inquiry string from the device a driver will not load.


Firmware problems, IDE drivers or a faulty drive can cause this kind of thing.


When you are having trouble with a device it is a good idea to try both connection methods. What are you using now?




Link to comment
Share on other sites

As indicated in original post, it was using ASPI. I just now went in and changed to NT passthru per KB #27109.




Drive is now recognized. Backup will presumably work, pending confirmation when client return to office tomorrow. Currently no disc in drive, and I'm remote off-site.




I think something must have caused Retrospect to switched to ASPI mode. There was no upgrade to ASPI which was provided by install of Nero 9 months ago. Is there a way to tell which exact ASPI driver Retrospect was trying to use? There's system ASPI as well as Nero ASPI installed.

Link to comment
Share on other sites

For future reference, I'd like to dig a little deeper into the ASPI issues in general as related to Retrospect.


You mentioned 6.5 will use ASPI by default if installed and available. Does that apply to 7.0 as well?


It appears to me the so-called NT pass-through is actually the default ASPI provided by Windows O.S., automatically loaded upon recognition of the drive device. Nero diagnostics refer to it as "System ASPI" as opposed to Nero ASPI. Am I understanding correctly?


Does Dantz have in-depth articles published on ASPI best practices, tactics & strategies as related to Retrospect?

Link to comment
Share on other sites



No. Retrospect 7 now only uses ASPI if you select it in the Retrospect preferences.


I believe your explaination is correct. ASPI and NT Passthrough are just different ways of looking down a bus at devices. NT passthrough should work on all systems but sometimes that isn't the case. Then you need to try ASPI.


This is all very low level stuff. Beyond using one or the other there isn't much else to know.




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...