Jump to content

Retrospect crashes server, blue screen, USBSTOR.SYS


Recommended Posts

Retrospect consistently crashes my server when I right click on my DVD burner in the Storage Devices/Environment pages. This does not occur when I right click on the CD-RW also installed. The crash causes a BSOD in USBSTOR.SYS which then creates a memory dump and restart. This occurs every time. I have tried an uninstall reinstall of retrospect - no help.



Win2K3 SP1, P4 2.8Ghz, 1.5 GB Ram, 4 x 250gb HD in RAID 5, with three external 250Gb USB HDs and an external DVD burner (LaCie dual layer DVDRW)


Retrospect Single Server 7.0.326

Retrospect Update, version


Device Details in Retrospect

vendor _NEC

product ND-3500AG

driver NEC DVD DL (1.56)


Please help!



Link to comment
Share on other sites



This sounds like a driver problem to me.

How many USB ports are on the machine? Have you added any USB cards? If so, have you updated drivers for the card?


If you are using a USB hub, don't. They can cause lots of problems. Does the error occur if the 3 USB hard drives are powered off?




Link to comment
Share on other sites

I'll try it later on this week or next when I can afford another server crash. (It's currently running a complex algorithm that takes 4 days to complete)










PS. It was on a USB hub but I moved it off. Hopefully that'll fix it but I'll let you know.

Link to comment
Share on other sites

Ok. I just tried it.


The DVD burner is directly attached to the USB port at the back of the server. I switched off the three USB hard-drives attached to the USB hub, leaving the hub switched on and plugged in.


I right clicked on the device in Retrospect and boom, it crashed again...


There are two USB ports in the back of the machine. Its a DELL Poweredge 700. The USB comes of the motherboard and there have not been any driver updates for the BIOS or motherboard.


I'll repeat after I remove the hub completely but I'm not holding my breath.



Link to comment
Share on other sites

Ok, repeated after I unstalled the hub completely.


Same problem, same blue screen.



STOP 0x000000D1 (0x01D3DB95,0x00000002,0x00000000,0xB90BA967)

USBSTOR.SYS - Address B90BA967 base at B90B9000, DateStamp 42435bb6


Any ideas or should I give up on using this burner with Retrospect?

Link to comment
Share on other sites

Ok. So I unistalled the USB ports in device manager and had them reinstall. I also installed the latest intel chipset drivers and the latest BIOS from DELL.


Rebooted and everything is running fine.


But Retrospect still manages to crash the machine when I right click on the drive.


Stangely enough this doesn't happen when the drive is connected to another machine, so it is probably something about the server. I did notice that USB support on servers isn't a top priority for DELL...


I'll try a PCI USB/Firewire add-on card and see if that helps.




Link to comment
Share on other sites



I tried a new USB/Firewire adapter, an Adaptec DuoConnect, with 3x USB2 and 2x Firewire.


I also downloaded the LaCie update software released in Jun 05.

(This crashed my system when running with drive connected to motherboard USB)


Updated LaCie drive using USB on Adaptec card.


Rebooted and tried Retrospect -> Devices. Boom it crashed as before.


So then I tried the firewire option. Retrospect DOESNT crash!!!


Ok. So that has fixed that problem. Lets see if having that solved will improve the consistency of the DVD+R backups....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...