Jump to content

Files backed up for XP Windows System State


Recommended Posts

I have Retrospect 6.5.350 running on XP Pro, SP2


Recently had a meltdown (while trying to install MS Critical Updates) -- long story.


Retrospect Emerg Recovery CD wouldn't work, so went about recovery the long way:

- Created new (empty) partition (let's call it C:)

- Installed XP Pro, SP2 on C:

- Installed Retrospect 6.5.350 on C:

- Installed updated driver 5.4.110 on C:


- Wiped the problematic partitions clean (let's call it D:)


- Tried running "Restore Entire Drive" from a DVD Backup Set, with "Restore System State" enabled. Used the other (now wiped) partition (D:) as the target.


- Used PartitionMagic to hide my recovery partition (C:) and make the newly-recovered partition (D:) the primary partition.


- Tried booting into newly-restored partition (D:, now called C:--how's that for confusing) and found that the VSS (Volume Shadow Copy Services) would no longer run on this newly-restored partition *even though* it was running fine when the snapshot for this newly-restored partition was originally created on DVD. (Make sense?)


- Did some digging and found that COM+ services would not run -- classes not registered.


Which makes me think that some of the System State files were *not* properly restored to the target partition (D:).


I have an older Disk Image of this partition which I can restore arbitrary files from.


So.... the question is:

*specifically* which files does Retrospect treat as "System State" files in XP??


These are the ones I know of (so far):







c:\documents and settings\Default User\ntuser.dat

c:\documents and settings\LocalService\ntuser.dat

c:\documents and settings\NetworkService\ntuser.dat

c:\documents and settings\myname\ntuser.dat

c:\documents and settings\myname\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat

c:\documents and settings\LocalService\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat

c:\documents and settings\NetworkService\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat



Are there any others I need to consider??



Link to comment
Share on other sites

Thanks for the reply Nate.


Here's the problem... My XP Pro SP2 system was completely wacky so I decide to do a "Full Restore", including System State to a point in time where the system was known to be working fine.


The resultant (i.e. restored) system (which spanned 3 partitions: C: D: and E:) did not work properly. The Shadow Copy no longer could start; the COM+ subsystem wouldn't start; programs were freezing).


So apparently not everything was properly restored, even though the error log said everything was fine.


My XP \System folder is on my C: partition, but all of my \Documents and Settings folders (including \Application Data) is stored on my E: partition.


i.e. the System State information spans two different partitions (some of it is on C:, some of it is on E:).


This is what appears to be giving Retrospect v6.5 problems and why I'm trying to figure out how to manually recover *all* of the information stored on these three partitions from this one backup set.


Any ideas?? So far, it seems like I can only ask for one partition to be restored at a time, meaning that it thinks that either C: or E: is not a system partition.


Make sense?


Appreciate any help.


Link to comment
Share on other sites

Why not just reinstall Win XP [sP2] to the original partition, install Retro and do a full volume restore?

While I'm not certain, I don't think that a system recovery works unless you first install the OS [with the same service pack level]. I.e., just restoring a freshly formatted partition with the backup files gives you a functional system.


PS. FYI. The 'to be restored' partition must be at the same service pack as the full system backup before using Retro to do the full system restore. Same with the DR CD - it must be made with the same service pack level as the full system backup.



Link to comment
Share on other sites

Thanks for the advice.


Actually, that's what I was trying to do (see the first post in this thread). All the restore media were at the same service pack level (XP Pro, SP2).


It's as if Retrospect was skipping over certain system files during the "full volume restore"...



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...