Jump to content

Why Do I Get -1020 Error At Tape Change For 650 Mb .ZIP File


Recommended Posts

I am using Retrospect Professional V6.5.350, Driver Update V5.4.110 on Windows XP Professional SP2.


Recently my tape backups have started to go into a second tape volume and I have been getting the following error at tape (media) change during the backup of a subdirectory that contains about 35 .ZIP files that are each between 500 and 800 Mb:


File "H:\H_SPL0\SVDOLCDR\CDRAVSCMP2-0019\CDRAVSCMP2-0019.ZIP": can't read, error -1020 (sharing violation)


The only other application running during the backup is the Windows XP Performance Monitor.


The backup of the file receiving this error is aborted and backup continues with the next file in the subdirectory. This error does not always happen on the same file probably because of new/changed files that were previously backed up on the tape volume. To me this is a bug, because when I run a Recycle backup I don't really have a Full backup until I run the next Normal backup which will successfully backup the file that received the -1020 error during the Recycle backup. I have observed the backup at this point on 2 occasions (not very exciting) and there are no other abnormal messages or anything in the Windows XP Event Log.


I have 2 questions:

1. Why am I getting this error? Searching the forum provided no answers.

2. Does Retrospect V7.0 have this same bug?


Also, I would like to suggest that the Retrospect Operations Log track more complete information about the program run than is now being done, especially the date/time of an actual New Media Request and the date/time of when the new media was mounted and ready.


Thank You,

Carl E. Johnson

Link to comment
Share on other sites

  • 2 weeks later...

Maybe this question was too hard since I haven't gotten any responses. Or, maybe nobody else is backing up a large file at the time a media change occurs.


My guess is that Retrospect has taken some type of "lock" on the file, and after a media change, Retrospect tries to take another "lock" on the same file that it already has a lock on. Since I was running the backup on a quiesced system, the only -1020 (Sharing Violation) error Retrospect could be getting is with a conflict with itself, i.e. bug.


So it appears that Retrospect is unable to handle backing up a file that spans backup media volumes, at least tape media. I wonder if the situation also occurs with backing up to multiple hard drives. This operating characteristic will be even more serious when I try to backup 12 to 14 GB .avi files downloaded from my digital camcorder.


As of the information I have now, I have to make the following assumptions:

A. Retrospect is unable to backup a file that spans output media volumes.

B. The same problem exists in Retrospect V7.0 so there is no point in me being in any hurry to spend $100+ to upgrade.


Thank You,

Carl E. Johnson

Link to comment
Share on other sites

Thanks for the reply Nate.


The answers to your questions follow:

1. I actually have 3 physical hard drives divided into 8 partitions/volumes. C and D are FAT16 for "Real" MSDOS V6.22 and the remainder of them are NTFS. C and D are the first two partitions backed up and they successfully completed backup/verify about 12 hours prior to my getting the -1020 error on the last partition (H) to be backed up which is on a different physical drive than C and D. The layout of the partitions/volumes are as follows:

A. Disk 1 - Seagate ST336752LW 15k rpm SCSI LVD - Partitions C, D, E, G, and I (in that order). Partition G contains the Windows XP and Retrospect files.

B. Disk 2 - Maxtor L01P250 7200 rpm ATA - Partitions L and F (in that order).

C. Disk 3 - Maxtor L01P250 7200 rpm ATA - Partition H. Note that only a Retrospect Subvolume portion of this drive is being backed up.


2. Backup Open Files is checked, but nothing else on that option screen.


3. There are no errors shown in any of the 3 sections of the Event Viewer either before or after the mount of the second tape media during the backup phase of drive H:.


If you have any other questions please advise.


Thanks again,

Carl E. Johnson

Link to comment
Share on other sites



Can you run a test backup with the open file backup option disaabled? You may get some other 1020 errors but I'm curious to see if they will happen on the tape change.


How is the tape drive attatched to the machine? Is it on the same SCSI channel as the hard drive?




Link to comment
Share on other sites

Thanks Nate.


The tape drive is attached to the same Adaptec 29160N controller card as is the Seagate ST336752LW hard drive (along with a SCSI CD-ROM and CD-R/W drive). Partition G on that drive contains Windows XP professional and Retrospect files. However, the file being backed up that gets the -1020 error is on a different physical drive - a Maxtor ATA L01P250. Just to add some more information, the order in which partitions are backed up is C, D, E, G, I, L, F, and a Retrospect Subvolume on H.


I can run a Recycle backup with open file backup disabled as you requested, however it will probably be sometime next week before I can do that because I have to get the next in my set of backup tapes from my safe deposit box and then schedule a time when I can be around about 14 hours after the backup starts to mount the second tape. The total time to do a Recycle backup to tape is about 21 hours, so it will essentially take a day just to run the test once I start it.


As far as getting some other -1020 errors, I scanned my Retrospect Operation Log which I have back to 08/07/2003 when I was running Retrospect V6.0.206 and the only other -1020 errors I got was for the Windows XP Performance Monitor "Perflib Perfdata *.dat" files. This is not surprising, since as I stated I run my Recycle backups on a quiesced system except for the XP Performance Monitor. After upgrading to Retrospect V6.5.319 around 08/21/2003 I never got that particular -1020 error again. The -1020 errors on the large .ZIP files that prompted this forum post first occurred on 12/23/2004 which is the same date my backups started using a second tape. Since then, the only -1020 errors I've gotten was at a tape change during the copy portion of a backup. The -1020 error occurs after the second tape has been mounted. This has occurred consistently (3 times) since then, but I waited to report the problem in case it was a one-time occurrence.


I will reply back to this post after I have run the test you requested. Also, before I start the test I will Re-IPL (reboot) my system and clear the 3 sections of the Windows XP Event Viewer logs before starting the test.


Thanks again,

Carl E. Johnson

Link to comment
Share on other sites

Hi Nate,


I swaped my offsite backup tapes Saturday and started to run the test you requested. Unfortunately, the results went from bad to worse. With Open File Backup disabled I still got the -1020 error at tape media change during the copy phase of the backup for a large .ZIP file plus 2 -1020 errors on drive G. I don't know what those files are used for so I don't know how serious those errors are. With Open File Backup enabled, I only get a -1020 error from the large .ZIP file at tape media change. Also, I got a fatal tape error during the verify, but that was over 4 hours after the -1020 error at tape change. I'll have to clean the tape drive.


In preparation to running your test I:

1. Cleared all 3 sections of the Windows Event Log

2. Re-IPLed (rebooted) my system.

3. Set XP Power Options to only allow shutting down the monitor.


At the end of this post is the entire copy/paste of the Retrospect Operations log for this test backup.


I also kept my own "pencil and paper" log of major events not logged to the Operations Log. Since this was done by watching the screen, looking at a clock, and then writing the information the time information won't be exact. Here are the events I logged:



1. 16:43:09 - Inserted first tape cartridge, started Retrospect, selected the sources and destination, and turned off Open File Backup. Ran preview which showed 146378 files and 89.0 G to be backed up.

2. 16:48:41 - Selected tape drive then "Proceed" and then answered yes to "Are you sure" popup.

3. 16:50:41 - Tape rewinding and erasing complete and copy of drive C starts.

4. 22:23:58 - At this point drives C, D, E, G, I, L have been backed up and verified and the copy operation for drive F starts. These drives contain all of the Windows XP system files and all other application executables. Drive F and the Retrospect Subvolume on drive H are all that remains to backup and they contain only data - NO executables.



5. 07:25:20 - Still comparing drive F - 9.2 GB remain - No new errors during the night.

6. 08:41:12 - End of drive F verify and start copy of Retrospect Subvolume on drive H - This is last item to be backed up.

7. 09:15:56 - Started copy of H:\H_SPL0\SVDOLCDR\CDRAVSCMP2-0005\CDRAVSCMP2-0005.zip.

8. 09:16:14 - Retrospect indicates "Writing Index"

9. 09:16:21 - Got popup to select new tape - Still only 9 total errors at this point and no new -1020 errors.

10. 09:17:34 - Removed tape 1 and inserted tape cartirdge 2.

11. 09:20:00 - Selected "Proceed" and replied to erase warning.

12. 09:20:58 - Tape selection popup goes away and Retrospect indicates "Erasing" - No new -1020 error yet.

13. 09:21:43 Retrospect indicates "Waiting for media".

14. 09:22:14 Got a new -1020 error for the file mentioned in #7 above. Retrospect bypassed the remainder of the file and immediately started copying the next file in sequence in the subdirectory.


Since this is the problem I was reporting, there is no point in continuing with my log. I exported 3 sections of the Windows XP Event Logs but they don't show anything related to the backup except for the tape error I got that terminated the backup. If you desire, I can enclose their contents on a future post.


Lastly, I tried to copy/paste the Retrospect Snapshot information that shows the files before and after the file that got the -1020 error were backed up but not the file that got the -1020 error. Unfortunatly you can't copy from that window. However, I was able to do a screen capture of it with Corel Capture 10 as a .jpg file but I don't know if attachments are allowed. If you want to see it let me know how to get it to you.


Please advise if you need more information.

Carl E. Johnson


Retrospect Operations Log follows:

+ Retrospect version 6.5.350

Launched at 07/03/2005 16:43

+ Retrospect Driver Update, version 5.4.110

+ Executing Immediate Backup at 07/03/2005 16:47

To Backup Set ADR20_GR0T_R65-1...

07/03/2005 16:47:41: Recycle backup: The Backup Set was reset


- 07/03/2005 16:47:41: Copying F16dosr0 (C:)

07/03/2005 16:51:31: Snapshot stored, 335 KB

07/03/2005 16:51:40: Comparing F16dosr0 (C:)

07/03/2005 16:53:14: Execution completed successfully

Completed: 2040 files, 108.1 MB, with 15% compression

Performance: 108.9 MB/minute (96.7 copy, 124.7 compare)

Duration: 00:05:32 (00:03:32 idle/loading/preparing)


- 07/03/2005 16:53:14: Copying F16data0 (D:)

File "D:\ZSYSTEMP\Perflib_Perfdata_2f4.dat": can't read, error -1020 (sharing violation)

07/03/2005 16:56:38: Snapshot stored, 380 KB

07/03/2005 16:56:47: Comparing F16data0 (D:)

07/03/2005 17:01:42: 1 execution errors

Completed: 2001 files, 306.2 MB, with 0% compression

Performance: 104.9 MB/minute (93.7 copy, 120.0 compare)

Duration: 00:08:28 (00:02:37 idle/loading/preparing)


- 07/03/2005 17:01:42: Copying NTF_SMWORK (E:)

07/03/2005 17:02:34: Snapshot stored, 62 KB

07/03/2005 17:02:42: Comparing NTF_SMWORK (E:)

07/03/2005 17:04:55: Execution completed successfully

Completed: 70 files, 42.2 MB, with 0% compression

Performance: 72.2 MB/minute (58.7 copy, 93.5 compare)

Duration: 00:03:12 (00:02:00 idle/loading/preparing)


- 07/03/2005 17:04:55: Copying NTF_WXPRES0 (G:)

File "G:\Program Files\Common Files\Symantec Shared\CCPD-LC\symlcrst.dll": can't read, error -1020 (sharing violation)

File "G:\WINDOWS\SoftwareDistribution\EventCache\{5A1BE4EE-3C73-44F0-A275-4E5D6B947BFE}.bin": can't read, error -1020 (sharing violation)

07/03/2005 17:49:42: Snapshot stored, 88.9 MB

07/03/2005 17:50:45: Comparing NTF_WXPRES0 (G:)

File "G:\Documents and Settings\NetworkService\Cookies\index.dat": different modify date/time (set: 07/03/2005 13:45:00, vol: 07/03/2005 17:46:43)

File "G:\Documents and Settings\NetworkService\Local Settings\History\History.IE5\index.dat": different modify date/time (set: 07/03/2005 13:45:00, vol: 07/03/2005 17:46:43)

File "G:\Documents and Settings\NetworkService\Local Settings\Temporary Internet Files\Content.IE5\index.dat": different modify date/time (set: 07/03/2005 13:45:00, vol: 07/03/2005 17:46:43)

File "G:\Program Files\Common Files\Symantec Shared\SNDFW.log": different modify date/time (set: 07/03/2005 16:34:25, vol: 07/03/2005 17:50:54)

File "G:\WINDOWS\system32\wbem\Repository\FS\MAPPING.VER": different modify date/time (set: 07/03/2005 17:11:17, vol: 07/03/2005 17:45:27)

File "G:\WINDOWS\Tasks\Symantec NetDetect.job": different modify date/time (set: 07/03/2005 13:45:00, vol: 07/03/2005 17:46:44)

07/03/2005 18:25:05: 8 execution errors

Completed: 33760 files, 5.4 GB, with 35% compression

Performance: 154.8 MB/minute (139.9 copy, 173.4 compare)

Duration: 01:20:10 (00:09:10 idle/loading/preparing)


- 07/03/2005 18:25:05: Copying NTF_PGMS0 (I:)

07/03/2005 19:00:32: Snapshot stored, 22.6 MB

07/03/2005 19:01:07: Comparing NTF_PGMS0 (I:)

07/03/2005 19:30:55: Execution completed successfully

Completed: 42915 files, 4.1 GB, with 20% compression

Performance: 130.6 MB/minute (116.5 copy, 148.6 compare)

Duration: 01:05:49 (00:03:04 idle/loading/preparing)


- 07/03/2005 19:30:55: Copying NTF_PGMS1 (L:)

07/03/2005 21:02:15: Snapshot stored, 28.7 MB

07/03/2005 21:02:52: Comparing NTF_PGMS1 (L:)

07/03/2005 22:23:58: Execution completed successfully

Completed: 61244 files, 9.2 GB, with 4% compression

Performance: 116.6 MB/minute (102.9 copy, 134.6 compare)

Duration: 02:53:02 (00:12:48 idle/loading/preparing)


- 07/03/2005 22:23:58: Copying NTF_DATA1 (F:)

07/04/2005 03:43:41: Snapshot stored, 579 KB

07/04/2005 03:43:51: Comparing NTF_DATA1 (F:)

07/04/2005 08:41:09: Execution completed successfully

Completed: 1134 files, 36.0 GB, with 0% compression

Performance: 131.9 MB/minute (115.0 copy, 154.6 compare)

Duration: 10:17:11 (00:59:53 idle/loading/preparing)


- 07/04/2005 08:41:09: Copying H_SPL0 on NTF_INTBUD0 (H:)

File "H:\H_SPL0\SVDOLCDR\CDRAVSCMP2-0005\CDRAVSCMP2-0005.ZIP": can't read, error -1020 (sharing violation)

07/04/2005 13:50:17: Snapshot stored, 1,735 KB

07/04/2005 13:50:28: Comparing H_SPL0 on NTF_INTBUD0 (H:)

Trouble reading: "1-ADR20_GR0T_R65-1" (1734211), error -102 (trouble communicating)

Trouble reading: "1-ADR20_GR0T_R65-1" (1734211), error -102 (trouble communicating)

Trouble positioning: "1-ADR20_GR0T_R65-1" (1734211), error -205 (lost access to storage medium)

07/04/2005 14:01:30: Execution incomplete

Remaining: 1027 files, 32.6 GB

Completed: 2183 files, 850.5 MB, with 0% compression

Performance: 113.8 MB/minute (112.6 copy, 203.2 compare)

Duration: 05:20:20 (00:12:22 idle/loading/preparing)


07/04/2005 14:01:30: Execution incomplete

Total performance: 126.1 MB/minute with 2% compression

Total duration: 21:13:48 (01:45:35 idle/loading/preparing)

Quit at 07/04/2005 14:47

Link to comment
Share on other sites

Hi Nate,


Are you still there? I ran the test backup as you requested but haven't yet received any reply. Maybe you are on vacation now.


In any event, I would appreciate hearing any ideas on how to solve this consistent problem of getting a -1020 error at tape change during the copy portion of a backup when Retrospect is in the process of backing up a large .ZIP file.


Carl E. Johnson

Link to comment
Share on other sites

  • 1 month later...

This is just an update to inform that this problem also occurs with .avi files:


- 08/14/2005 23:47:27: Copying H_SPL0 on NTF_INTBUD0 (H:)

File "H:\H_SPL0\SPLWORK\MVI\V20040916-D.avi": can't read, error -1020 (sharing violation)


This is a 7.4 GB .avi file from my Canon Digital Camcorder, and as before, the only other application running was the Windows XP Performance Monitor.


Carl E. Johnson

Link to comment
Share on other sites



Sorry for the slow response. I have been far away from all things "computer" for a while.


Some of the 1020 errors in your log are legit. The perflib file and the symantec files are most likely in use while the backup is running.


The real strange one is the 1020 on large files that span tapes. Do you have any other programs installed that monitor files or provide open file backup functionality? If you stop all the items in your start up using msconfig does the problem still occur?


I assume that on subsequent backups any files that gave an error on media span are backed up sucessfully?




Link to comment
Share on other sites

Hi Nate - Welcome back to "computerland".


To answer your second question first, a subsequent NORMAL backup does back up the file that got the -1020 error during the RECYCLE backup at tape change during the copy.


As far as I am aware there is nothing else on my system that provides open file backup functionality besides Windows XP. I do have Windows XP System Restore running, but:

1. Monitoring is turned off for the drive containing the file that got the -1020 error.

2. Prior to originally posting this problem on 06/13/2005 I ran a RECYCLE tape backup with System Restore completely turned off and still got the -1020 error.


Since running the test you had earlier requested for which I replied on 07/04/2005 I made some changes to my tape backup strategy as follows:

1. Turned Open File Backup back on.

2. I split the tape backup into two jobs - one that backs up the drives containing all the Windows system files and other executables and one that backs up drives containing only data files. Only the data file backup job requires more than one tape.


It is interesting that if I run a RECYCLE backup of my complete system to my 400 GB external Firewire hard drive I have no problems, but I don't have enough data (yet) to fill up the drive so I don't know if the -1020 always occurs at any media change or only for tape. Also, so far I only have one external hard drive so I couldn't test that anyway.


In contrast, the tape backups consistently get the -1020 error at media change during the copy portion of the backup. So far I have only had media changes on large files so I don't know if file size has anything to do with the problem. At the time I get a media change request during the copy portion of the backup the "executing" section of the Retrospect Activity Monitor shows 0 errors. After I mount the second tape and once its finished rewinding and starts to copy again, an error will show up immediately in the Activity Monitor and looking at the log shows the -1020 error.


I never thought to turn off everything in msconfig probably because the problem is so closely coupled to the tape media change and the external hard drive backup has no problem. I am reluctant to run that test, because as you can see from the log of the most recent backup that follows my name, the job takes almost 29 hours to run.


Since I'm running V6.5.350 I think I'm going to have to live with this problem. I had V7.0 for a while but was unable to determine if this problem still occurred because of its fatal error of not being able to back up large EFS encrypted .ZIP files. Hopefully both problems will be solved in V7.5(?).


Carl E. Johnson


+ Retrospect version 6.5.350

Launched at 08/14/2005 14:52

+ Retrospect Driver Update, version 5.4.110

+ Executing Immediate Backup at 08/14/2005 14:55

To Backup Set ADR20_GRT2_R65-1...

08/14/2005 14:55:10: Recycle backup: The Backup Set was reset


- 08/14/2005 14:55:10: Copying NTF_DATA1 (F:)

08/14/2005 19:28:39: Snapshot stored, 609 KB

08/14/2005 19:28:49: Comparing NTF_DATA1 (F:)

08/14/2005 23:47:18: Execution completed successfully

Completed: 1194 files, 30.0 GB, with 0% compression

Performance: 130.1 MB/minute (112.8 copy, 153.8 compare)

Duration: 08:52:07 (01:00:19 idle/loading/preparing)


- 08/14/2005 23:47:27: Copying H_SPL0 on NTF_INTBUD0 (H:)

File "H:\H_SPL0\SPLWORK\MVI\V20040916-D.avi": can't read, error -1020 (sharing violation)

08/15/2005 10:13:26: Snapshot stored, 1,736 KB

08/15/2005 10:13:36: Comparing H_SPL0 on NTF_INTBUD0 (H:)

08/15/2005 18:38:01: 1 execution errors

Completed: 3214 files, 59.9 GB, with 0% compression

Performance: 125.5 MB/minute (105.7 copy, 154.5 compare)

Duration: 18:50:34 (02:34:58 idle/loading/preparing)


08/15/2005 18:38:01: 1 execution errors

Total performance: 127.0 MB/minute with 0% compression

Total duration: 1 03:42:49 (03:35:19 idle/loading/preparing)

Quit at 08/15/2005 18:46

Link to comment
Share on other sites



I'm not convinced this is a bug in Retrospect 6.5 yet. Most of the time tapes will span in the middle of a file. If it were really a bug with spanning between tapes we would have seen thousands of similar issues from other users.


Your backup to firewire disk is actually spanning between a bunch of 600 MB files too.


Plus you should never get 1020 errors when open file backup is enabled.


Something else has to be involved here somehow. The question is "what?"...


Is this a dual boot machine? Can you install XP on another partition and try running the backup from there?




Link to comment
Share on other sites

Hi Nate


I certainly don't know where the problem is. Maybe the problem lies in the driver for the tape drive. I also thought other people would have reported this problem, but I also thought that when I tried V7 months after it had been released and found out it was (unlike V6.5) incapable of backing up large EFS encrypted zip files, but nobody had yet reported that problem.


This is not a dual boot machine but I suppose I could change that and install Windows XP on another partition, etc. However, I don't think it is worth the major effort to do that because, even if it showed that Retrospect was the problem, the fact that V6.5 is not the current version it probably wouldn't be fixed. Just not a time effective option to save a possible 5 to 10 percent of the tape media usage. I would be better off just making a third backup job to eliminate the tape media spanning issue altogether.


Another reason I'm reluctant to expend this significant effort is that the current setup of the Retrospect Operations Log is essentially useless for problem solving. The fact that error messages are not time stamped is almost unbelievable. So you end up runing test after test with no clue as to what is happening or when it is happening and having to resort to a guesswork try this, try that mode of operation. I was an IBM mainframe systems programmer for over 20 years and I don't remember anything that didn't time stamp error messages.


Things that I might have considered trying:

1. Run the same backup using the Windows XP Professional Backup utility and see what happens.

2. Yank the old, old TR4 tape drive out of my old system and see what happens when a large file spans tape media when using Retrospect V6.5.

3. Temporarily copy some of the large files to some of the system drives to a directory "ahead" of the more normal size "system" files and see what happens at tape media change.


If this is only a tape related issue, it could be a moot point in the next several months because after I acquire two more 400 GB external hard drives I may switch to using external hard drives instead of tape backup in the future. The economic equation of tape vs hard drives has changed, since a hard drive can be bought for less than just the equivalent amount of tape media alone, let alone the expense of the tape drive. Then I will only use tape for archiving.


Unless I make another post to this thread you can assume that it is closed.


Thank you,

Carl E. Johnson

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...