Jump to content

Does Retrospective 7.0 Actually Work?


Recommended Posts

I licensed 6.5 a few years ago, but it never worked, and I abandoned it. I'm now trying the 7.0 demo to determine if anything has changed. So far, no luck.


I've tried backups on 3 different Dells:

1. Optiplex GX270 with XP Pro and SP1 and an NEC ND-2100AD DVD drive;


2. 360 Workstation with W2K, SP4 and both a NEC ND-1100A DVD and a Plexitor PX-708UF DVD drive; and


3. 650 Workstation with XP Pro and SP1 and an NEC ND-1100A DVD drive.


On each, Retrospect 7.0 installs correctly and runs successfully the "Configure CD/DVD drive" routine. I set it up for DVD +RW, and it seems satisfied with that.


When I attempt a simple boot drive backup, it successfully creates a backup set of DVD+RW discs.

I have the "Verify" option set. On every drive and every machine, the verify process discovers hundreds of errors. They are all of the " error -206 drive reported a failure: dirty heads, bad media, etc." variety. This occurs with both Imation and Fujifilm brands media.


This seems like a pretty big coincidence to me; particulary since all the machines and DVD drives seem to work properly for other uses.


Is Retrospect still not ready for prime time?

Link to comment
Share on other sites



For supported drives, you shouldn't have to configure the drives. Just get the latest Retrospect Driver Update.

In your case:


1. It appears the NEC ND-2100AD is not supported unless it's the HP version so you would you have to configure the drive.


2 and 3. Both are supported:

ND-1100A - http://www.dantz.com/en/support/compatibility_list_detail.dtml?id=8851

PX-708UF - http://www.dantz.com/en/support/compatibility_list_search.dtml?q=px-708uf


Retrospect requires it's own drivers and configuration because it writes to these optical drives in a different method compared to other 3rd party applications. This method is what allows Retrospect to continue reading, writing and restoring while the session is still open thus allowing you to use the full capacity of the disc instead of wasting available space by closing the session.


For the first drive, if it configured successfully and you're backing up using the same type of media that you configured with, you might want to try setting the drive to a lower write speed and testing it out:

Configure > Devices > Right click your CD/DVD drive > Properties > Click on the "Set Write Speed" button (the first button in that window)

It's set to default but you can play with the settings.


The other 2 drives are supported so I would recommend downloading the latest RDU and be sure to remove the custom configured driver "deviceXX.rdi".

Link to comment
Share on other sites



Make sure you have the Retrospect driver update applied to your installation of Retrospect. This contains custom drivers to support cd/dvd writers within Retrospect. You can get this on the Dantz website in the updates section, here:



Also, you can check for officially supported drives on our compatibility list here:



The ND-1100A and PX-708UF drives are supported.


If you custom configured these drives to work with Retrospect, you will need to delete the custom driver files as these take priority over default drivers. You can search your computer for "*.rdi" files. These are usually located in the same directory as the Retrospect config file and operations log.

Link to comment
Share on other sites

Thanks for the info.


None of the three machines have any *.rdi files, even though all of them went through the Retrospect 7.0 custom configuration routine. Is this a typo? Should I be searching for some other file type?


These verify errors don't seem to be DVD device write speed dependend. They occur on all three machines even at the slowest write speeds.

Link to comment
Share on other sites

On my Dell GX-270, which has the NEC ND-2100AD (an unsupported device), the Configure > Devices > Environment shows the driver _NEC DVD +RW - RDI (1.56). According to the Windows Explorer Search Engine, there are no "*.RDI" files on any local drives. Under the "Product" column heading, it shows "DVD+RW ND-2100AD", which I find encouraging, even though it doesn't work properly.


The Dell 650 Workstation, which has the NEC ND-1100A, a supported device, also shows the

" _NEC DVD +RW - RDI (1.56)" device. There are, however, no "*.RDI" on any of the local files, at least according to the Windows Explorer search tool. If I understand the advice given here, using the custome device is apparently an error. Should I remove the custom driver support? If so, since the machine has no "*.RDI" files for me to delete, how do I remove the custom device and restore the organic ND-1100A device?

Link to comment
Share on other sites

If the RDI driver is showing in Retrospect, then it should be on your system.

Can you check this path: C:\Documents and Settings\All Users\Application Data (hidden folder)\Retrospect


You may not be able see these files because the Application Data folder is hidden.

To show the folder: Tools > Folder Options > View > Show hidden files and folders.


Using the custom driver is not necessarily an error but if the device is supported, then using the Retrospect driver is recommended.

Link to comment
Share on other sites

I did manage to remove the custom configuration from within Retrospect, although I never found any "*.rdi" files to delete. It is now using the NEC ND-1100A driver support. That has helped. A simple "C:" drive backup now has several dozen "error -206 drive reported a failure: dirty heads, bad media, etc" errors rather than several hundred. That seems like progress, but it still doesn't seem like an acceptable outcome on which to base my system backups.


Are there other issues I should be exploring to get error-free backups to DVD R/W, or is that just not achieveable with Versoin 7.0?

Link to comment
Share on other sites

Well, I'm sitting here with an NEC ND-1100A drive on an Optiplex GX280 running 7.0.265 with RDU7.0.3.101 and I've tested with FujiFilm CD-R media and a Ridata 4X DVD+RW and haven't run into any problems.

The erase portion of the DVD+RW did take awhile which is to be expected when formatting 4.7GB but I haven't gotten any type of errors.


Error 206's can be caused by several things:

Bad Media

Bad Drive

Bad connection ie. problem with the ATAPI cable or possibly the IDE slot


It sounds like you've already tried different brands of media.

You may want to try moving this drive to another machine and use another cable.

If that doesn't work, I think you may want to try another ND-1100A drive.

Link to comment
Share on other sites

Thanks for the feedback. I have 3 different Dells (GX-270, 360 and 650), 3 different drives (ND-10100A, ND-2100AD and PX-708UF) and 4 different brands of DVD+R/W media (Imation, Fujifilm, Sony and Maxell) (I'm not using CD-R at the moment). All exhibit the same behaviour. It's difficult to believe they all share a common hardware problem or that the media all share a common manufacturing defect. I need a functional backup option, so I'm anxious to believe Retropect 7.0 will work, but at the moment Occam suggest that the common failure here is Retrospect 7.0.

Link to comment
Share on other sites

  • 3 weeks later...

Well, I have a Dell GX 260 with a ND1100A DVD+R/W (supported), and every time I put in a fresh DVD, it's erased for a while, then Retrospect Professional crashes, complaining that the power was turned off or something. And no catalog is produced, and no reference to what happened is in the log.


I had also had a problem with CD-Rs using the same drive, but this happened "only" once (but the write speed was HORRIBLE).


I used TDK DVDs, by the way. so, we now have four Dells, three drives, and 5 different brands of DVD+R/W.


And I was waiting for over 30 minutes in the tech support queue before I finally just hung up. Retrospect used to be a ROCK SOLID product in the good old Macintosh days 6 years back.

Link to comment
Share on other sites

Correction: the log does report the crash that I referred to just above.


Another fun trick that Retrospect plays is that it gets lost and thinks is awaiting media when it isn't. So it's hanging. This happens when one starts the backup, the first disk of the backup set is asked for (the only DVD in my current backup set), and one inserts it. Try to stop the backup and Retrospect just doesn't respond. One can't get the DVD out of the machine, either. Kill the process (in XP), and one get's a box saying that Retrospect ... crashed, maybe because of a power failure.


Retrospect can also be made to crash if one tries to use the Retrospect help system while the program is running. Also, it seems that if Retrospect is running, it sometimes does not let Internet Explorer initiated. Kill Retrospect, though, and suddenly IE pops up.


I'm sorry, but this looks like a REALLY BUGGY PRODUCT.

Link to comment
Share on other sites



What DVD/CD burning software do you have installed? Cases where Retrospect goes off into no mans land are often a result of other software trying to grab hold of the DVD/CD drive. Programs fighting for deivce access can also cause the other problems you have mentioned.


One thing you can do is to install ASPI and enable ASPI in the Retrospect preferences. The ASPI installer (ASPIINST.exe) is in the Retrospect program folder. This will change the way Retrospect looks down the IDE bus and talks to your device.




Link to comment
Share on other sites

Retrospectively, it sort of works. As long as you can babysit the server and the clients, and your hardware is all in perfect order, then Retrospect can be made to run pretty well. It does a lot of things very nicely, better than many high-end "enterprise" backup solutions, in fact. I replaced Veritas BackupExec with Retrospect, and my life is definitely better. Online purchasing & download, setup and configuration, hardware compatibility are all strong points. Retrospect is still not ready for prime-time in the enterprise, though.


Leave Retrospect to its own devices for 24-48 hours, and you're as likely as not to come back to a bunch of failed and/or waiting backups and an error dialog that's holding up the works. Dantz still does not grok the concept of a hands-off backup server that does its thing, sends email when it hits a nonfatal error, and keeps on going with the next job. No, Retrospect pretty much dies at the drop of a packet, as it were, and then doesn't know what to do, doesn't email anyone, just sits there doing nothing. Perhaps it's attempting to achieve nirvana or something; if that's the case, it's doing a great job.


Even if you set the prefs to their maximum "no feedback required" configuration, it doesn't stop Retrospect from throwing up a dialog box and waiting for its keeper to click the mouse. Hello, Dantz! I want a backup server that doesn't NEED a mouse. The GUI is great, but its use needs to be OPTIONAL.

Link to comment
Share on other sites

  • 4 weeks later...

I'm sorry for the delay in responding, Nate. I had given up on Retrospect, then I realized that I had not restored a backup from an external hard drive. NOW I have to buy this product. You can imagine my pleasure. Unbelievably, I found the "standard image" included the lousy DirectCD, which can screw up absolutely anything. So, I caused that feature to be uninstalled. Also, I removed the PowerDVD software, which I also never use.


What I'll do is try a backup & see if it now works.

Link to comment
Share on other sites

I can't get a straight answer on how to make Proactive Backup work on 7.0 professional.


I bought an upgrade to 7.0.249 as soon as it appeared, then tried to use Proactive as I had used Backup Server in the past - when setting up a new Proactive Backup script, I get a message saying, "Proactive Backup requires an additional license" despite having been assured it was included. I can't find how to purchase a Proactive add-on; clicking on the helpful 'Purchase...' button leads to the main Dantz/EMC web page with no obvious place to purchase such a license.


I've sent multiple emails to support; all but the first have been ignored; the first one assured me that Proactive is included in Professional... I'm still waiting for answers to the other two or three from several weeks ago.


Can anyone help me?


-- Bruce

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...