Jump to content

Retro 7: Restore from Snapshot


Recommended Posts

This looks like a bug in Retro 7. I could not duplicate this in Retro 6.5:

  • Get properties for a backup set.

  • Go to the Snapshot tab, Pick a volume and select Browse.

  • Browse down a path that is more than 2 folders deep.

  • Highlight a file or folder that is located at least 2 folders down the path and select Restore.

  • At the Restore window I get "0 files (zero K) selected for restore".

  • You have to click the "Files Chosen" button to open another Browse window and go to the same file and place a checkmark in its box in order to restore.

If I do this in a folder that is close to the top of the path (up to 3 folders deep) then I can see the number of files selected to restore and proceed with the restore without having to go thru a second browser window.

I have tried this in Retro 6.5 and I was able to go to a file 6 folders deep and restore it without a problem.

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
  • 4 months later...


It looks like the fix for this has not made it in v7.0.326. This problem could turn a simple restore into a complicated process.



As someone who is evaluating the trial version of RP7, I am concerned that a problem raised last April and long accepted to be a genuine bug is still not fixed. I don't like the idea that a restore might be complicated. I want my chosen backup product to make restores easy. The product appears to have moved from V7.0.300 (or perhaps even earlier) to V7.0.326 in that time, i.e. at least 26 updates in 8 months and yet this bug is still there!


Can someone from Dantz please assure me that it will be fixed very soon.

Link to comment
Share on other sites



The standard restore procedure (click on the "restore" button from the restore "menu") is fully functional and works properly.


The problem outlined here is related to an alternate restore method. This will be addressed in an updated version of Retrospect however the release date has not been made public.




Link to comment
Share on other sites


I've not yet played with the restore facilities of RP7 as I'm just taking one step at a time during the trial period to avoid any mistakes. However, is this 'alternative restore method' a matter of selective restore versus 'standard' full restore, or does the standard method also allow selective restores?

Link to comment
Share on other sites

  • 2 months later...

Reviving this 10 month old thread.

Now that Retrospect 7.5 was released, what are the chances for the restore from snapshot bug decribed above, to be fixed in Retrospect 7? Or will the fix be available only in v7.5?

I am familiar with the "standard restore" method. In my case however I find that I have to restore more files deleted from a server by users. These files are in the latest snapshot and much easier to restore from there.

Link to comment
Share on other sites

Hi there, was wondering if you can help.


Bought Retro 7.0 just over a month ago and need to get some files restored back again from an external hard drive. when i try to restore some files it does not show that I have any files in Backup 1.... but when I open the window normally using my computer it shows 39gig of space used with around 60 blue disk icons of around 600mb each.


My files are there but I can't seem to access them!!


Please help if you can..


C .. London , England

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...