Jump to content

Can't get retrospect Express HD working


Recommended Posts

I just purchased a new Maxtor OneTouch 2 external hardrive. On my system, I currently have two other Maxtor external hardrives. One of the existing drives is a Maxtor 5000XT and the other is a Maxtor OneTouch first generation. I was not using the Retrospect software in the past because I could not get it figured out and it seemed to be very buggy while draining a lot of system resources. I purchased the OneTouch 2 so that I could take advantage of the automatic back up features and he one touch back-up.


My operating system is XP Pro with SP2. I installed the new drive but had to go to DOS to format it with NTFS. I never received any registration screens prompting me to register the software. When I press the onetouch button, nothing appears to happen. When I launch the Maxtor Express HD software, my CPU use goes to 100% and the program seems to hang. When I got to the Onetouch software button,and select the drive and try to set it up, nothing happens. I am feeling pretty frustrated and hope that some one hear can assist me in getting this software properly set-up. frown.gif


I followed the information in the following thread:




1. I uninstalled the Retrospcet HD software,


2. deleted the directory in documents and setting,


3. disconnected my other maxtor drives,


4. reinstalled the retrospect software,


5. turned back on the drive.




When I try to set-up Retrospect HD the programs hangs and maxes out my CPU again. Any ideas will be apprecieated. I will continue to work on it from my side.




Thanks in advance,





Link to comment
Share on other sites

I get an error message when I try to install this software on Windows XP(sp2). "Application has generated an exception that could not be handled" Program fails to load after that point. I've tried loading it on 3 different machines, with the same result. No response from Dantz yet on a fix for this problem.



Link to comment
Share on other sites

  • 1 year later...


This topic is now archived and is closed to further replies.

  • Create New...