Jump to content

assertion check at "elem.c-826" error

Recommended Posts

I got the "assertion check at 'elem.c-826' " error in the course of doing an incremental backup of a folder (which I've denoted as a "Volume" in Retrospect) on a Windows machine from my Mac. I have 2 backups on separate external hard drives. I backed up the folder using the first drive without a problem. Ten minutes later I tried to backup the same folder on the second external drive and got the above error. I've tried it again several times and continue to get the error. I do not get the error when backing up other folders on the Windows machine.


Can anyone tell me what this error means and how I can avoid it? Thanks.


I'm running Mac OSX 10.3.7 and Retrospect 6.0.204 on the Mac.



Link to comment
Share on other sites

Hi Nate,


It's a backup. I suppose I could, but it messes up the consistency of my backup system. I have one backup set that includes 30 or 40 volumes, of which the problem volume is just one. I could create a separate backup set for this volume. I will give it a try tomorrow and let you know if it is created without encountering this error.


From what you're saying, I guess there's a problem with the file for this volume on the external drive to which I'm backing up.


Thanks for your assistance.



Link to comment
Share on other sites

Hi Nate,


Well, I created a new backup set for this volume and the backup went just fine - no errors at all. This is a 10 GB Volume. I can either leave it as a separate backup set or you mentioned something about transfering the contents from one backup set to another. I've never tried this and have checked the manual. Here's what I think is involved.



I go to Tools>Copy. Then I select the backup set containing the damaged volume. Then I select the backup set that I just created containing a clean version of that volume. Then I create a selector that excludes the damaged volume from the data to be transferred. (It's all in a single folder so I suppose I would just create a selector excluding files contained in that folder.)


Am I on the right track, or is there a simpler way of accomplishing this if I choose to do it? Thanks again for your kind assistance.



Link to comment
Share on other sites

  • 2 weeks later...

I get this error too... in the middle of a backup, after scanning for files on a network source...


Trouble in Retrospect:

Internal Consistency check failed

Assertion Check at "elem.c-826"

With only a 'Quit' button...


Software versions:

Retrospect Backup 6.0.204

Device Access Version: 1.0.106

Driver Update Version: 5.9.104

Mac OS X Server 10.2.8 (6R73)


System configuration:

Dual G4 tower 1.25Ghz with 512MB ram, serving only filesharing

Backup unit is a HP Ultrium 230e (external UW-SCSI)


It's not the first time I see this error, I always fix it by deleting the storage set, making a new one and – again - editing my backupscript.


It’s very annoying and makes Retrospect not trustable as a serious backup solution where you can depend on.


I mailed this problem to Dantz eurosupport, they better fix this soon or they loose another customer.



Link to comment
Share on other sites

I just got this error also.


Mac OS X 1.3.7

retrospect 6.0.193

retro update that was released yesterday (6.1.102)

Pioneer 107D DVD drive

using -R media


after 16 DVD's, only half of the 16th DVD was written, and then it asked for a new DVD, #17 and I get this error during an incremental backup. So, I ask it to verify the catalog starting with DVD #11, it gets to DVD #16 and goes into Resychronizing (slow) mode and eventually gives the elem.c error. I'm rebuilding the catalog since a repair attempt ended in the same error.


I think this needs some attention from the programmers.


Thank you.

Link to comment
Share on other sites

The programmers are probably going to want to know if you can reproduce this on a machine that is supported by their product; one that is not modified with a processor upgrade of some sort.


The busses in the original Blue & White G3 were not really up to snuff (both FireWire and ATA). I'd suggest trying the program on a modern Macintosh that's within Apple specs to see if the problem perisists. Or maybe just for fun see if the DVD drive will work as a slave off whatever ATA controller you're running.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...