Jump to content
Sign in to follow this  

Unable to backup SQL 2k databases with SQL agent, unknown error

Recommended Posts



Here are the stats:

I am using Retrospect 6.5 (v6.5.350) multi-server with SQL agent and Open File agent on Windows 2000 Server w/ SP4.


The SQL server machine has been upgraded from Windows 2000 server to Windows 2003 Server without SP1.

SQL server is MS SQL 2000 w/SP4.

Retrospect Client version: 6.5.136

Share Point services (not Portal) has been installed on this machine as well. It is using the MS SQL database, not MSDE.


During the backup process, I am able to backup the drive data on the server, but not the SQL databases. This is the error I receive:

Trouble reading files, error -2147221164 (unknown)

I receive this error for each database.

The Retrospect SQL agent is using local admin to access the SQL server.


Well, that error number doesn't exists anywhere.


Here is what I tried so far:

Remove the SQL agent and client from the SQL server.

Reinstall the Backup client and SQL agent.

Tried to backup just one database, not the whole server or all databases, still receive the same error.

Rebooted both machines, as well. (hey, it works for 99.9% of Windows issues)

The SQL server was upgraded to Windows 2003 to be able to use Sharepoint services and during the course of the upgrade SQL server needed to be updated to SP4.

The Retrospect backup was working after this upgrade/update.


This error just started to happen a few days ago. There were no additional updates done to the machine.


Please let me know if there is a way to troubleshoot/resolve this issue.


Thank You,


Christopher Massa

Share this post

Link to post
Share on other sites



"unknown" errors mean that Retrospect does not know what the problem is. It tried to send backup commands to the database but all it got back was the error message.


google brought up a few articles about this error:



I'm not sure if the causes are the same but it is worth looking into.




Share this post

Link to post
Share on other sites



I just wanted to send a followup with regards to this issue.


I was able to resolve it, thanks to everyone's help. I looked into the error message on google and on the posts here.


It turns out is was an unregistered DLL on the SQL server machine.


C:\Program Files\Microsoft SQLServer\80\COM


I found a MS KB that pointed to the suspected dll:



Although the KB refers to the issue of having v7 and v2000 on the same machine, which was not the case with me, it did give me the pointer.


After I registered "sqlvdi.dll", the backup process was able to work against the SQL databases.


Christopher Massa

Share this post

Link to post
Share on other sites



This totally worked for me.


For others, here's the actual command

regsvr32 sqlvdi.dll


and I did it in this directory

C:\Program Files\Microsoft SQL Server\80\COM

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this