Jump to content

Open File Backup option error 1017


Recommended Posts

Using Professional version 7.5.387


Get a can't use Open File Backup option for local disk , error 1017 (insufficient permissions)


VSS logs an Event ID 12292 just prior to Retrospect logging this error.


I'm going to investigate the VSS error but thought someone might have some ideas. I've tried the various suggestions in other posts about the error 1017 without any luck.

Link to comment
Share on other sites

I was able to solve my problem as described below. Hopefully my solution will help others who have a similar problem.


First I tried to duplicate the problem using Windows XP backup. It also generated the Volume Shadow Copy error that I was receiving prior to the Retrospect error. That sent me on a Google search which found the following in a newsgroup : Computing.net


If you look at Response 15 in this thread, you'll see how to check the Application ID in COM+ Applications for MS Software Shadow Copy Provider. In my case it wasn't the same as the path shown in path to executable in Services for MS Software Shadow Copy Provider Service.


Using regedit, I fixed the problem as described in the response (be sure to back up the key first) and it resolved my problem in both MS Backup and Retrospect.

Link to comment
Share on other sites

Thanks Louis. I'm copying the relevant information below from Post 15 in case the link breaks. VSS errors plague many users.


Please note that this issue is a Microsoft issue. EMC has not tested these fixes, and support is not provided for VSS errors. Proceed at your own risk when making Registry changes, and always backup your Registry prior to making any changes.



This may not be applicable to your situation, however might be worth a look. I have had similar problems with VSS on XP machines that turned out to be caused by the MS Software Shadow Copy Provider Service (SwPrv). You should be able to manually start and stop both VSS and SwPrv (net start vss) (net start SwPrv). If VSS manually starts OK, but you get an error when trying to start SwPrV, then you could have a permissions problem with it (account used to start it? should be system account), or a registry error with the services command line. I have run across several situations with XP machines where the command line for the SwPrv service is incorrect.


Possible Solution (these instructions are for XP)

Open Control Panel, Administrative Tools, COMPONENT Services

Inside the Console Root folder, goto COMPONENT Services -> Computers -> My Computer -> Com+ Applications.

On the top toolbar, click on View, Status (or click the Status button on the toolbar).


You will see all Com+ applications and their statuses including the Application ID and the PID (if currently running).

Make a note of the Application ID for the MS Software Shadow Copy Provider entry.



Next check the command line used for the SwPrv service. Navigate back to the top root folder. Inside the Console Root folder, goto Services (local). Note, you can also get here from Control Panel, Administrative Tools, Services.


Find the MS Software Shadow Copy Provider Service and double click on it. Notice the Path to Executable field. It will have an entry similar to the following:

C:\WINDOWS\System32\dllhost.exe /Processid:{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}


Check to make sure that the GUID inside the curly brackets is the exact same as what you found in the Application ID in the first step. If it isn't, then this is what is preventing the service from starting.


To correct, open regedit and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SwPrv

Double click on the ImagePath value and make the necessary correction.


It is obviously a good idea to export a backup reg file of the above key in case you make a mistake or need to restore the original settings.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...