Jump to content

Linux client is "deferred" -- why?


Recommended Posts

We've only seen this on some of our PC clients, but...


Running "backup server" mode.


One of my 4 Linux clients is stuck in a "deferred" mode. Computer *has* been restarted, but client is still deferring.


I can manually backup the client, but can't get it out of this "deferred" state.



Link to comment
Share on other sites

Update on my end (I'm using the 7.5 client, btw...)


I have two basically identical "backup server" systems.


I add the client to one of them -- this specific client will be stuck as "deferred" when I turn on backup server.


I add the client to the *other* system -- the client backs up in backup server mode. (!)


But even after doing that sucessful backup in the second system -- the client will still be stuck as "deferred" when I put it back in the 1st system. (And I should add that I can add *other* clients just fine to this first system!)



Does this indicate corruption in the "RetroConfig" file? If so, I have all kinds of scripts in my server system that would take an exceedingly long time to recreate. Is there any way to verify/fix this problem if it's a problem in the config file?




- Steve

Link to comment
Share on other sites

  • 1 month later...

Did you find a solution?

I'm having this issue with an XP client. I've tried wiping out the Documents and Settings\All Users\Retrospect folder and reinstalling, but it still always defers execution. All other clients work and a regularly scheduled script backup works for this client too, just not proactive backups.




I found a file called retro_defer in windows\temp. Deleting that fixed the issue.

Link to comment
Share on other sites

I can't say WHY but I think I may have found a workaround for this.


After enabling a second NIC and setting the box up as my internet gateway, I found that I could not use the client at all - it just doesn't seem to like being multihomed, even when configured to only respond to one address. Following a hint I picked up from another thread, I added the client by IP address and not only did it re-appear but it also could be used by the backup server - ONCE.


So I added a cron job to stop and restart the client every night and it now works with backup server.


This is version 7.0.110, installed from tarball on Debian AMD64 using 32 bit libraries.

Link to comment
Share on other sites

  • 1 month later...

I have the same problem here.

I have Retrospect MultiServer 7.0.344

Proactive backups do not work for my RedHat ES4 server. The client always gets "deferred". If I leave the server polling, it will keep trying the client forever. This starts new CPU processes on the OS and will create a big load on the machine, forcing me to kill the RETRO process.


Regular backup do work fine.


I tried the solution herefore mentionned and they don't work.

The RH client is added by direct IP adress. I tried stopping and restarting the client and it doesn't change anything.


Anyboy solved this problem?

Link to comment
Share on other sites

  • 7 months later...






While this topic is probably dead for those involved, I couldn't find the solution anywhere else, so thought I'd add it here for posterity.


I had the exact same problem with the client being deferred. This was on a RedHat ES server running the latest Linux client. Finally, I made the connection -- I don't have a "DISPLAY", since we manage everything via command line. The installer automatically puts the "RETROSPECT_HOME" environment variable in the system login (profile) script. I guessed that when the server was trying to back up the system, it was trying to put up a dialog. With no GUI, it failed -- deferring the backup.


My solution: comment out the "RETROSPECT_HOME" lines in /etc/profile. Other systems may need to do it in other places, but this is what worked for me -- finally!



I had this problem too. A Retrospect Linux client 7.5.122 constantly deferred. This fix worked for us. FINALLY!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...