Jump to content

problem restoring files from backup


Recommended Posts

We are using 6.1.126 Restrospect on a server backing up some 50+ clients. Generally no problems. This day I need to recover some data from a Mac client. Using an immediate restore based upon file/folder search as the snapshot (state of last backup) had the files already deleted. I find the files with my search and perform a recovery of the files... only... they do not recover. I do not even get prompted for a tape... after a while of displaying a blank dialog box it just claims the recovery of 0 files was successful. So I added in another file which I found it could recover, along with the ones I need and it recovered the one but not the others. Watching it I see as it closes out the restore that it scrolls the files names along the bottom of the dialog box... so I know the program is aware of the files. So I ended up looking at the privileges on the files... the ones recovered and the ones I cannot recover and they are indeed different so I am wondering if this is the problem. The files I cannot recover are -rw------- the ones I can recover are usually -rwxr-xr--. Do you think this is a privileges issue? I am confused as I can find them in my search... if they weren't backed up they would not be displayed. They have valid file sizes when I view the info. They just won't recover.

 

I would appreciate any help on this one.

Thanks

Bill

Link to comment
Share on other sites

Thank you as I was not even aware that you could go back in history for snapshots.

Unfortunately though it did not turn out any better then that which I had already tried. In fact worse as the files were not even displayed as if they never existed. I jumped back then even a month and still received similar results.

Link to comment
Share on other sites

This has branched off into two issues; the behavior of the Search Restore and the behavior of old Snapshots.

 

Since you can see the files you want in a Search of the Backup Set, you should be able to Restore them

 

What are the exact steps you are taking?

 

- Immediate -> Restore

- Search for files and folders

- Select your Backup Set(s) (just one? Or more then one?)

- Select your Destination volume

? Which Restore method is selected at the top? "Retrieve files and folders," "Restore entire disk" or one of the others?

- Enter your search criteria

- Click "Files chosen"

- Unmark the files you don't want, Mark the file(s) you do want

- Click "Restore"

 

 

I just successfully searched for and restored a couple of files with rw- --- --- permissions, using Restore just files, so there is no inherent problem with doing that.

 

What were your steps?

 

Dave

Link to comment
Share on other sites

Thanks... All of the steps you list are exactly what I am doing, I am retrieving files and folders. I am selecting to retrieve only select files. Thank you for testing files with similar permissions and proving that not to be the issue.

 

I have recovered too many files, in too many ways, over some dozen years with Retrospect but I have yet to see something of this nature.

 

I have not had this problem before. Although I have recovered files from the trash which were invisible, seeming not to have been recovered but in fact they were.... that is not the issue here. This is something I have not seen before. I considered the files were aliases but that is not the case. It is the weirdest thing.

 

There has to be some sort of explanation, outside of the recovery issue, which helps me to understand why the files are not visible in a snapshot but visible in a file search.

 

The only oddity that I am aware of, other then the obvious, is that this user had a folder on the desktop named Documents while there is the standard Documents folder located in the user's home directory. It is feasible I guess that Retrospect is confused between the two folders but my file searching reveals both folders, and both with different content. The snapshot will reveal the two folders as well, just siginificantly less data in the one on the desktop then there should be.

Link to comment
Share on other sites

Okay... I have recovered the files. I called EMC tech support and they suggested I do my find, check date of backup on found files, then go through my set contents to check and see if the session pointed to by the backup date revealed all the files being present. They were indeed present. So then I recreated that snapshot, incidentally from two months ago. Then recovered from this snapshot.

 

While this worked I still have an unanswered question as to why they would not recover from my found files searching. The snapshot part of my story (files not being present in snapshot) is seemingly explained by the fact that the last snapshot of them existing was two months ago and I had not gone back that far. The fact that the user waited this long to ask me about them also begs the question of the files' value.

 

Anyways, if I ever get an answer to my question I will post it. Until then, thanks for the helpful suggestions and wise advice.

Bill

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...