Jump to content

Retrospect honors SMB but not AFP connectivity to Volume for Backup


Recommended Posts

I have a G5 mac OSX 10.3.9. I have been using Retrospect 6.1.126 for over a year. Doing a Duplicate of a PC server Volume to a Firewire on my Mac every night. It has been working great. Recently, we were told to connect to server with AFP protocal.I can mount the server... it appears on my desktop. I have access to all files, Copy, delete, move open etc.

 

When I go to set up a Restrospect Backup Script and choose the volume to back up, destination, and schedule, the script looks OK as before (SMB), but FAILS when I check if its a Valid Script. I followed instructions on how to mount an AFP volume, but when I go to define the volume, it asks me for a password, but won't accept it, and says try again. I have tried all my known passwords, to no avail.

 

Does anyone have a solution or fix or workaround? I would appreciate any help.

lynn@worthit.com

Link to comment
Share on other sites

Quote:

I followed instructions on how to mount an AFP volume

 


 

It would probably be a good idea for you to describe, step-by-step, what you did. It's easy to say you followed instructions, but, well, it's not working and it should.

 

This phrase specifically:

 

"I can mount the server... it appears on my desktop. I have access to all files, Copy, delete, move open etc."

 

suggests to me that you didn't properly have Retrospect mount the volume; generally, when configured correctly, you will _not_ have access to all files from the Finder.

 

The way it's supposed to go is:

 

- Mount the AFP volume from the Finder

- Retrospect->Configure->Volumes->YourRemoteVolume->Volume menu->Configure...->Enter password associated with the user name shown in the "Saving a password for automatic login" window

- UNMOUNT volume, either from the Finder, or from Retrospect->Volume Database->Volume menu->Put Away

- Retrospect->Configure->Volumes->YourRemoteVolume (it should be grey)->Any button (Subvolume works best).

-Observe the volume mount. Configure your subvolumes as necessary.

- At this point, the Finder may have limited access to the volume, but Retrospect will have full access.

 

Dave

Link to comment
Share on other sites

Dave,

When I was connected to Volume (It's a PC Server) before I was using SMB protocal. I had a script for backup, and it worked fine for a year.

Now they are telling me to connect to Server using AFP protocal.

I did exactly as you said (Same steps) and as Dantz User manual says as well.

 

What happens is everything goes as prescribed until I click on Configure the Volume. I get the pop-up window, and I click on the Volume I want to back up, but on the next pop-up window where it asks me for the password, it does not fill in the address, and other info. It asks me for my password, but I already had Volume mounted and had already entered my password to access the Volume, and no matter what password I enter, it won't accept and tells me invalid script.

 

Also, before, I left Volume mounted on my desktop, and did not unmount when Retrospect finished.

The script would run every night just fine.

 

I am stymied. I think it might have something to do with permissions on the PC server the Volume is mounted on.

 

Any suggestions.

 

Lynn

Link to comment
Share on other sites

hi lynn,

 

have you read this kb article:

 

http://kb.dantz.com/article.asp?article=1144&p=2

 

you need to mount the volume as 'root'. this may be why your passwords are not being accepted. do you have the root account enabled? see the above document for more info. Retrospect runs as the root user and will not have access to volumes mounted under a different account.

Link to comment
Share on other sites

Quote:

you need to mount the volume as 'root'.

 


 

No no no no no.

 

You _only_ need to log into the Finder as root when you are saving a Catalog or File Backup Set TO a remote AFP volume. Using a remote volume as a Source does _not_ require any the root login trick.

 

> everything goes as prescribed until I click on Configure the Volume. I get the pop-up window,

 

Where to you "click on Configure the Volume?" Where exactly is this in the steps outlined above? What's a "pop-up window?"

 

Can you walk us through, step-by-step, exactly what you're doing, and what you're seeing when you do it?

 

How Retrospect interacts with remote shares depends on the permissions set on those shares; in some configurations it can work without having Retrospect mount the volume (which it can't do for SMB volumes anyway). Other times the volume needs to be mounted with the effective user ID (UID) of zero for the program to work. But without knowing _exactly_ what steps you're taking, and _exactly_ where in those steps it fails, there's no advice that we can give that might help.

 

Dave

Link to comment
Share on other sites

Per the User manual... page 172

To configure a shared volume, log in to mount the volume. I DID.

Select the volume in the Volumes Database list and choose Configure from the Volumes menu. I DID.

The password configuration dialog appears listing the server, volume and user names. THIS INFORMATION DOES NOT COME UP, IT IS BLANK.

In the space provided, enter the password for the displayed user names (which isn't displayed) enter the password (which doesn't work because there is no name displayed, but it allows me to enter a password, none of which work).

Does this clear up the steps I am taking?

Lynn

Link to comment
Share on other sites

> The password configuration dialog appears listing the server, volume and user

>names. THIS INFORMATION DOES NOT COME UP, IT IS BLANK.

 

 

I'll assume that you mean the "Saving password for automatic login" window is not entirely blank, but that the fields for Server: Volume: and User: are blank. Is that correct?

 

These fields will indeed be blank when attempting to configure a non-AFP volume. So perhaps the problem is in how you're mounting the volume originally from the Finder.

 

- In the Finder, select "Connect to Server" from the Go menu (or press command + K)

- Enter:

afp://xxx.xxx.xxx.xxx (where xxx.xxx.xxx.xxx is the actual IP address of your AFP accessable sharepoint)

- Authenticate

- Try and Configure Retrospect

Link to comment
Share on other sites

  • 3 weeks later...

I have new information...

When I connect to server using SMB protocal ... I get a normal backup.

 

When I connect to server using AFP protocal, the script says it is a VALID script, but copies 0 files says there is nothing new and gets out. I don't think it is reading the Sever.

 

Anyone have suggestions?

 

Lynn Lerner

lynn@worthit.com

Link to comment
Share on other sites

Quote:

Anyone have suggestions?

 

 


 

Well, I had a some suggestions about three weeks ago, but apparently you either didn't take them or decided not to address them here.

 

/pout

 

You really need to describe the steps you're taking. Carefully, accurately and completely. Simply answering another poster's queries that YOU DID is not the same thing as describing it yourself.

 

It's also _very_ helpful to use the same terms that Retrospect uses, especially in regards to Sources and Destinations.

 

It's likely that you are have not configured your Source volume for auto-mounting by Retrospect, resulting in the program (which runs as root) being unable to see files on a remote volume that has been mounted by a user other then root.

 

It doesn't matter that Retrospect can see the files when a different file sharing protocol is used; if you want to use AFP, Retrospect needs to mount the volume.

Link to comment
Share on other sites

Quote:

Quote:

you need to mount the volume as 'root'.

 


 

No no no no no.

 

 


 

Quote:

It's likely that you are have not configured your Source volume for auto-mounting by Retrospect, resulting in the program (which runs as root) being unable to see files on a remote volume that has been mounted by a user other then root.

 


 

rolleyes3grem1.gif

Link to comment
Share on other sites

tongue.gif right back at you, Walter!

 

Your original suggestion:

 

you need to mount the volume as 'root'.

 

taken out of context _might_ sound the same as what I've said since. But the full context of your suggestion included:

 

do you have the root account enabled? see the above document for more info.

 

Clicking through to the Knowldege Base article, the reader would see the first step as:

 

"1) Log into the Mac OS X backup computer as Root"

 

It was to this that I replied "No no no no no"

 

Unless the remote AFP volume is being used as a Destination (and even then, only if the Catalog or File Backup Set is being stored in a subdirectory below the root level), there is _no need_ to log into the Finder as the the root user.

 

To use a remote AFP volume as a Source, it is enough to simply have Retrospect (which runs as root) pass valid authentication information on to the remote server. The resulting share will be owned by root, even though it may have been mounted with Joe_Foo's login and password.

 

Giggle.

 

Dave

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...