Jump to content

[SOLVED] unable to read xattr - "unexpected end of file" killing Linux backup, redux

Recommended Posts

I had a similar error back in 2014, but it was an unrelated issue.

The platform is CentOS 7, but with FreeBSD kernel (FreeBSD 11.1 and older versions didn't experience this issue, but the current 11.2 and 12.0 kernels report the lack of xattr information differently).

Basically, the FreeBSD kernel doesn't allow the Linux-based Retrospect client to read extended attributes / xattr of files, and so Retrospect refuses to back up any of those files. I don't need extended attributes, I just need the files backed up!

The Retrospect Client is logging this for every file encountered:

fetFileSpec: ExtAttrGetData() failed with error 61

When tracing system calls on retropds.23, I see this:

 linux_llistxattr()	  ERR#-61 'Attribute not found'

Basically, as expected, it can't get the extended attributes.

The Retrospect Server logs this differently, though:

can't read, error -1114 (unexpected end of file)

None of the files are changing in size, so there is no "unexpected end of file". Retrospect has full read/write access on the drive (obviously, since it is what places "retropds.23" there). It looks like the Retrospect Server is interpreting the message from Retrospect Client incorrectly!

I've tried reporting the problem to Support on the Retrospect website, but since I'm running it on an "unsupported configuration" (that's worked fine for the past 6+ years), they won't even consider fixing the bug.

Does anyone know of a way to get Retrospect to ignore xattr information? Or to get the Server to NOT skip files?


Link to comment
Share on other sites

Engineering came to my rescue!

It looks like this is fixed in Server version and newer (still in internal testing, as of May 23rd, 2019).

A server upgrade it therefore required if you intend on using Retrospect on FreeBSD 11.2+ or FreeBSD 12.0+.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...