Jump to content

A new variant of "error -1103" problems


Recommended Posts

It seems as Retospect stops backing up as soon as it encounters a -1103 (write protected) error.

-	2018-11-19 10:00:00: Copying Windows7_OS (C:) on S055OG
		2018-11-19 10:02:25: Found: 309 002 files, 64 152 folders, 110,6 GB
		2018-11-19 10:02:31: Finished matching
	2018-11-19 10:02:34: Selector "All Files Except Cache Files" was used to select 308 998 files out of 309 002.
		2018-11-19 10:02:47: Copying: 6 150 files (16,8 GB) and 4 hard links
		File "C:\$Recycle.Bin\S-1-5-21-3941569082-136807904-2980746977-8672\$RDS1MC6.xls": can't read, error -1103 (write protected)
		Trouble reading files, error -1103 (write protected)
	2018-11-19 10:03:00: Execution incomplete		
		Remaining: 6150 files, 16,8 GB
		Completed: 0 files, zero KB
		Performance: 0,0 MB/minute
		Duration: 00:02:59 (00:02:44 idle/loading/preparing)

WRITE protected? The backup should READ the files, not write, so write protection should not matter.

And even if one file could not be read, Retrospect should continue to backup the remaining 6150 files and not just skip them.

By the way, the file in question is a file that Windows puts in the trash, and not anything that the user puts in the trash.


Here is another variant:

-	2018-11-19 15:17:52: Copying Windows (C:) on S103DF
		Using Instant Scan data for Windows (C:) on S103DF
		2018-11-19 15:18:38: Found: 369 341 files, 68 789 folders, 80,5 GB
		2018-11-19 15:18:44: Finished matching
	2018-11-19 15:18:48: Selector "All Files Except Cache Files" was used to select 369 339 files out of 369 341.
		2018-11-19 15:18:54: Copying: 1 250 files (6,2 GB) and 2 hard links
		File "C:\Users\s103df\OneDrive - TR3PL\.849C9593-D756-4E56-8D6E-42412F2A707B": can't read, error -1103 (write protected)
		Trouble reading files, error -1103 (write protected)
	2018-11-19 15:19:58: Execution incomplete		
		Remaining: 865 files, 5,1 GB
		Completed: 385 files, 668,2 MB
		Performance: 607,3 MB/minute
		Duration: 00:02:06 (00:01:00 idle/loading/preparing)

This looks more like the Onedrive problem outlined in this KB article: https://www.retrospect.com/en/support/kb/scanning_incomplete_1103

But it still doesn't backup the remaining 865 files.

What's up with this?

Link to comment
Share on other sites

Was this file in OneDrive before it was deleted?

When this problem with Files on Demand files first reared its ugly little head, any 'local'* copy of a OneDrive Files on Demand file that was deleted would still cause the -1103 error while it was in the Recycle Bin. I never bothered to investigate too far, I negated the -1103 error by not using Files on Demand, but using a reboot to Linux (most of my systems can native boot to Linux if necessary) to look at the files system it appeared that the deleted files only exists as a reparse point in the Recycle Bin folder to the actual location where the file is stored.

Information on this is sparse, but it looks like the code that implements the Files on Demand is under certain circumstances creating invalid data structures in the NTFS MFT which most likely confuse Retrospect. When I've tried scanning NTFS volumes from Linux with Files on Demand enabled that give the -1103 error they always reported an unclean with an unknown error. NTFS volumes with Files on Demand enabled that don't give the -1103 error always reports as clean.


* I have yet to find where the local copies of One Drive Files on Demand files are physically stored. Trying to resolve the target of the reparse point that is the OneDrive folder leads me nowhere. The local copies of Files on Demand are not much use as backups when Windows 10 won't boot and you need to perform data recovery from Linux.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...