Jump to content

v12 - 'needs media' when running old script

Recommended Posts

Hi, just upgraded to v12 and hit a snag.

I have 2 media sets, 1 on a NAS the other an External Drive.

When running a backup script which would save to a media set on my NAS I get the message 'Waiting for media' and there is a choose media button. I'm not sure how to select my old media sets that reside on the NAS. Further when I look at the NAS media set, the location now points to the external drive?? I know that my earlier backups were saving to the NAS, how do I update the media set location information?


Any idea?


Link to comment
Share on other sites

  • 3 weeks later...

Hi twickland,


Excuse the very late reply, I just got back from a holiday, yay. Backup issue still persists, nay.

I tried the pencil icon and selected the correct folder and got the following red message appearing in the window, I've attached in screenshot. Would you know what that means? Retrospect telephone support recommended that I rebuild the catalog files, which does work. However if your solution worked, it would be far more elegant and save me a load of time. I rather suspect this is related to the media set residing on a NAS. After the upgrade retrospect seems to see my NAS folder with a name structure like "Soda@NAS._afpovertcp._tcp.local/Stuff" whereas before it just showed the name of the shared folder in the Sources tab.

Link to comment
Share on other sites

I've attached in screenshot.

...which seems not to have been saved to your post.


You also didn't mention where the media set's catalog is stored. If it's stored on the NAS, I'd try moving the catalog to a local volume on the Retrospect server and just keeping the media set's data files on the NAS to see if that makes any difference.


That being said, you may well have come across a bug in 12.0.0. You certainly shouldn't have to rebuild the catalog over and over again. If the problem persists, you should reopen your case with Retrospect support.

Link to comment
Share on other sites

Hi, tried attaching the file again.


The catalog files are on the local volume while the media sets are on the NAS. Once the catalog has been rebuilt it seems to work fine, It's unfortunate there isn't an easier way to move and attach a media set(I didn't move the media set in this instance.)


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...