Jump to content

Waiting for media error

Recommended Posts

Hi there,


Last night all our back ups suddenly stopped, there is a flashing question mark and an error saying waiting for media. The back up thunderbolt drive is connected and visible by retrospect. When you click on the media set it just says busy.


The back up is just mirroring another thunderbolt raid attached to the server.


Back up drive has 924GB free still.


Running of mac mini server running 10.9.2


We have restarted the machine and the back up server and still get the same error.




Link to comment
Share on other sites

Check disk permissions on Finder level and via the terminal.

I had moved a disk backup set to another drive using a Finder copy and I got the same "waiting for media" error.

After manually setting the ownership of the files via the terminal and setting file ownership in the Finder I was able to get rid of the error.


Maybe this info can help in your situation.

Link to comment
Share on other sites

But I made no changes to disk permissions or anything between the backups working and not working.


The fact these steps fixed the problem also point to an issue with Retrospect, not file permissions:


1. Media Sets->Choose your media set-->Members->Click the Pencil Icon to edit and rechoose your locatino.

2. Click your media set again.

3. Click repair. For me this took like 5 seconds to run at most, even on large backups(500gb+).

4. Once that is finished click verify. Let the verify finish. Obviously this may take a while depending on the size of your backup and speed of your network. Some of mine took multiple days.



- John

Link to comment
Share on other sites

  • 3 weeks later...

I know WHY this happens... cos it happened to me. It seems to especially effect NAS disk backups, and it's to do with how Retrospect 'sees' them on the network. What I mean by that is: when you start a backup to a NAS drive, do NOT mount it on your desktop. Retrospect can find and backup to it fine, without mounting it. If you do a backup with the NAS drive mounted, and the 'no media' error appears, you'll have to rebuild the catalogue.


Otherwise if it is a normal desktop hard disk (connected via USB/Firewire etc), and it suddenly doesn't recognise the backup, it might be that you've connected the drive through a different type of connector. Just reconnect to the other port on the drive, if it has one. Or, the drive may be developing bad blocks on the disk platters, in which case start another member on the same drive, to bypass them – if you know the drive is good, and Retrospect is just being overly cautious. So long as your member backups are intact, you'll be OK, but a catalogue rebuild may be necessary in future, if the 'no media' error reappears again.


Whether it's a bug or not, who knows, but this is the solution.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...