Jump to content

Retrospect Desktop 10.5, but using old v9 Engine - how to update it?

Recommended Posts

How the heck do I update the Retrospect Engine, currently at v9.0.2? This truly mystifying!


Note: I've recently purchased an upgrade to the new Retrospect Desktop v10.5.0 (145) console app.


I've tried the update feature (in the Apple menu, I think) in the console app twice, says I'm up to date, but it hasn't updated the engine.

And for the life of me, I cannot find any downloadable DMG file with a any versions at all.


IS there a v10.x of the Engine or am I stuck with v9.0.2 forever? I must be missing something.


Regards and thanks.

Link to comment
Share on other sites


It's inside the 374 MB download.




I"m afraid it IS'NT inside the DMG file, certainly not as a separate installer or app. So unless Retrospect has hidden the Engine it inside the console app, I've no idea where they've put it. In the meantime, I'll dig a bit more, to see if it can be found/installed.

Link to comment
Share on other sites

Sorry for the confusion. The "Update" menu item refers to the console, and the 10.5 console contains the engine installer inside. The 10.5 console should prompt you to upgrade the 9.0 engine and display a small upgrade icon next to the name in the left navigation. You can also extract the engine installer from the Preferences under Console. See our documentation for more information.

Link to comment
Share on other sites

I've finally managed to update the Engine to v10.5 - hurray!!


However, the way I managed to do this is somewhat surprising... I opened the Retrospect console app by right clicking it and selecting 'show package contents', went into the 'Resources' folder, and then to the 'updater' folder. And ran the package called 'Retrospect Engine Installer.pkg'. Voila! If you then open your System Prefs window you should see the version change to v10.x.


Link to comment
Share on other sites

  • 2 months later...

Update to this thread... I may have found another way to do this in the Console app, but it's a bit vague.


Look in Preferences > Console (not sure this features in v9, but it is in v10.x), and click on Export Server Installer... button. Like I said, even in the user guide, it doesn't say exactly what this is suppose to export, the Engine only, or the Engine and Console app (again)??? Not tried it, but if anyone can shed some light on this feature, you're welcome to add your bit in here.


I suspect that this is how you are supposed to install the new version of the Engine. I wish the user guide (for v10, p13-14) made it a bit clearer.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...