Jump to content

Loops after user disconnect and -519 error

Recommended Posts

+ Retrospect version 7.6.123

+ Driver Update and Hot Fix, version

Clients either 7.6.107 or 7.7.114. This problem happens with both. I hoped that upgrading to 7.7.114 would fix the problem, but NO.

Disk backup sets, Proactive backup.


If a laptop user disconnects his/hers laptop during the "building snapshot" stage of the backup then sometimes the Retrospect server loops. The server uses 100% CPU and the other backups running slows considerably.


I can not stop this execution in any way (that I found). I click on the "Stop" button, confirms that I want to stop the execution and the "Stop" button is disabled. But the backup never stops. I have waited hours.

So I have to stop all the other executions (which takes some time due to CPU usage, but works out eventually.)

Then I have to "End task" in the Windows task manager.

I get the same error afterwards:




Why is this happening?

How can I prevent it?

If I can't prevent it, how do I stop ONLY the offending execution?


What is the recommended client version for server 7.6.123?


Is this fixed in version 7.7?

Link to comment
Share on other sites

  • 2 weeks later...

I've not seen this exact issue in 7.7, although I do have backups hang on "Building snapshot" and have to crash retrospect in the same way to allow other clients to backup using the same script.


I really *really* hate cancel buttons which do nothing. It should try and cancel the script nicely until 'x seconds/minutes' and then kill the process if it fails to stop - rather than just sat hung blocking further backups.



Link to comment
Share on other sites

  • 9 months later...

I have a similar problem, with server version 7.6.11 and client v.7.6.106 ...yes, this is a very old version, from 2008 :-/  Right now I  have it running on Windows 7 SP1 with about 20 hosts.


I'll get the -519 Network Connection error, and the only way to get that particular backup to stop is to end the process in Task Manager.  CPU usage is nearly 100% until I end the process.  I am also curious if this is solved in 7.7.  It seems this issue would go away if Retrospect force-closed the problematic backup after X time, or offered an option to force-close after a user-defined time.   Our backups never take more than an hour, more typically they are 5 - 20 minutes.



I've been trying to chase down an issue with our network, where outbound access goes from 20 MBit (what we pay for) to 1 Mbit, meanwhile inbound is steady at or near 20 Mbit.   The link lights on our Cisco GB switches look like the lights on a hub with a ton of Ethernet collisions -- blinking so much they almost (but not quite) seem solid.  

This only seems to happen when a backup is in a "519" state, but even shutting off the server doesn't change the network issue, the network seems to clear of its own accord, and the server could display -519 for a day or two without the network issue showing up, or even appearing at all.   Unfortunately I don't have login access to the switches, firewall or router (managed by HQ IT) so I don't have any more information right now.  


Has anyone else observed this?  

am I on the right track, e.g. could Retrospect (or the network adapter) be sending spurious packets stemming from -519 Network Connection Error? 

Any other way to collect information, or possible fixes in case the Retrospect server is the offender?


[edited July 17 15:21 PDT]

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...