Jump to content

Engine hang when tape powered down

Recommended Posts

It happened several days ago, and I'm not certain about the sequence any more, but I think the story was like this.


I was doing something with the tape, and Retrospect 9.0.2 requested another tape.


I took the opportunity to clean the tape ddrive, but Retro didn't "see" the cleaning tape. When the cleaning was done, I put in the tape it was asking for, and the display persisted as "empty" (no media).


I futzed with "scan" and "scan all" and waited a bit, but nothing changed. Thinking this might be an issue with the drive, I power cycled the drive.




As I recall, when I powered up the drive, and tried o operate on it, the console hung. Then I tried cycling the engine, and the engine hung. It was a busy hang, as I recall. I could not get the console to connect at all, nor get the control panel to stop the engine. I ended up killing the engine (kill <pid>)


The attached file is a sample of the engine from Activity Monitor.


Lesson: don't take devices away when Retro need them, or it gets unhappy.

Sample of RetroEngine.txt.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...