Jump to content

Trouble getting Retrospect to us all members of a set - keeps asking for new media when 2.5GB is still available

Recommended Posts

Hi There,


I've been trying to run a backup for a week with no luck. I've deleted the catalogue, the script, erased all the members of the media set (using disk utility), then rebuilt everything - and done that 3 times over.


But each time I run the first backup, Retrospect only uses half the capacity of the members then says it needs more media.


If I click the "Choose Media" button and try to add the third 2TB disk (despite there being 500GB left on the second disk) it states:

"This disk is already a member of this media set" which makes sense because each time I've set things up, I've added all the disks to the media set so it can grab new media as needed and run overnight unattended.


What doesn't make sense is that if I go to the finder (when Retrospect is asking for new media) I can see that:

1-Backup: 946MB Available

2-Backup: 528GB Available

3-Backup: 2TB Available


Nothing has really changed in terms of the amount that needs to be backup up and we've been using this 6TB configuration for the best part of a year - it usually lasts 4-5 months of daily incremental backups before we need to recycle the media. I've also tripple checked the amount needed for the first backup and it's 3.7TB - so with 6TB available I'm 99% sure this isn't a capacity issue.


The problems started last week when Retrospect reported that it needed new media, because the disks were full I ran a recycled backup. But from that point on, Retrospect has been exhibiting this issue (hence me removing everything and trying to create a clean start) but it always gets 99% through before asking for new media.


How do I force Retrospect to use all the members of a media set - or trouble shoot this issue?


Retrospect: v8.2.0

Mac OSX Server: v10.6.8


Any help would be much appreciated.





Link to comment
Share on other sites

How do I force Retrospect to use all the members of a media set - or trouble shoot this issue?

Make sure that Retrospect hasn't inadvertently been configured to use less than the full capacity of each volume.


Go to Media Sets, highlight the desired set, and click on the edit (pencil) icon at the bottom of the window. This will enable you to view and set the maximum amount Retrospect is allowed to use for each member.

Link to comment
Share on other sites

Thanks heaps for the reply,


It states that it's going to use 1862GB or 100 percent of each disk in the media set - which seems about right.


The backup I'm having issues with is one that runs at 1pm each day. Interestingly, we have another backup that runs at 11pm each night and that backs up the same disks with no issues - even though it's media set has 1.5TB less capacity (3x 1.5TB disks).

Link to comment
Share on other sites

Thanks for that - good call.


There are errors which I get all the time regarding:

- "Copying Time Machine data is not supported"

- "Can't read, error -1012 ( feature unsupported)" on a few email messages in User's hard drives

- "Can't read, error -1101 ( file/directory not found)" on /Library items in User's hard drives

- ".DS_Store": didn't compare"


I assume I can ignore these?



Then there are a lot of erros like this:

!Trouble reading: "2-OffsiteBackup" (27519775), error -102 ( trouble communicating)


So this is obviously some issue with Firewire on the backup server?


Thanks heaps - will investigate further.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...