Jump to content

Restrospect recovery help needed!!! Please!


Recommended Posts

Hi all,


I have been using Retrospect Express for several years on a Maxtor OneTouch III external drive. Recently my desktop suffered a catastrophic hard drive failure. I have since replaced the hard drive, reinstalled my OS (XP Pro + all updates including SP3) and all applications. This is a single home-use PC.


Unfortunately in the intervening years I have lost my Retrospect Express installation CD and after downloading it, realized that I did not have a licence for it any longer. It seems I can’t purchase one from the Roxio store either, as the embedded link in the app appears dead and a search of the store turned up nothing.


Anyway, after reading through forums, it seems 7.7 will recover Express backups so I downloaded a trial version of Retrospect 7.7.562 and installed it.


I have attempted to recover my files (mostly digital photos which are irreplaceable and from overseas missions on which I have been deployed – and they have high sentimental value to me).


However, it seems I cannot get 7.7 to recover the files. It recovers the folder structures, but not the file contents, and I have checked and double checked that all files are ticked in the folders I want to recover.


Attached are some screenshots.


1. I mark 12,351 files for recovery (32GB of data)

2. I confirm the selection.

3. The summary tells me all is good. I am restoring to a folder named ‘RR’ I defined as a volume through Retrospect. I select Start.

4. After about 2 seconds, the restore is apparently complete (but of course unlikely with 32GB of data)

5. Windows Explore shows my RR folder now has all the folders, but none of the folders actually contain any files.


I’m at a loss to work this out. I have tried this about 5 times now with the same result.


Can anybody please help me?



Link to comment
Share on other sites

  • 3 weeks later...

Wow - the lack of assistance that this forum was able to provide is telling in itself...


Lessons for me:

1. Don't use backup software that locks up your data in a proprietary format, effectively locking away the data you own in a format that requires you to purchase software to unlock it. Why? Companies can change hands; products are frequently superseded or no longer supported, and users of older software versions may find support for their product is no longer available or no longer a priority. The upshot? Locking away your data in a proprietary backup format can introduce significant risk to your data risk management.

2. Use a backup software product that copies your data in a way that is readable from Windows Explore. This will simplify your file recovery if, for some reason, you cannot reinstall the backup software that created your backups. My new backup solution includes the software on the external HDD and doesn't require a licence key to activate it, and all the backed up data is readable on the external HDD directly from Windows Explore minimising the risk :)


Despite the complete lack of support on this forum, I managed to recover most of the data from my Restrospect backup. But not without angst and not without having to try and understand how this product works, what it needs to recover files, etc. In my mind at least, this is a lot of effort to go through to get to a pretty straightforward point - recovering my data. I for one have well and truly learnt my lessons from this experience...


Control Panel ==> Add/Remove Programs ==> Uninstall


Topic closed.

Link to comment
Share on other sites

Wow - the lack of assistance that this forum was able to provide is telling in itself...


I would suggest that more patience is required. For example, this is my first visit to the new forum this year. I have been active in the Retrospect forums over the years and have found that most forum members do not visit every day.


The other forum-related point is that, since you consider the recovery method important and have found a method, you should share this method with the forum. That is the purpose of the forum.

Link to comment
Share on other sites

Fair comment xz4gb8, but I challenge you to find anyone to remain patient who has a lot of valuable data that suddenly only exists in one place when before it was two, and then be unable to recover that data and be very uncertain as to whether it is retrievable at all. Hence my point - it should be a pretty straightforward process to recover my data - or so I thought. Two weeks since I posted there has still been no solution offered. Good thing this wasn't critical data for a SME...


Anyway, after attempting to contact the USA (which is not where I reside), sending emails to a support link on a Retrospect website that to this day remain unanswered, following links in the product to purchase another licence that directed me to disused websites with no functionality, posting on this forum and its predecessor (both of which resulted in no solution being offered), driving around to various retail stores to see if I could purchase another version of Restrospect (which I was unable to do), and finally contacting forensic computer examiners for quotes on a full HDD data retrieval, it turns out that a rebuild of the catalog using the trial version of Retrospect 7.7 was the solution. To be fair then this forum was a help - since rebuilding the catalog seemed to be a common solution to a variety of problems - but none of the issues I saw while trawling through hundreds of posts were the same as the one I was experiencing so in that respect it was a punt to see if it would work.


Anyway, the lessons I learned from the experience make it very unlikely I will ever be in this situation again.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...