Jump to content

error 1018 - trouble reading files/not enough memory


Recommended Posts

When backing up the Exchange Information Store I'm receiving the error:


Trouble reading files error -1018 (not enough memory).


The server is running Exchange 2003, sp1 on Windows 2003 sp1. It has 1 GB RAM. The information store is about 23GB. I can back up the information store with NT Backup. The information store data files are on the d drive and the log files are on the e drive.


This problem has been going on for a long time on this server, and was being worked around by using NT Backup, but I want to stop doing that. Last week I upgraded from the 6.5 version of Retrospect to the 7.0 on the backup server. I pushed out the clients to upgrade the Retrospect client on the e-mail server, and stopped and restarted the retrospect client service, though I didn't reboot the entire server. I still receive the same error.


Any advice? Looking at the logs, it's been doing this since the information store was about 14GB.

Link to comment
Share on other sites

Yes, we do have the Exchange add on. The backup sets are going to tape. This has happened with multiple backup sets, though they're set up the same way.


On the backup sets:

Options are set to: Don't compress catalog, Fast catalog rebuild. Media action is normal.


I'll try creating a backup set to go to a file, see what happens and report back.

Link to comment
Share on other sites

Okay, I did the backup to file on the server and received the same error. Since I could watch the back up this time though, it seems that the error is with verification. I left verification turned on for the test, since it's turned on in our nightly backup of multiple servers. I hadn't considered verification as the error before, because of the location of the error in the log (it looks like the first thing it did was find the error). Also, the log files for Exchange are not being cleared, even though this is a full backup - so the disk fills up unless I run an NTBackup to clear the logs.


Here's the log


2/7/2006 10:10:01 AM: copying First Storage Group on server

2/7/2006 10:10:01 AM: Connected to server

Backup type: Full

Trouble reading files, error -1018 (not enough memory)

2/7/2006 11:22:33 Am: Execution incomplete

Remaining: 1 files, 28.0 GB

Completed 2 files, 28.0 GB

Performance 395.3 MB/minute

Duration 01:12:31 (00:00:06 idle/loading/preparing).



1) Assuming my verification theory is correct, can I turn off Verification for just one volume in a backup set, or would I have to make multiple backup sets?

2) Why aren't the transaction logs clearing, when the Exchange options are set to do a full backup.


Thanks for any insight! I could almost live with making a file backup of the information store, before the backup of the server to tape, if the logs were actually being cleared. I can't say I'd be happy about it, but at least it'd be more maintainable then the current situation.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...