Jump to content

Retrospect client locks up server during backup

Recommended Posts

I used to run Retrospect 6.5 from my main server that doubles as Exchange server and a file server. Backups would bog down that server however, so I when I upgraded to Retrospect 7, I also moved Retrospect to another computer (running XP sp2). I did some backups and all seemed quite well.


The past week however, I have not been able to complete a backup of the main server. The server invariably locks up SOLID (power off REQUIRED - no access to start menu or task manager) during the backup: sometimes immediately, sometimes halfway through copy, sometimes during snapshot creation, sometimes just as verify begins. I have been tearing my hair out trying to solve this problem. Even more frustrating for me, it is not COMPLETELY consistent. Sometimes I can select a small set of data (say make a 1 GB folder a volume), and that will backup just fine. Other times, it will lock up even on a small set.


I hardly know what facts to list that might show what I might be doing wrong. It baffles me completely. The only thing I did differently this week is to install another SATA drive for d2d backups in the backup station, and move it to another table (ahah!). Crap.


Could be hardware, but why can I run this server 24/7 using it for exchange and file serving and never wavers at all, and yet if R7 backup is attempted, it crashes. I can back up my other servers just fine, but this one is a mystery.


Lock ups occur attempting d2d OR tape, full OR incremental. I tried retreating to the 6.5 client (same R7 server), but that locked up too.




XP sp2

3 ghz Pentium D

4GB ram

Retrospect 7.0.326 MultiServer w/update

SATA drives

LSI Logic scsi to a Sony LIB-D81 (sdx 700c) AIT-3 tape drive




Dual Xeon 3Ghz

4GB ram

Raid-5 Scsi (adaptec 2120S, circa 500 GB)

Windows Server 2003 sp1

Enterprise exchange

File server

With EITHER R7.0.107 client or R6.5.136 client


Looking at graphs of memory used and CPU percentage for this server, neither gets above 60% on the server until lock up. CPU is usually around 15% during backups. I can still ping the server when it is locked up, but that is pretty meaningless (ok, the teamed network cards work).


I have not installed any new software or hardware in this server. In troubleshooting this issue, I have tried swapping out memory anyway (I have spare dimms), I tried uninstalling unessential software, and I am just clueless what to try next. I just messed with memory settings which is silly.


Well, I guess next I move Retrospect BACK to this server and see if R7 will run in a bogged down fashion again from this server. That is not very appealing, but I guess that is my next stop.


Any BETTER ideas???

Link to comment
Share on other sites



If I were you I'd try changing the settings under the backup options, I'd start by deselecting Multi-volume datasets and test it and then try without open file backup and see if that works or not. The open file backup could be causing the problem I guess if the disk activity threshold is too high (maybe reduce it to 1,000 and see how it goes). I'm not a retrospect expert though so I may be way off the mark.



Link to comment
Share on other sites

Thanks, but I tried with and without OFO and it made no difference. I spent ALL weekend fighting this SOB, but without success (not that it makes me grumpy...). The delicious irony is that the server runs all day just fine, and steadfastly refuses to run a backup. Although it did lock up once (Dec 13th) when I don't THINK there was any backup activity.


Lockups occur EVERY TIME when doing a backup of this server that takes longer than 30 minutes. Lockups occur at different points in said backup, but most frequently during snapshot creation.


Things that work fine

1) Backing up any of the other servers (3) in the office

2) Running ANY program except some form of Retrospect backup on this server

3) backing up small directories on this server



1) Running backup disk to disk

2) Running backup to tape

3) Swapping memory chips in server

4) Running R7 over network vs running R7 at server

5) Swapping network controllers in server

6) Using either Retrospect 6.5 client or Retrospect 7.0 client

7) Removing all non-essential software off of server

8) turning off open file option in backup routine

9) running CHKDSK on reboot on all drives in this server


Any of the above offer clues that I am missing? All the server's Event viewers in windows are devoid of errors at times of reboot, except to note (after I power off and back on) that the previous restart was unexpected.



1) Going back to R6.5 as the base application (I have tried the client) on the server that is locking up

2) another backup program

3) ordering and testing a new motherboard

4) swapping out the raid array card - I think this requires completely rebuilding the array, which means I need it backed up first, since a complete rebuild destroys all data in the array... well, I think.

5) doing a backup without a snapshot.


Precautions being taken

1) using Take Command's (great shell) copy command to move any recently modified files on to a different disk in another server with similar directory structure. Still need to set this up to run every night, and this does NOT backup Exchange.

2) ordered a 1 TB external drive and will attempt to use the crude Windows built-in backup routine on Tuesday night or perhaps a trial version of Backup Exec (hey, I really need a backup) to get a backup of this server somewhere.


I guess I will try NEXT going BACK to R6.5 tonight (with 25 or so employees using this server continually, I can't test anything except nights and weekends). If THAT works, then this is a software problem, and I need to have a little chat with Dantz support. If that doesn't work, then this is a hardware problem and I will call up the mfr and get them to ship me another motherboard.


Anyone wants to critique this, or just SHOOT me, please do.....

Link to comment
Share on other sites

I swapped out the motherboard and cpu's last night, and Retrospect 6.5 locked up trying a backup. I removed 6.5 and when to R7 and that locked up trying to do a backup (end of snapshot).


I uninstalled the last 60 days of Windows Server 2003 Service Packs..... and R7 locked up AGAIN during a snapshot....


I installed a 60 day trial version of Backup Exec 10 and that worked just flawlessly. But I don't like that program (I used BE7,8,9 for years).


How in blue blazes did I screw up something (registry???) that ONLY affects Retrospect!!!!


ARGHHHHHHHH. I guess I can reformat drive C and START over with windows server frown.gif

Link to comment
Share on other sites

Ok, today I got an identical LOCKUP using Backup Exec's trial version. This ain't software.


In addition, for the first time, I got a Blue Screen of Death!! yeah, an error message. Chasing down the error message, it looks like I have a bad array OR a bad raid controller card. The one thing I did not replace, as replacement risks losing the array, but gotta do what I gotta do.


Thank you for lurking....

Link to comment
Share on other sites

  • 2 weeks later...

Attention lurkers....


Turns out the issue was the controller card . I replaced the Adaptec 2120S scsi raid card (which has some cache soldered into the pcb I believe) with a new, identical model and the Retrospect backup has worked for about a week. So, I guess that was it. And yes, I had tried different drivers first with the old card.


The old array card had the battery backup option, and I did NOT test to see if this was some kind of weird glitch related to that. I installed a new card with no battery (just to keep it simple). I really hate replacing raid array cards, since I am then counting on Adaptec's promise to recognize the "foreign" array, and risk losing the entire array (which as you may remember is not very well backed up). Anyway, Adaptec swears this works great if you replace with the exact same model card, and it worked smoothly. Not sure what you would do if that card was no longer made, and hence you could not order it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...