Jump to content
Sign in to follow this  
mmcleary

Linux Client and ipchains

Recommended Posts

Hi Guys,

 

 

 

The Linux client on my server appears to be running ... it appears on the network, but Retrospect won't connect to it.

 

 

 

It was working fine yesterday morning then last night I set up a firewall configuration with ipchains and now its not happening.

 

 

 

ipchains was already install ... just not configured so I really haven't installed anything. My rules only impact on my external interface so Retrospect shouldn't be affected ... but it is.

 

 

 

Even if I turn off my firewall rules, Retrospect is not happy.

 

 

 

Anyone experienced a compatibility issue between the Retrospect Linux client and ipchains?

 

 

 

Cheers, Malcolm

Share this post


Link to post
Share on other sites

Hi Guys,

 

 

 

I've got the client going again, but the solution is not good.

 

 

 

My Linux server has two NICs, but I've only been using eth0. When I was setting up ipchains I activated eth1 by assigning it an IP address. Now by deactivating eth1 and stopping and starting the Retrospect client all is well again.

 

 

 

I only want the client to work on eth0, but when both NICs are active it appears to be visible on eth0 but it doesn't work.

 

 

 

How do I force the client to only work on my primary NIC?

 

 

 

Cheers, Malcolm

Share this post


Link to post
Share on other sites

Hi Guys,

 

 

 

Looks like I need to start the client as follows ...

 

 

 

/usr/local/dantz/client/retroclient -ip x.x.x.x -daemon

 

 

 

to get it to bind to a specific IP of a NIC.

 

 

 

The default condition is to bind to all IPs, but that is not working on my machines.

 

 

 

All I need to do now is modify the start up process so that it always binds to the IP on eth0.

 

 

 

Cheers, Malcolm

Share this post


Link to post
Share on other sites

So far I havent had any trouble. Stopping IPchains or adjusting the firewall rules to allow UPD and TCP on port 497 should do it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×