Jump to content

Can't set up client


Recommended Posts

First time user of this forum.




I just upgraded from 6.o professional to 6.5 professional. Now I can't set up a client. I am running Retrospect on Windows XP Pro OS, the client is Windows 2000. When I try and add the client, it just sits there with "searching for backup cliets...". When I run the test and enter the address, it finds the computer.




More details... I am running a very small network at home office. 2 computers comunicate through a switch (NetGear).




Please go through all the settings needed of each machine in order for me to set up the Client. THANK YOU???!!! eric

Link to comment
Share on other sites

  • 1 month later...

There seem to be a few similar posts to this, I have the same problem:


I have just upgraded from retrospect professional 6.5.336 to 6.5.350


I had one client already listed from the 6.5.336 and this works fine for connection etc.


I want to add a new client as i have one remaining license in the manager


Both retrospect profession and client are running on Windows XP + Sp2.

Firewall has been disabled on both machines (and restarted).


If i try to add a new client it just hangs with: "searching for backup clients..".

does not even find the existing listed Client, that functions OK for backup.


Under retrospect "Add clients" I can click test, enter the IP and the new client is reported but I cannot add it!


I do not have dual NIC,unless you count the firewire interfaces on both machines, but i have disabled Networking over the firewire cards that are on both machines.


I have tried the winxp "repair" option for the network connection.


Is there any other way people can suggest as a means of getting my new client recognised?

I am loathe to deinstall my netwrok driver just i case it messes up my recognition of the existing client.

many thanks, Dan

Link to comment
Share on other sites

> Both retrospect profession and client are running on Windows XP + Sp2.

Firewall has been disabled on both machines (and restarted).


Does this mean you tried with the the firewall intregrated in XP (and enabled by default, with a new GUI, in SP2) turned both off and on? If not, would you try turing off the firewall on both machines (running Retro + Retro Client) to see if it's firewall that's blocking access.


The Retro Client is supposed to "register" itself with the SP2 firewall but it might depend on install vs. upgrade order. And I'm not sure what's required on the server machine (post or pre SP2 update. You didn't mention if the SP2 update was recent or before or after the Retro installs).


Can you ping the clients directly? I assume you can since you mention that using the direct IP method allows you to see (but not add) the client.


I'm running Retro Multi-Server 6.5.350 from a W2K Server machine (so no firewall) and Clients (6.5.136) from XP SP1 and XP SP2 machines all over a 100M/10M wired LAN, but with the firewall disabled on all Client machines. They're all in the same subnet/broadcast domain (10.25.24.x, So far I haven't had a problem seeing or adding all clients.

Link to comment
Share on other sites

Yes I have tried with SP2 firewall off on both machines simulataneously.


I have also checked that the firewall settings are configured correctly on both machines

as per KB article:




and tried switching the firewall back on with both machines.


I can ping the machines OK and they are on the same subnet. I can even get the response from the client using the test method by entering either the clients computer name or the ip address. I just can't add it.


It makes me wonder why retrospect bothered to include the test button in the first place if you can't do anything with the information you get back from it!


The client is active under services, but was installed after the SP2 install.


The retrospect pro update was also installed after the SP2 install.

I have made sure the "local area connection" is searched first in "adapters and bindings " connections search order in win XP.


I'll try uninstalling and reinstalling the client again, although i suspect the problem lies with the machine on which retrospect pro is installed on. If i ever solve it i'll post what the cure was!

Link to comment
Share on other sites

I solved it! A new router had been installed between when I registered the first client and when i tried to add the second client.


I got around it by physically moving the computer onto a different hub, then bound and added the second client. I then moved the computer back again and it seems to work fine even with the second client.


Seems like everthing else was a red herring...this problem seems to be very common. Its a shame Dantz don't produce an advanced troubleshooting guide for this particular problem including info on using netstat and netsh commands etc to narrow down the fault.

Link to comment
Share on other sites

I assume that the router was blocking broadcasts (e.g. used by the Piton system Retrospect uses) which would have been the root problem.


However, just out of curiosity, were the two machines (Retro server and Retro client) in the same subdomain (e.g. 192.168.1.x/ IPs but same subnet mask) after the router was added? This might be a quick way to deterime the cause (for myself or others who see this in the future).


Also, did the router have the option to enable/disable broadcasts (all or of certain types)?

Link to comment
Share on other sites

yes, sorry slight confusion on the terminology.

the two machines were on the same subdomain and same subnet mask, Just different IP numbers (192.168.10.x and y) respectively.


layout was similar to below:













The new switch1 and upstream router were added recently.

the two machines were on the same subdomain, same subnet mask, after the router/switch1 was added. I don't have much more info on the router/firewall, But Switch 1 should be open to all internal traffic.


Client 1 was bound and OK, prior to switch replacement

But both clients were not being recognised on searching for new clients.

I moved Client 2 to switch 2 (Netgear FS105 switch) and it was spotted immediately, and i was able to "add" it.


I then moved it back onto switch 1 and it was able to communicate OK now it was bound.

Hope it helps someone else!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...