Jump to content

OWC Neptune not seen by Retrospect 5.1

Recommended Posts

Just spent the entire day trying to get my brand-new copy of Retrospect 5.1.177 to work with my recently-new Other World Computing Neptune “Value Done Right” 52 X 32 X 52 external FireWire CD-RW drive.



* Power Mac 9600/350, 160 MB RAM, VM Off

* OS 9.1

* OWC Mercury FW400 4-port PCI FireWire card

(Information on the 3 other installed PCI cards available by request; i doubt that they are involved)

* OWC Neptune “Value Done Right” 52 X 32 X 52 external FireWire CD-RW drive with Lite-On LTR-52327S mechanism with firmware version QS54 / MMC-3. I am told that this drive uses the Oxford 911 chipset, though i have been unable to verify this.

* Extensions as described below

* Retrospect 5.1.177 freshly installed, with selectors etc. copied from previous Retrospect 4.3



Retrospect fails to see the OWC Neptune drive. Note: Toast Titanium 5.2.1 has no problem seeing the OWC Neptune, and can write to it and read from it just fine. Apple CD Audio Player works with the Neptune just fine. Via the Toast CD Reader driver, Mac OS 9.1 can use the Neptune as a standard CD-ROM drive with no problems whatsoever.


Attempts to solve, so far

* Extensive RTFM: read the enclosed paper and PDF documentation for Retrospect 5.1.177

* Spent several hours on the Dantz Knowledgebase (good stuff, yet didn’t address my question)

* Checked the OWC knowledgebase: nothing relevant found

* Tried various combinations of starting the Neptune: power on before OS startup, power off until OS startup complete, FW disconnected until OS startup complete & Neptune powered-up & stable, then hot-plugged. No differences between these methods.

* Extension Conflict Elimination: Chose OS 9.1 All set, duplicated, and added back the Retrospect 5 and Toast 5 extensions.

3rd. party (non-Apple; includes Dantz extensions) and Apple FireWire extensions currently enabled are as follows:


* 9 ATI extensions and control panels related to the installed Radeon 7000 PCI video card

* DiskWarrior extension 2.1.1

* DMI FW Tape Driver 1.1.3

* FireWire Enabler 2.8.5

* FireWire Support 2.8.5

* MacsBug 6.6.3

* Retro.Startup 5.1.175

* Imation FW Tape Driver 1.1.2

* Indigita FW Tape Driver 1.1.2

* Retro SCM FireWire SCSI Driver 1.1.2

* Spressa iLink CD-RW Driver 1.1.2

* Stuffit Engine 6.5.1

* Toast CD Reader 5.2.1

* Toast FireWire Support 1.0.8


Note: Toast Titanium 5.2.1 etc. as listed above work just dandy with the OWC Neptune and this extension set (and they work with less restrictive extension sets, as well). Identical results (Neptune works with Toast, fails to be seen by Retrospect) obtained whether Apple’s FireWire Authoring Support extension 1.1.2 was active or disabled.


Other Thoughts

The Extension Manager information for the Retrospect 5 extensions (Imation, Indigita, etc.) all mention the existence of, and need for, a Retrospect Firewire Support extension. The Retrospect 5 documentation (somewhere) mentioned that FireWire support is self-contained within Retrospect 5.1. Which is it? Do i need a Retrospect Firewire Support extension, which the Retrospect Easy Install failed to install? Or is the Extensions Manager text obsolete?


The Retrospect 5.1 Device Status window correctly lists the 9600/350’s internal and external SCSI busses and their contents. Sometimes, not always, it also lists what appears to be a third SCSI bus (IDs 2:0 to 2:6), even though there has never been an add-on SCSI card in this machine (nor an ATA card)... just the FireWire and the (currently disabled) USB cards. How are FireWire devices supposed to be displayed, inside Retrospect, in the Device Status window?


Looking forward to finding a solution to this problem, and getting some nice, reliable, Retrospect backups done smile.gif.



Link to comment
Share on other sites

  • 2 weeks later...

Part of the problem has been solved. Retrospect 5.1 can now see the Lite-On mechanism in the OWC Neptune, and create a profile for it.


The problem was imperfect extension conflict elimination on my part. There is an extension installed by DragonBurn, bundled with the OWC Neptune, called FWSBP2CDRDriver. This extension causes a conflict which prevents Retrospect 5.1 from seeing the Neptune FireWire drive, even though both Toast and DragonBurn can see and work with the drive just fine.


This is now an issue with OWC, not Dantz, though how Dantz expects every FireWire CD-RW drive owner to own Toast is beyond me… bundle those extensions, folks!


The issue of my media rejection errors belongs in another forum… Dear Dantz, all is still not well!


More if the situation warrants,



Still in Retrospect Hell, but that’s for another forum section.

Link to comment
Share on other sites

  • 2 weeks later...

Wait, there’s more…


I have no idea how i missed this working combination, which i am sure i have tried before. In any event, Retrospect 5.1 Desktop does work on OS 9.1 or 9.2.2 (OS 9 Helper-patched) withOUT needing Toast extensions. Here is the absolue rock-bottom list of extensions needed to make Retrospect Desktop 5.1.177 on a Power Mac 9600/350 with an OWC Neptune CD-RW drive with 52X32X52 Lite-On mechanism be able to see the drive in the Devices list:


  • CarbonLib 1.5 or 1.6*
  • FireWire Authoring Support 1.1.2
  • FireWire Enabler (2.7 with OS 9.1 and 2.8.5 patched with OS 9.2.2. Other combos may also work)
  • FireWire Support (2.7 with OS 9.1 and 2.8.5 patched with OS 9.2.2. Other combos may also work)
  • QuickTime 6.0.3 or 4.1.2 (other versions probably also work)*
  • QuickTime Power Plug 6.0.3 or 4.1.2 (other versions probably also work)*
  • Retrospect FireWire Support 1.1.2
  • Retrospect SDAP Support 1.2
  • Text Encoding Converter 1.6


This list assumes one is looking inside the Extensions folder. Many items are never listed in the Extensions Manager.

* If CarbonLib 1.6 is used, the QuickTime extensions are needed, otherwise Retrospect complains about a missing library. If CarbonLib 1.5 is used, the QuickTime extensions may also be omitted.


I really, really, really thought i had tested this combination before. Apparently not… or else something else is going on. Zapping PRAM, trying various drive power-up sequences, and total shut down/startups made no change.


Hopefully no one else will have this problem. Thanks go to Dantz for providing this forum, and OWC Tech. Support for sticking with me until the problem was solved.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...