Jump to content

How I got a Linux client to backup to my Mac (PB)


Recommended Posts

This is mostly an informational post, as I worked through the problem and came to a satisfactory solution for myself. I am posting this in hopes it may help others.


I set up Retrospect to backup my RedHat 7.3 box (6.5.108 client) to DVD on my PowerBook (Desktop 5.1.175). I was backing up fine over AirPort with my AEBS configured as a bridge. I was also backing up an iBook over Airport.


Then, I enabled NAT on the AEBS. Backups still worked from the iBook, but not from the Linux box. Figuring my AEBS was blocking the communication (I later verified this), I attempted plugging my PowerBook into the ethernet. It didn't work. I could ping, telnet, etc. and they were on the same subnet, but Retrospect would not backup the Linux box.


So, naturally, I removed the client from the Backup Client list in the Desktop, then tried to add it back. It could not find it.


I tried quitting and restarting the server and the client, removing /var/log/retroclient.state, and even reinstalling the client. Nothing. I used tcpdump to show that the Linux box was getting the multicast packets from the Desktop, but was not sending anything back. Then, I noticed it was trying to send a responses to the AirPort IP address, but ONLY when AirPort was "On." When AirPort was "Off" on my PB, absolutely nothing was sent back.


I reconfigured my AEBS as a bridge and now it sees the Linux client and I am backing up over ethernet. However, it still only works if my AirPort is "On" even though it backs up over ethernet.


I'm wondering if the multicast packet the Desktop sends out indicates what IP the client should respond to. Perhaps the Desktop had an old idea of what the correct IP is, and was setting this erroneously to the AirPort interface's IP address. Maybe deleting the Retrospect Desktop preferences or reinstalling the Desktop would have removed whatever state would be causing that, but I didn't try.


Further testing with tcpdump shows that the IP address of the AirPort interface is in fact sent in the multicast packet. No matter what I set the IP to, that's what gets sent. If AirPort is "Off" then gets sent.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...