Jump to content

What is the hidden option, Disable Fast and Wide SCSI, for?

Recommended Posts

My DAT drive worked fine under OS X 10.1.5. Under Jaguar I would get kernel panics. I switched from an Adaptec card to an ATTO card, and everything worked. Until Jaguar 10.2.8. Then using the tape drive would work only if it was normally off and I did a restart with it on. After the backup was finished, if I did not do a restart with the DAT turned off, within a few hours I would freeze solid.


Now, under Panther 10.3.1, even with ATTO's latest update, usage of the DATA drive is again highly problematic. Basically the backup stalls, usually while writing but sometimes while scanning. A force-quit of Retrospect seems to work, but it really doesn't, and I can only only do a hardware restart.


Now I notice that there is a hidden option in Retrospect 5.1: Disable Fast and Wide SCSI. What is this option for? It sounds like it might just be the ticket for me, and I'm going to try it at my next backup, but it would be nice if someone would it explain it to be before I do.



Link to comment
Share on other sites

Retrospect supports sync/wide negotiation for higher performance drives to enable better performance when connected to a fast or wide SCSI card on a fast computer. This allows data to be streamed quicker to supported drives. Disabling this feature will slow down data transfer.


The bigger issue is trying to fix the problem causing the hangs and kernal panics. Slowing down the transfer may fix the issue, but it's not necessarily the best solution.


Please see the following link for relevant OS X SCSI troubleshooting:



Also, make sure you check with the SCSI card vendor and the tape drive vendor to ensure you have the latest firmware and/or driver updates. Make sure your SCSI card adapter is supported in Panther by the vendor. Panther’s SCSI changes could additionally affect Retrospect’s ability to communicate with certain tape drives, autoloaders, and libraries.

Link to comment
Share on other sites

Thanks for responding, AmiJ. Unfortunately I have, as they say, been there - done that.


A fully operation solution for me, since I have an older machine (B&W G3 400), has been to install OS X 10.1.5 on an available hard drive and use that drive as the startup drive for a backup using my SCSI DAT drive.


Under OS X 10.1.5, OS X, Retrospect, ATTOExpressPCI, APS(Sony) DAT drive work together without a hiccup.


Under OS X 10.2.x, they will work together long enough after a restart to do a backup, but ultimately the machine will freeze.


Under OS X 10.3.x, there is no way to get them to work long enough to do a backup. Backups will appear to proceed trouble free and will then stall in such a way that Retrospect cannot be force-quit and I can only do a hardware restart.


Of course, firmware, drivers, etc are all as supposedly required for the respective systems.


So exactly what is responsible for the degradation of my SCSI connection to my DAT drive as OS X evolves remains a mystery.


Link to comment
Share on other sites

We have been having successively greater problems as Mac OS X is revved also.




10.1 - No problems beyond known retrospect bugs


10.2 - Kernel panics, odd crashes and freezes, poor performance***


10.3 - Cannot perform any backups without a kernel panic.




Our backup server has been upgraded to 10.3.1 and we now get consistent kernel panics whenever a backup is run. We are using an ATTO ExpressPCI PSCd adapter. Here is the panic.log:






panic(cpu 0): IOGMD: not wired for getPhysicalSegment()


Latest stack backtrace for cpu 0:




0x000833B8 0x0008389C 0x0001ED8C 0x00263D0C 0x00263F28 0x00263B84 0x00670D5C 0x006710F0


0x0038D8C4 0x0038DA84 0x0063951C 0x0038D6A0 0x0038DC40 0x0066E4BC 0x00277A90 0x0007B65C


0x00021650 0x0001BCD0 0x0001C0D8 0x00093D58 0x00000000


Kernel loadable modules in backtrace (with dependencies):




dependency: com.apple.iokit.IOStorageFamily(1.3.1)@0x57e000


dependency: com.apple.iokit.IOSCSIArchitectureModelFamily(1.3.0)@0x386000




dependency: com.apple.iokit.IOSCSIArchitectureModelFamily(1.3.0)@0x386000




Proceeding back via exception chain:


Exception state (sv=0x142B0780)


PC=0x900075C8; MSR=0x0000F030; DAR=0xE40DAE60; DSISR=0x42000000; LR=0x90007118; R1=0xBFFF9900; XCP=0x00000030 (0xC00 - System call)




Kernel version:


Darwin Kernel Version 7.0.0:


Wed Sep 24 15:48:39 PDT 2003; root:xnu/xnu-517.obj~1/RELEASE_PPC






*** The kernel panics in 10.2 were related to an apparently bad Adaptec SCSI card that was bundled with the machine by apple. Replacing it with an identical card from another machine fixed (at least) the kernel panics.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...