Jump to content

Retrospect Express 7.6 doesn't restore Windows XP SP3


Recommended Posts

I have Windows XP Pro SP3 (with all current updates) running on an HP/Compaq DX2250 system. We have a 1TB Iomega Prestige external USB drive for backups. We have the OEM version of Retrospect Express 7.6 installed. Backups are running fine with no errors reported. Although the system was delivered with Win XP Pro SP2, I have a valid Pro SP3 CD kit, and I'm using the i386 folder from that kit to prepare my disaster recovery disk (instead of "slipstreaming" the SP3 bits into my SP2 i386 directory on my system disk). I follow a "ping-pong" backup strategy with an "A" and a "B" backup set, alternating between the two sets, and recycling one of the two sets on a weekly basis, so each set is reset every other week. I do nightly incremental saves to alternating sets. So I usually have two weeks of snapshots to work with, and files are around for about two weeks.


I have a couple of "spare" SATA hard drives that I have been using to try to assure that I can do a system restore using the Disaster Recovery disk and my backups.


Everything seems to work fine up to the point at which the system is rebooted after finishing up the restore. In over a dozen tests, I've seen the system actually come up in Windows allowing me to log in and let the process complete only two times. In most of the tests, Windows starts up, gets to the point where it displays a Windows XP Pro "flash" screen and then just sits there, never displaying the "Windows is starting up..." message and never displaying the administrator login opportunity.


Also, during a normal boot and when the process has succeeded, there is an HP vendor splash screen displayed early in the startup, when it fails, that isn't displayed at all. Rebooting doesn't resolve the problem and booting in "safe mode" gives the same results (but with VGA graphics).


I have no idea why it works sometimes, but it has worked twice. Either I am doing something wrong or the procedure simply does not work reliably. I have opened a support case on the web site, but so far I have received no useful advice, in spite of providing lots of incremental information.


I do wonder if there is some race between Norton Internet Security 2011 and the Retrospect restore that is causing this to fail.


Needless to say, I am concerned that if I needed to really do a disaster recovery, it would never succeed. I am especially concerned because we have several systems and use Retrospect for all of our backups.


I really need some help here. I hope someone from EMC / Roxio / Retrospect management will be responsive and help get this resolved.

Link to comment
Share on other sites

I really need some help here. I hope someone from EMC / Roxio / Retrospect management will be responsive and help get this resolved.

You are aware that these forums are user-to-user support, aren't you? That's explained in the Forum Rules.


I don't use the "Express" version of Retrospect, so I'm not able to offer any suggestions on your problem.



Link to comment
Share on other sites

Thanks, Russ, I am aware of the forum charter, but I also know that sometimes "management" pays attention to the forums and helps make sure that the "formal" support mechanisms are working. I have an open case for this problem, and so far I have been asked for more information (which I did provide) but have received NO useful suggestions on how to resolve the problem.

Link to comment
Share on other sites

  • 2 weeks later...

I finally figured this out on my own, no help from Retrospect Support, other than encouraging me to upgrade to Retrospect 7.7 Professional.


I downloaded the 7.7 trial, but it doesn't provide access to the Emergency Recovery CD ISO so you can't actually try the 7.7 recovery procedure. So I bought a 7.7 license, since I knew I could get my money back if it didn't work. That allowed me to test the new 7.7 Emergency Recovery procedure. It really is a better approach (it's hosted on Microsoft's WinPE platform, so it boots into memory and uses real Microsoft tools to prepare the target disk for the restored software). I do like it, but... it behaved EXACTLY the same as Retrospect Express 7.6 once I had restored my backup -- Windows got to exactly the same place in the initial boot and then got "hung" in exactly the same way.


To make a long story short, the problem was all in Windows' intended behavior together with the fact I tried to restore onto a disk that had been "visible" to Windows (partitioned and set up with a formatted file system that happened to be empty of useful data) at the time I had done my backups.


http://www.wilderssecurity.com/showthread.php?t=210322 provides an excellent overview of exactly what I was seeing and the root causes.


I removed the partition and file systems from the disk I planned to use for the recovery testing, then shut down Windows and physically uncabled the disk, then rebooted and did a fresh backup. Then I shut down, disconnected my "good" working disk and hooked up the test disk, and booted into the Emergency Recovery environment. I used the tools to setup my disk, installing a partition and then creating a file system. It initially wanted to call my new boot disk "E" and this made my first restore fail to configure properly; it also never offered a chance to make the disk bootable, and in fact it was not, I had to work around this initially with Paragon Software's free Rescue Kit CD which would boot me into Windows although I could not get it to repair the bootability issues. I fixed the "drive E" issue by redoing the restore once I rebooted into the Emergency Recovery environment and reformatted the disk. Then it booted correctly, but only by using the Rescue Kit, I eventually got out my Windows XP Pro SP3 installation CD and used it to get into the repair environment where I was able to run fixmbr and fixboot and fix the bootability of my restored disk. Then things worked fine.


It should NOT have been this hard. I was able to get it all working but I got zero useful help from Retrospect Support, other than encouraging me to buy the Retrospect 7.7 Professional kit.


Note that through this all I have had an open support case, which I updated today with most of the same information I've provided here. It has been close to a month since I initially asked for help with this problem. No one from the support team ever provided any useful support, other than to claim they are not responsible for supporting Retrospect Express, which is still being offered by EMC's Iomega as part of their disk product offerings. Plenty of finger pointing with Iomega saying Roxio/Sonic does the software support and Roxio/Sonic saying they do not do support. Not customer friendly. Still a good product.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...