Jump to content

Retrospect 7.7 hangs under Windows 7 64bit


Recommended Posts


formely I worked with Retrospect 7.6 Express under Vista OS. No problems at all.

I run now Windows 7 64bit and Retrospect 7.6 Express didin't work properly anymore. So I bought Retrospect 7.7 and installed the most recent version: 7.7.208(64bit) and the driver update and hot fix: version

When I make a immediate back up, after a while Retrospect makes my complete system hang :question: .

Win 7 64bit

External Drive: Iomega 750GB MDHD750-S


Link to comment
Share on other sites

Hello bfish,


How far into the backup does the hang occur? Are there any asserts or errors in the log?


How severe is is the "hang"? Do your mouse and keyboard freeze, or does everything just become unresponsive to clicks?


Finally, what version of win7x64 are you using(i.e Ultimate,Professional,Home)?







Link to comment
Share on other sites

I have exactly the same problem. I too got 7.6 Express with my IOMEGA NAS and liked the software so I upgraded to 7.7 and while I don't find my Vista 64 locks up the Retrospect application just runs at 20% all night and day until I kill the application. (I also don't like that when it is running a script you can't actually see what it is doing it just takes you to the silly monitor screen). I am also running 7.7.208 (64bit).

Link to comment
Share on other sites

Hi Jeff,


I only tried to make a backup on the Iomega ext. drive. I don't have a free partition on my other HD's, so I can't compare.

But before I installed Win7 64bit (Vista), there was no problem at all. I can write to another partition on the Iomega or on the same as where the backup should be saved on. So there is no problem with the Iomega, I assume.

Link to comment
Share on other sites

I have just updated to 7.7.208 also and Retrospect hung trying to restore a V7.6 backup.

I had selected the files/folders to restore and had clicked OK to overrite the existing files in a new location.

I thought is was a version problem, but I tried again later and it started to restore.


Also have a problem with the Restore CD not letting me restore the whole system. That button is greyed out, It will only let me restore files and floders.


I am not impressed with this version of Retrospect and would not be using it if I could avoid it. If it does not improve I will have to use something else.

Link to comment
Share on other sites

Thanks bfish,


I have tried to recreate your issue, but so far I have been unsuccessful. I have upgraded from 7.6 express to 7.7.208x64, performed backups with both versions with no unexpected problems.


Was your Vista operating system also 64bit? Or, are you using the same backup set created with 32bit 7.6 express with 64bit 7.7?




Your first problem may be related to the issue bfish and JTB1965 are having. I am working on trying to find some reproducible steps to simulate the issue.


Your second issue...


Also have a problem with the Restore CD not letting me restore the whole system. That button is greyed out, It will only let me restore files and floders.


I am under the assumption that you are talking about the Emergency Recovery disk. If you are trying to restore a backup of windows 7 that was generated with 7.6, you will not be able to perform a emergency recovery system restore.


Retrospect 7.6 did not include windows 7 compatibility. The backup data must be generated with 7.7 for successful emergency recovery restore, or else it will lack necessary partitioning information used during the emergency recovery restoration process. This only holds true for emergency recovery restores of Windows 7 and Windows Server 2008-R2, normal restores should be OK.


However, if you install a windows 7 "dummy" and perform a live restore much like you would with 7.6, the backup should complete successfully.


After backing up with 7.7, you shouldn't have this problem.


Link to comment
Share on other sites

I purchased a new acer revo computer with Windows 7 installed.

I installed my upgraded Retrospect 7.7 directly (Retrospect 7.6 was not installed).

I then created the Recovery CD and did a backup (using 7.7) to Drive D:

I checked that the backup settings included Back up System State.


Then rebooted from the Recovery CD and choose Restore Locally and Full recovery was greyed out. Could only restore Files and Folders.


==> Failure as a recovery process.

Link to comment
Share on other sites

  • 2 weeks later...

I am having the same problem with retrospect and windows 7 -64 ultimate.


My cpu is intel i7, @ 3 GHz. I have 12 GB of Ram My computer continually hangs when I try to do a normal backup. There is no error reported. There is no information in the log that will tell me what has happened. The size of the incomplete backup file is 62 GB. The full backup would have been 120 GB. However, I have had the hang problem take place with about at 5GB out of a 22GB data back up. I have also had this problem when running a duplicate script.


I am using two external hard drives. Both are western digital Mybooks, but different vintage. One drive is a 500 GB drive the other is a 1 TB, which is new.


I have zone alarm anti virus running.


I have un-installed (removed) a number of applications with no impact. I have un-installed and reinstalled retrospect with no impact. I have disabled some features in start-up (via msconfig)with no impact.


The interface to the external hard drives is USB.


FYI: My next step is to contact tech support on 3/18. I was thrown of by their schedule, and I did not see a mechanism for e-mailing therm.


I am also going to try to see if I can do the back up from one internal hard drive to the other.


In the long run this does not help me, since my goal is to have backups independent of the computer, with one set off site. However, it may help quantify the problem.

Link to comment
Share on other sites

As the proud owner of Windows 7 ULTIMATE, you have the built-in feature named "Create a System Image", which backs up your entire computer to an external hard disk, and which can be restored from by simply booting from the Window 7 DVD and choosing restore.


Does "Create a System Image" work on your computer?

If it too, hangs, then there might some other kind of problem with your computer.

If it gets right through, then there might be a problem with retrospect.


I thought I might also mention that if you perform a "Create System Image" of the same computer to the same disk at a later date, both images are stored on the disk and you can select which image is to be restored from, but they only take up the space of a little more than one image, since it keeps a delta between the images.

Edited by Guest
Link to comment
Share on other sites

[color:red]My problem is solved![/color]


I did extensive diagnostics and found no clue to what was causing the computer to hang when running Retrospect. Although I had updated or confirmed that my drivers were current, I went back through systematically and reevaluated or reloaded each one.


At some point in the process I looked at the JMB36X driver for the JMicron PCIE IDE/SATA controller. After updating this Driver, my problem has not reoccurred.


I have run four full back-ups and three partials as a part of my confirmation process.


Additional Information:


My Motherboard is an ASUS GT6, 1366. In the past I had downloaded the drivers from the ASUS site. On a whim or instinct, I decided to see if the JMicron site had different information. The driver at JMicron was newer than the one at ASUS, so I down loaded and installed it. I had no special insight that this would make a difference. However it did. I have not had a problem since.


Also: although it is subjective, my system appears to run faster, even though I have enabled all but a couple of the start-up modules and services. The Windows diagnostic does not add any insight to this performance observation, since before the driver change my system performance was rated at 7.6 and after, the same. There were no IDE/SATA errors, drive errors or any other kind of error reported that would have suggested looking the IDE/SATA controller driver. In fact, the only errors reported were ones that occurred when I restarted my machine after a lock-up.


In fact, I had no problem Burning or reading Blu-ray disc, I could create a system image disc using windows backup and I could back-up all my data files using Western Digital Smartware software, which came with my external drives. (This of course was not as convenient, as flexible or as integrated a solution as I have with Retrospect)




Thanks for the suggestions. I hope this helps with the other Retrospect hang problems




Edited by Guest
Link to comment
Share on other sites

  • 3 weeks later...

Hello bfish,


Have you checked compatibility?

Just an FYI for you.


It is always best to check with the software manufacturer FIRST. They will tell you if they have tested the product and the version, as well as whether or not it will work with Windows 7.

Check out the Windows 7 Compatibility site: (There you will find out about hardware and software compatibility.)


There is a pulldown from which you can choose "hardware" and "software".


There are also some great articles, instructional videos and such to help with your Windows 7 at our Springboard site:



In any event a lot of the times, Vista drivers will work in lieu of Windows 7 drivers, however, it's not 100%!


As stated previously, it's best to have the Windows 7 certified drivers installed.

Thanks again,

John M.

Microsoft Windows Client Support

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...