Jump to content

Rules-Selecting Users folder without Movies and Music


Recommended Posts

I'd like to define a rule to backup the OSX "Users" folder but not backup the OSX "Movies" and "Music" folders.


First selecting the OSX "Users" folder, in Including


[color:blue]Folder - MacPath - contains - "/Users/"[/color] will select more "Users" folders than needed but since the rule [color:blue]Folder - is - OSX Folder - Users[/color] doesn't work/save this is the best I could come up with.


Then skipping OSX "Movies" and "Music" folder, in Excluding any of

[color:blue]Folder - MacPath - contains - "/Movies/"[/color]

[color:blue]Folder - MacPath - contains - "/Music/"[/color]


What am I doing wrong, my iMovies movies are backed up?


How to specify THE OSX "Users" folder and not all the "Users" folders ?

Same form "Movies" and "Pictures"





Edited by Guest
Link to comment
Share on other sites

Because Retro 8 doesn't do wildcards, I have had to specify the account name in the path, like



Folder Mac Path contains /users/maser/movies/




Folder Mac Path contains /users/chs/movies



What I'd suggest you start with, though, is to just define the "Users" folder on each client as a "Favorite Folder".


And then set up *exclude* rules to specify what you do not want to backup from that folder.


The problem with "Movies" and "Music" is that you have to have explicit knowledge that the user doesn't have any *other folders* with those names.


I get away skipping (most) Music files by not backing up:


Folder Name is iTunes Music


and not worrying about the rest of the files within that folder.


Luckily, most of my clients don't save Movies -- so I only have to explicity give the path to the Movies folder for a handful of clients.


It would be really nice if you could specify /users/*/Movies/


But the program is not there (please chime in on this one in the Product Suggestions thread...)



Not sure if any of the above will help you, but that's what I do with this situation.

Link to comment
Share on other sites



Thanks for your reply.


I would have been pleased with the possibility to select THE OSX "Users" folder (the one containing the /ChS/ folder).

It looks like R8 has this possibility in the rule, but the rule "Folder - is - OSX Folder - Users" does not seems to work.


I'll go manually the "favorite folder" way you suggested (I have > 50 users...)


Then I there a way to select all the "favorite folder" at once?


BTW where is the Product Suggestions thread?





Link to comment
Share on other sites

For the suggestions above, note that it matters whether the source filesystem is case sensitive for names.


BTW where is the Product Suggestions thread?

Retrospect for Mac OS X Product Suggestions forum


I've never seen any of my excellent product suggestions used over the many years. I think that the Product Suggestions forum is a black hole.



Link to comment
Share on other sites


I'll go manually the "favorite folder" way you suggested (I have > 50 users...)


Then I there a way to select all the "favorite folder" at once?






No -- you have to "browse" each client hard disk and manually select it.


You might consider putting a "Tag" on the favorite folder at that point as that will help when building your backup scripts later (as you can then just add the "Tag" to the script -- rather than having to add each individual client source again...)

Link to comment
Share on other sites

I have big problems with excluding rules, too.


Maybe to start with questions – what is the difference between Folder name is and Folder Mac Path is?


I want to exclude iTunes for one user, okay ... Folder Macpath contains /Users/blah/Music/iTunes/ ... right? Or not? Should'n "contains" inherit "is"?


Then the next question occurs – /Users/.../Music/... or /Benutzer/.../Musik/...? What about localization? At the moment I have both exclude rules.


I also set up an exlusion rule that all foldern whose names end with " ø" shall be exluded.


But no, they are not. Better, they are, but only on the second internal harddisk where such folders lay on root level. But on my system disk, where such folders occur in several places, nested, nothing gets exluded.


In RS 6 there were two options, ehm, I only know their German names, something like Folder and Whole Folder (maybe Containing Folder?).


Also I haven't found out how to exlude a "new type" sparseimage that is a package, ergo folder as part of a path.


Error of thinking? Bug?


And this is yet the beginning of my hassle with 8 ...

Link to comment
Share on other sites

You go to System Preferences, select Language & Text

then put Francais or Deutsch before English, logout and login to apply the changes.


It looks like OSX uses the english name for specific folder like "Music" and if you select another language the finder dynamically changes its name to "Musik" or "Musique" before displaying it.


So you should be safe to select Folders using english names.


Also in R8 if you browse Folders you'll see that even the system is in French or German you'll see the name in English plus a .Localized file

Link to comment
Share on other sites

For me, I exclude folders one of two ways:


Folder Mac Path contains /users/maser//




Folder Name is



So, as an example, for all my Mac clients, one of my Exclude section rules is:


Folder Name is iTunes Music


and nobody's iTunes Music folder is backed up.



So my overall rule for my mac clients looks like:


Include files:

Any of the following are true

Saved rule includes All Files Except Cache Files



Exclude files:

Folder Name is (blah)

Folder Name contains (blah)

Folder Mac Path contains (blah)




and that works

Link to comment
Share on other sites

Well, that doesn't work here yet.


I haven't ried thsi interesting include of yours.


But my excludes had been like ...


Folder Mac Path containsTemporary Items (ignored)

Folder Mac Path contains /Users/me/Music/iTunes/ (ignore the machiiiin)

Folder Mac Path contains /Benutzer/ich/Musik/iTunes/ (ignoooored)

Folder Name ends with ø (guess what, ignored)


As to mention some of them.


What am I doing wrong?! Especially two very large folders (iTunes Music and A&M) are together nearly 140 GB that I want to exlude, to put them into another set ...


Maybe the next days I will try it again, who knows ...

But when I try a on-the-fly-script with my rules, e.g. folders ending on ø are excluded on a harddisk that is not concerned! But they are not excluded on THE harddisk I want to backup, the normal system harddisk.

Link to comment
Share on other sites



I use the wizard only to get the possibility of any kind of preview. Am I too dumb or is there no other way to see a preview of a script? I even haven't found out how to dive into a complete (!) backup. Strange thing.


I have several proactive scripts, due to in earlier time RS 6 worked on a "Backup Server G4" and my desktop was a client. My Pro has more power and RS 8 cannot work with G4/400 without me dying, so my main machine backs itself up. And one or tweo clients later on. All proactive.


Cha-oss ...

Link to comment
Share on other sites

I'm assuming the name of this script is "Hochberg"?



(I'm guessing here -- I'm just comparing to mine...)



I know statements like:


Folder Mac Path *is*


do not work if it just has the name of the folder in it (like your "Freeze Files" line.)



What I *don't* know is if having a non-working line in a rule somehow stops other possibly working line from functioning.



Or if "Folder is Trash" is actually the one that doesn't work.


I use:


Folder Name is .Trash



I would probably suggest you make a *new* rule, and add/test things one at a time. It's possible this rule is corrupt beyond what I think might not work and you might start over?

Link to comment
Share on other sites

I'll post my whole ruleset (one ruleset), the only one that gets recognized is the "is trash" ;-) The rest is ignored. They seem to work with folders right in the root level (!).




If you are having trouble attaching files to your posts, see here:

Forum Attachment Rules Change


You may have to get Robin to do some magic on your account so that you can attach files.


But your links show what you see, thanks.


I don't think that any of your "Mac Path is" rules are going to work because there's no leading / . You might experiment a bit with leading and trailing "/" omission/addition for the "Mac Path is" and "Mac Path contains" rules.


I think your two "Temporary Items" rules do it the right way for that type of rule.


At this point, without a manual, it's hard to differentiate bugs from intended behavior.



Link to comment
Share on other sites

No, I had no problems, and I knew about the magic, but I can upload to my own space. I just removed those files again. And I changed my rules a bit ... still experimenting.


If you look at the Mac Pathes of the everything but cache default you see, that there are several without /, too. But I nearly wiped all of mine off and replaced them with Name is and Name contains. Only the iTunes and Virtual Users folders still have a Mac Path contains.


But I don't know when to check ... and how. Again with a manual wizard thing? I guess ...

Link to comment
Share on other sites

There is a *big* difference between paths for "Mac", "Windows" and "Unix" -- you should follow the MacPath examples.


And, apart what you might think -- OSX clients are not *UNIX* clients when it comes to Retrospect 8...



And (from what I remember of your rules) there's a difference between "Folder is " and "Folder Name is ""...

Link to comment
Share on other sites

Well, Folder is Trash worked, it was the only rule that was not ignored. I deleted that rule and some other and composed a new ruleset. I will test this in the near future.


Okay, near future has come, I tested ... and this is what happened:


• First, I made a new Test Set A, to be sure. Disk type.

• I chose my internal first harddisk, fuguratively called Istanbul.

• I then chose the ruleset Hochburg to apply (snapshots 1 and 2).

• Then I browsed through the conclusion of selection.


On the root level .Trash was NOT checked, nice, this is what it has to be. I did not snapshot that.


But when diving into my user, I saw, everything is checked. No exclusion. I marked two corresponding folders in the snapshot 3.


If this is not a bug, what is it then?







Edited by Guest
Added test results.
Link to comment
Share on other sites

I *think* there might be a bug when using a rule in the Backup Wizard (as opposed to using the same rule in a script.) I saw this on Friday and mean to follow-up with this next week.


All I can suggest is try your rule in a script and see if what is actually backed up is what you think should/shouldn't be...

Link to comment
Share on other sites

Today I initiated a complete recycle backup - and it seems it works this time. Interesting. But the amount to backup is what I expected, not the complete load like when the first backups were made.


So there might be a little worm inside of it. But now it works (I hope). I will tell this the service man Vaidas, too, he just mailed me back yesterday that he has forwarded this rules issue to some RS engineers.

Link to comment
Share on other sites

Yes -- I've reported this too.


I'm able (at least with my current config file) to set up rules that work *in scripts*, but are completely ignored -- or display wrong information -- when "Previewing" with the Backup Wizard.


(It may be that the rule *is* working, but the Preview is not -- haven't nailed that down.)

Link to comment
Share on other sites

  • 3 weeks later...

Ladies and Germs,


So I already have a thread going about not being able to connect with clients. Restarted the Retrospect Engine, deleted the config files,...Seems to be working.


One problem, I trashed the rules (bonehead move I know) and had to rebuild them. Believe it or not my set of Rules were previously working. I could indeed Exclude/"Folder is Applications" and it would not copy those files. I can't believe I've got to set a path name in order to get this to work. (I can hear Russ sighing from here).


One thing that surprised me was when I did my "test restore", I previewed it to see if indeed the applications were NOT copied. In the preview they weren't but I did the full restore anyway just to make sure. Lo and behold, there they were. Not good, not good at all. This is not what I had in mind after Retrospect convinced me that the upgrade was going to solve all my problems.


Any kind words would be appreciated. In the meantime I guess I'll rewrite my Rules as Macpath's and see if that works.


Fortunately I have a separate server with Retrospect 6 on it. I'm back to that version for the time being. I can't afford to not have this data backed up. You'd think the folks at Retrospect would understand these headaches and get with it.




Peter Keenan

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...