Jump to content

6.1 Hangs on backup since DVD is mounting

Recommended Posts



I've been a Retrospect user for years. I recently retired my B&W G3 server (running 10.4.11), mitgrated to a dual processor G5 running 10.4.11, upgraded to 6.1.230 and device update The same backup script and Retrospect Event Handler had been running great on the G3. And after using the migration assistant and upgrading, it worked on the G5 for about a month. I'm backing up to the internal DVD drive.


About a week ago, I walked in the morning and Retrospect had hung asking for the DVD disk it wanted to backup to. No amount of clicking in the Retrospect windows would unfreeze it. I had to force quit Retrospect. The other thing that is now different is that the DVD is mounting on the desktop after a backup operation finishes. While Retrospect is hung, trying to unmount the DVD results in a message that the device cannot be ejected since it is in use. Even disk utility can't unmount or eject the DVD until I do a restart and hold down the mouse key to force an eject.


Once I restart, and run the backup, and wait to insert the DVD until Retrospect asks for it, it will proceed naturally and then mount the DVD. Once Retrospect quits, then the DVD can be ejected.


I've done a reinstall of 6.1.230. No different.


Any help will be most appreciated.


I'm not running any clients or remote backups.


Thanks in advance,


Link to comment
Share on other sites



If I force quit Retrospect and then restart, and then Run the backup script within Retrospect, then it will complain that it can't use the CD/DVD drive, but if you dismiss the dialog box and then eject the DVD, it will eject and eventually retrospect will ask for the DVD, pushing the DVD back in will let it proceed normally.


How do I get it to start running the backup at night and not hanging because the DVD is mounted?

Link to comment
Share on other sites

I seem to recall that there's a little .kext or Plug-In that Retrospect can optionally install that lets Retrospect DVDs be mounted by the finder.


I don't back up to DVD, so I have never installed it (or, when installing, I did a custom install to not install this if its done by default).


Here's the Plug-in description of what needs to be removed:


Retrospect CD/DVDs mounting in the Finder: Retrospect 6.1 includes an updated File System Plug-in that can successfully mount Retrospect CD/DVDs in the Finder on computers running Tiger. This includes the ability to mount DVD+R DL media.



Link to comment
Share on other sites

Thank you for your suggestion. I had removed the whole retrospect fs extension directory and restarted (per the knowledgebase article's directions). It wouldn't run a backup to DVD at all. So, I did a reinstall of the 6.1.230, which put it back; and we're still exhibiting the same behavior. The only way I've gotten it to work is to have it eject the media upon Quit, so the DVD tray is open and when I walk in the morning, it is waiting for me to push it in, it completes the backup and then quits, and proceeds to startup Filemaker (which I use as my database server) and life gets going.


I don't understand why it worked fine for about a month before starting this behavior.


Still looking for answers,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...