Jump to content

Scheduled executions don't run until Retrospect is manually launched

Recommended Posts

Hello everyone,


I'm having a vexing bug with Retrospect 6.1 running on our xserve with 10.5 Server. We have several scheduled backups set up which will run fine for several days, then after a random amount of time (sometimes just a day or two, sometimes almost two weeks) they will stop automatically executing until the Retrospect application is manually launched. Interestingly, Retrospect will "catch up" on any of the scheduled executions which it did not automatically launch for -- for example, I noticed I wasn't receiving e-mail notifications on Friday, so I went to the server and launched Retrospect. In the log, I could see nothing had run since Wednesday, and immediately upon launching it began trying to run all the backups which it should have on Thursday. It took a while for it to "catch up" to the current scheduled tasks, but according to logs it managed to get back on time by Saturday. It ran all of its scheduled backups on Saturday at the appointed times, then around midday Sunday -- poof. It just stopped executing. It's not that the backups are starting and then failing -- there's just nothing in the log for them. When my coworker arrived this morning and opened Retrospect to check, it immediately kicked into gear and started executing all of Sunday's tasks.


Any suggestions as to what could be causing this and what troubleshooting steps I should take?




Tom Morrisey

Diversified Control, Inc.

Link to comment
Share on other sites



It appears that you are seeing one of the frustrating bugs with Retrospect 6.x that has existed for years. The Retrospect programmers have tried and tried to find the cause (and there may be multiple causes) because each release of Retrospect 6.x over the years claims to have fixed it (see the release notes) but hasn't. We see this bug about once a month, and have seen it for years.


The cause of the non-launch is that the "retrorunfile" preferences file becomes corrupted. Here's the "wave the rubber chicken" dance to fix things when this happens:


(1) Quit Retrospect (if running)

(2) delete the following file:


(3) restart Retrospect

(4) quit Retrospect


Retrospect will recreate the corrupted file in steps (3) and (4).


At this point, all we can do is live with this bug. If you have Retrospect set up to send email notifications, you will notice when the notifications stop coming and know that you need to do the rubber chicken dance, above.



Link to comment
Share on other sites

Hi Russ,


Thanks for your prompt (and candid!) advice! I will try what you suggested regarded the RetroRun file... even if the bug still crops up it'll be nice to be able to at least make it go away for a while. Is this confirmed fixed in Retrospect 8? Might be a compelling argument for my company to upgrade.


Thanks again,


Link to comment
Share on other sites

Is this confirmed fixed in Retrospect 8?

Retrospect 8 is a completely new code base, starting from the Windows Retrospect 7.x code base. Retrospect 8 is a completely different design, and does not use the retrorunfile for autolaunching.


Retrospect 8.x has the latest bugs, not the old ones. Enjoy.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...