Jump to content

occasional errors backing up two clients

Recommended Posts

We have a script backing up all the network clients to a NAS drive. It's been working for yonks but recently often fails, always at precisely the same point, giving the following errors:


Can't save Backup Set [name] error -1116 (can't access network volume)

Can't access state session [date/time], error -1116 (can't access network volume)

Trouble matching [Volume D:] on [client] to [backup set name], error -1116 (can't access network volume)

[same again for volume E:]

[same again for volume C: of the next client]

Cant save Backup Set [name], error -1116 (can't access network volume)

Can't compress Catalog File for Backup Set [name], error -1116 (can't access network volume)


So it does many clients, then fails on the last two. Always it resolves the first of these clients to its 3 volumes, c:, d: and e:. The log reports it copies volume C:, says 'Snapshot stored', then 'comparing C': and that's when it reports the errors given previously.


I'm assuming the first client to fail is responsible for the second?


I cannot tell which volume it's complaining about, the client or the NAS. Don't see how the NAS could fail always at the same point in the backup though. It seems it has to be the first of these clients that's at fault. We rebooted the NAS in case it was having issues, but we still have the problem. The client that fails first also notes the failures of the last two volumes.


As I say, some nights it runs fine, on others it has *exactly* this sequence of errors.


Any ideas?

Link to comment
Share on other sites

I seem to have solved this. I ran a manual backup of just the first problem client to the usual set, and this failed in the usual way. I backed up the second problem client, and as I expected, this worked fine. So the second client only failed once the first one had caused some problem.


After watching closely what was happening during the attempt to back up, I concluded the set must have some corruption in the data relating to the first client. I have backed that up to a new set to prove this, successfully, and will now start up a new set for everything. I did try rebuilding the catalog, which succeeded, but did not help.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...