Jump to content

Machine will not start after complete system restore


Recommended Posts

I have a problem with a PC that won't start after a complete Restore to a new HDD.


The original HDD had some problems and so I obtained a new HDD. However, the original disk then reported itself fine and so I left it alone and used the 'replacement' disk as a drive D and ran regular backups of the original drive C to the new drive D. The original disk has now had more problems but is again reporting itself as fine, only I don't trust it this time! Hence the idea has been to swap the disks - make the new HDD the system C: drive and keep the 'slightly suspect' original as a D:


Both drives are working fine. Both are Hitachi TravelStars (the original a 2004 130Gb model, the new on a 2008 320Gb model).


So I have run through the following:



a. Started the machine on the original C: drive and run a backup to bring the backup set up to date

b. Copied the backup sets and catalogue from the D: drive (destined to become the new C: drive) to an external USB drive

c. Run the DR CD and performed a complete Restore from the external USB drive


Result: On final restart, the machine starts up with all the usual 'Windows XP' stuff, then I get to the blue Windows XP screen which would usually turn into the Welcome screen only it doesn't get as far as 'Select account'. It just gets to a 'Windows XP' logo centre right and there it stays. It's almost started, but not quite...


2. Remembering that the original C: drive is still alive

a. Started the machine on the original C: drive and created a new backup set direct to the external USB drive

b. Run the DR CD and performed a complete Restore from the new backup set on the external USB drive


Result: Exactly the same. The machine starts, we get to the blue 'Windows XP' screen that should turn into the Welcome screen, and there we stay...


3. Again using the original C: drive

a. Run a disk duplication from the original C: drive to the 'new' drive (which was the D: drive)


Result: Exactly the same as before


Is this something to do with the change in disk? I'm surprised if it is as I've moved systems from one disk manufacturer to another before and not had a problem, but this time the system 'gets stuck' in exactly the same place. This suggests the restore - all three that I've tried - are all working...only the system then won't start presumably for the same reason.


I can see me needing to create an XP SP3 streamline disk and reinstall Windows over the top of the new restored C: drive :-(


Anyone any ideas on what's going on and why the Restore won't start up properly? This is the first time I've had this issue with a Retrospect-driven disk swap.



Link to comment
Share on other sites

Well this is answering my own question, but I'm posting this in the hope it may help others.


Right, so the problem was that after completing a complete restore, the machine would reboot, get as far as 'welcome' and there the machine would sit, stuck.


I managed to get the machine started by reinstalling Windows and doing a repair (having created myself a slipstreamed SP3 install CD of course!), but I still found applications considered themselves not to be installed. The key to all this was that the 'new' HDD had previously been used in the machine as a second drive (drive D:).


It seems Windows records a deviceID in its registry for each physical device and so although the machine was being restored as a single HDD machine with a 'new' HDD, because that physical HDD had been used in the same PC as a D: drive previously, the restored registry had the drive marked as being drive D:


The result was the restore completed with pointers to applications and to Windows itself pointed to drive C: locations. However, because the physical disk had been previously used in this machine, Windows had its deviceID recorded as drive D: and so the machine started with its only and system drive marked as drive D: but with all software being installed and configured for drive C: This is the reason for the freeze on initial start-up after the complete restore. A call was being made to a Windows resource with a C: path, only the single restored drive was marked as D: and so everything stopped.


Reinstalling Windows over the top of the restored disk allowed Windows to start, but then applications wouldn't run as they referenced drive C: locations and the re-built machine had everything on drive D:


So how to overcome this?


Using the original HDD which was still running, I opened regedit and found:



In there I found "\DosDevices\D:"


I deleted this key as it linked the deviceID of the 'new' HDD to be drive D: I then ran a Retrospect backup so recording the updated registry without the DosDevice\D: key. For full instructions see: http://support.microsoft.com/kb/223188


I then re-ran the DR complete restore using the 'new' HDD as the restore destination. This time the restored Windows didn't hold the deviceID of the 'new' HDD and so was happy to allocate it as a new drive C: and suddenly everything worked...first time.


So the moral of this story is...


If you re-use a physical HDD that has been a 'high drive' (drive letter higher than C:) as a 'new' primary drive C: the restore will fail as the restored registry with recognise the physical HDD with it's original 'high' drive letter. This means the restored image will not match the drive letter and so nothing will work.


So there' two options...


1. If the original C drive is still working, remove the HDD that you intend to make the new drive C: and then delete the DosDevice key for this device from the registry, backup and then restore from this backup


2. Use a new HDD which has never physically been in the machine to be restored and so for which no DosDevice registry key will exist in the Windows registry.


Hope this helps someone else!



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...