Jump to content

cannot set up or restore


Recommended Posts

Maxtor one touch II, retrospect hd failure


My hard drive died. According to windows explorer, I had 127 restore points on the F drive in retrospect.


When I reloaded Maxtor and Retrospect, I could not restore any of the restore points. The restores would start and then give a message: errors restoring.... 0 files restored.


I tried to restore small groups of files and single files. Same error.


When I tried to setup a backup, Restrospect did not recognize the F drive. I would only create a restore point on Drive C.


I went online to get an update for Retrospect Express and downloaded version 1.1 from the EMC website.


All the same problems with setting restore points and with restoring from the F drive.


I removed the 1.1 version completely and reinstalled my old disk with Retrospect 1.0.196.


At this point, Retrospect says I have 0 restore points. It will not even open itself to set up a restore point.


I am at a loss. I would throw the Maxtor drive in the trash, but I have a couple of critical files on it. How can I get them to restore?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...