Jump to content

Workgroup 4.3 & ASIP 6.3.3

Recommended Posts

We have been successfully using version 4 for 2/5 years on a G4 Server running OS 9.2.2 & ASIP 6.3.3. I recently made the apparently major mistake of upgrading to Workgroup 5.0. After several crashes of my Server, I discovered the recent item noted in these forums that Dantz no longer claims compatibility with ASIP. While I hope to migrate to OS X Server 10.2 sometime soon, my problems are more immediate.




I have completely removed all aspects of version 5.0 using Sherlock as best as I could. I have reinstalled version 4.2 from the CD & applied the 4.3 update. All should be as it was prior to the upgrade attempt...BUT NO!!!!




I can't get 4.3 to run. It will get as far as scanning a client's files, & then quit before writing to the backup set. Understand that I've done the following, some more than once: reinstalled, trashed the original backup set, re-written all my scripts from scratch, given the application 20 MB of Ram, reinstalled the client software, etc. I keep getting errors 1 or 2 when the application quits. The log never adds an error to figure what's wrong. Why did this work SO well prior to my update attempt???? Nothing else has changed on my Server!!!

Link to comment
Share on other sites

Retrospect 4.3 uses the same files system calls, specified by Apple, as Retrospect 5.0. Many, but not all, customers were seeing these same issues with Retrospect 4.3 and ASIP 6.3.x servers. You may come across the same incompatibilities.




Is the error "error 1 (unknown)" or "Error type 1?"




Error type 1:


Retrospect 4.3 and Retrospect 5.0 have one major difference: Retrospect 5.0 is a Carbon application which allows it to run on OS 9 as well as OS X. Any Carbon application running on OS 9 requires the CarbonLib extension, in addition to base extensions, to launch and run. With previous versions of Retrospect, no extensions were needed to actually launch the program.




You may have programs on your machine that conflict with CarbonLib or Carbon based applications in general. It is important to update all your programs to ensure best case compatibility.




We currently do not have a list of known extension conflicts. Every system is different, and extensions that have a conflict on one system do not always have a conflict on another system.




Regarding the error Type 1, we have not seen a situation yet where the problem does not go away when booting from either the System CD or a Retrospect CD. This would indicate an extension conflict with an installed program that may not be designed to run while Carbon applications are in use.




Also, CarbonLib 1.6 and Authoring Support 1.19 are now available from Mac OS 9's Software Update control panel. You may need to be using OS 9.2.2 to upgrade.






Error 1 (unknown) on ASIP Server:


Dantz has been investigating several problems that customers have reported when backing up an AppleShare IP server with Retrospect 5.0. Reported problems include:




1) The ASIP server crashes when Retrospect 5.0 autolaunches or


is launched from an alias.




2) The ASIP server crashes at the beginning of a backup with the


Retrospect 5.0 client.




3) Retrospect returns "error 1 (unknown)" for some files backed


up from an ASIP server with the Retrospect 5.0 client.




Our investigation has revealed that these problems result from using Carbon APIs with AppleShare IP software. Problem #1 occurs when any Carbon application is launched from an alias, confirming our contention that it is not a Retrospect issue. Retrospect 5.0 uses HFS+ file system calls, as specified by Apple, which stimulate bugs in the AppleShare IP software, resulting in Problems #2 and #3.




We have reported all of these problems to Apple, but Apple's development efforts are now focused on Mac OS X Server. Without a commitment by Apple to address these problems, we have no choice but to suggest that our customers consider replacing AppleShare IP with Mac OS X Server.







Link to comment
Share on other sites

Thanks for your reply...but the issue simply is this:




After finding problems with 5.0, I reverted back to 4.3 (which we have been using for the past 2 years successfully). Now, all of a sudden, 4.3 quits with error type 1 or 2 whenever to attempts to WRITE to a backup set. I've tried this with all my scripts. I've reinstalled 4.2 (with the 4.3 upgrade). I've recreated all my scripts from scratch. I even tried creating a new backup set. All to no avail. WHY AM I HAVING PROBLEMS WITH 4.3 NOW, AFTER THE 5.0 INSTALL???? I'VE GONE THROUGH THE SYSTEM & DELETED ALL FILES RELATED TO 5.0. WHAT GIVES????

Link to comment
Share on other sites

As you may know, Type 1 and Type 2 errors are Apple generated errors, generally indicating memory issues or extension conflicts.




Try booting with Extensions turned off and backup to a File backup set on your local drive - does the problem go away? If so, you may need to follow standard Extensions troubleshooting, as outlined by Apple.





Link to comment
Share on other sites

I had already planned to try this when I have the time to allow the server to be down for an extended period. I guess my big issue here still remains that I did not have ANY problems with 4.3 prior to installing the 5.0 upgrade! I'm wondering if there must be an extension, or some other system file installed by 5.0 that I missed when deleting? I found several FireWire drivers 5.0 had installed by using Extension Manager (viewing as packages) and was surprised to see these drivers still in the system folder listed as 5.0. I removed them, hoping that they were the cause of 4.3's current behavior. Remember that I've used Retrospect for 2.5 years with no problems. No other changes have occured on my server.

Link to comment
Share on other sites

Rather then manually deleting files, with Retrospect 5.0 you should run the installer and select the option to 'Uninstall' Retrospect to ensure that all installed files are removed. Also, under OS 9 you can look in your installer folder to see the Extensions that Retrospect may potentially install on your system (not all extensions are installed on all systems).




If you experience "type 2" errors with Retrospect try the following:




1) If using the Retrospect Driver Update, try downloading a fresh RDU from the Dantz web site.


2) Try restarting the computer with basic Apple Extensions plus the extensions required for your backup device.


3) Make sure you are using the latest FireWire or USB drivers available for your computer, operating system and backup hardware


4) Reinstall the Retrospect application


5) Perform a "Clean Install" of the Macintosh Operating System, followed by a reinstall of the drivers/extensions necessary for using your backup device.




Many customers were experiencing the ASIP issue with Retrospect 4.3, which uses the same file system calls, specified by Apple, as Retrospect 5.0.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...