Jump to content

CD-RW will not do incremental

Recommended Posts





I have been using Retrospect 4.3 (Mac OS 8.6) and a Yamaha 4260 drive to do backups every two days for several years. It has been working fine until just recently.




What is now happening:




I erase a full disk to start fresh. I name the disk (Storage Set) "Backup Set 1" and it appears as "Backup Set 1" in the Configure Devices window. I do a Full Backup using the script I have written.




The next time it tries to do an automatic incremental backup, it fails with a Media Request Timeout. When I see this message (the next morning) I try to do an incremental backup manually and Retrospect says it cannot find the requested Storage Set. If I look at the Configure Devices window, it now simply says "erased." So, I tell it to Skip the requested set and it writes the incremental backup as "1-Backup Set 1" (a new Storage Set member).




Two days later, the same process occurs. I now have a CD-RW disk with several new Storage Set members. For some reason Retrospect will not recognize the disk as the original Storage Set. Also, when I tried to erase this disk in Retrospect to start over again, I got a "hardware failure" error message several times.




This tipped me off to a theory: Whenever Retrospect starts a new backup session to a CD-RW, the first thing that comes up (after it catalogs the source drive) is an "erasing" window which lasts for 10 or 15 seconds. I don't know what it is really doing, but it has always done this. I think that the drive may have a true fault, or the disk is bad, and when Retrospect tries to "erase" the disk before writing the backup it gets an error message (although no error message is logged). This causes the media request timeout. Then the process repeats itself each time I create a new Storage Set member.




The thing I find peculiar about this is that I've been using this drive and rotating two CD-RW disks for about two years with no problems. The previous disk, which became full, was working perfectly. Finally, Retrospect seems to have no trouble writing the incremental backups when I use the Skip function!




This issue seems to relate to another posted message from June which also involved a Yamaha drive. All I am trying to do is verify what Retrospect is doing/expecting in the backup process so I can determine when the error occurs. In the meantime I guess I'll try a fresh CD-RW disk...








-- Eric





Link to comment
Share on other sites

As this device has been working for reliably for many years, with the same media, you should definitely try new discs. Media does have expirable life spans. If the problem continues, I've listed standard SCSI troubleshooting to help you further isolate the problem.




1) another device on your SCSI bus is interfering with the CD-RW drive's communication. Turn off your Mac and the SCSI devices. Make sure your SCSI ID numbers don't conflict. Disconnect all SCSI devices except for the CD-RW drive.




2) you have a bad cable. Replace the SCSI cable that connects the CD-RW drive to the computer after removing other devices and cables from the SCSI chain.




3) you are missing a terminator or have a bad terminator. The last device and ONLY the last device in your SCSI chain needs to be terminated. Try replacing the terminator if you already have one on the chain.




4) the computer may be having a problem. Install Retrospect on another Macintosh and try the CD-RW drive there as the only SCSI device.




5) the drive may be defective. If you have implemented all of the preceding steps and get failures on multiple discs after changing cables, terminators and computers, then the drive, being the only factor that has not changed, is the culprit--send it back to your vendor for repairs.



Link to comment
Share on other sites





Thanks for the reply. I'm quite experienced at troubleshooting, that is partly what I do for a living, and I can tell you that the problem is not anything obvious. I took the drive apart and cleaned it, which seems to have helped a bit, but I am willing to believe that the drive may just be screwy. I have some new information based on messing with it this weekend:




What I have found is that the only "malfunction" is that sometimes the NAME of the disc is not recognized by Retrospect. That is, I have a freshly erased CD-RW and it comes up as "erased" rather than the name I gave it. If I write one backup session to this disc, sometimes it will now have THAT name (the name of the first member of the set), but sometimes it still says "erased". Obviously, when it comes up as "erased" then Retrospect thinks it needs new media! I have also had cases where a disc that I know has backup sessions on it comes up as "erased" or "damaged."




I doubt there is anything in the program itself that could cause this kind of erratic behavior when reading data from the disc, so I'm inclined to think it is the drive. As I said to SB in another thread, this drive has been a bit flaky at times. It's just that it has worked flawlessly with Retrospect for years!




I am trying to see if there is any later firmware for the drive, but Yamaha's support is also kind of flaky, so I'm not holding my breath. I'll probably just replace it and I suspect my problems will go away!






Thanks again,




-- Eric

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...