Jump to content

Bad backup set header found

Recommended Posts

Hi I am having issues while backing up an Xserve 10.4.10, that hopefully someone can shed some light on. Every backup we run generates reams of errors during verification into the error log, of the form:



Trouble reading: “1-Monday-Wednesday” (443858), error 212

(media erased).

Bad backup set header found (0x3f7a1f3b at 425,935).

Bad backup set header found (0x29333439 at 425,936).

Bad backup set header found (0x7a3b2d3b at 425,941).

Bad backup set header found (0x078d0875 at 425,949).

Bad backup set header found (0x071f0703 at 425,973).


Sometimes the backup completes, other times it fails. The last error message before failure is:


Trouble positioning: “1-Monday-Wednesday” (443858), error 109

(unexpected filemark or FTP end of file).


We run three backup scripts, with different tapes, on alternate days, all generate the same messages. We backup the internal hard disk of the server and an attached RAID, partitioned twice. The error messages can appear while backing up any of the drives/partitions. I have used Retrospect for many years in different configurations, different drives and platforms, and have never seen messages like this before, so am thinking this maybe a hardware issue?


The configuration is an Xserve with dual channel U-320 SCSI card. One channel connected to a HP LTO-3 external drive, the other channel connects to a hardware raid controller. Retrospect is patched to the latest level with the advanced driver update.


Thanks in advanc


Link to comment
Share on other sites

If you've got the Apple Dual-channel SCSI card (really a LSI Logic 22320 dual-channel SCSI card), good luck. It's a piece of junk. We never got it to work right in our Xserve; replaced with an ATTO UL4D and all of the problems went away.


Aside from that, it does sound like you've got a hardware issue with the drive. Have you tried a cleaning cycle? Are your tapes old/worn? Have you tried diagnostics?



Retrospect is patched to the latest level with the advanced driver update.


Not trying to be difficult, but that isn't any information without versions. I've seen so many, many cases where people have sworn that they have the "latest version" (whatever that means) when they don't. And your post lives in these forums for years. People searching for solutions months from now don't have any insight whether their versions match yours or not, and the help we provide in these forums isn't for you, specifically, but for the community. We are just Retrospect users like you.





Link to comment
Share on other sites

The SCSI card is not Apple card, I have experience of those before! The card is an ATTO UL5D.


Point agreed about the versions to clarify:


Retrospect Backup version 6.1.126

Retrospect Driver Update version


Backup scripts are recycle backups everynight.


Thanks in advance


Link to comment
Share on other sites

Because you have an ATTO UL5D (PCI Express), even though you don't say, I assume that you have an Intel Xserve rather than an Xserve G5 (which has PCI-X). This appears to be confirmed because you say the Xserve is only a month old.


Are you aware of this note on the ATTO web site about issues with the UL5D caused by bugs in Mac OS 10.4.10:

Problems accessing tape drives attached to a UL5D in a Intel-based MAC-Pro or X-Serve


Prior to this "workaround", ATTO was suggesting that people not update to 10.4.10. You don't mention UL5D firmware version or ATTO driver version.


People have also reported problems in these forums with this ATTO workaround. Our Xserve is the Xserve G5, so I don't see this, and I'm not about to update our UL4D's firmware and driver to the "workaround" version (even though the UL5D driver and firmware also are for the UL4D) because we aren't seeing the Intel Xserve issues.


But it sure does sound like hardware issues. We had slightly different but somewhat similar issues with our Exabyte VXA-2 1x10 1u PacketLoader (SCSI) attached to our Xserve G5's ATTO UL4D, and it turned out to be a combination of a marginal batch of tapes from Exabyte, coupled with problematic error-recovery routines in an Exabyte firmware release last summer. A new batch of tapes (even though the ones we had were new) and a later firmware release cured our issues. Just to be sure, you might try a cleaning cycle with a cleaning tape before your backup. I feel your pain - it took me hours and hours to decide what the cause of our issues was, made more difficult because there were two interacting causes (error recovery routines in a firmware update, plus a marginal - but not outright bad - batch of tapes).


If the header issues were caused by bad RAM, you would be seeing ECC error correction in your Xserve's logs, but you don't mention that. Only other troubleshooting suggestion I could provide would be to run diagnostics for your tape drive (your Xserve seems to be doing fine) and to make sure that your LTO3 and its autoloader are the only devices on that SCSI channel - you don't say, and we had an issue (very different from your issue, though) with Retrospect a couple of years back that was only cured when we put the tape drive and autoloader on its own SCSI channel, away from a disk drive being used by the system.


Note, as a final comment, that there have been Apple bugs with certain versions of Mac OS X 10.4 that surface when ACLs are used on an Intel Mac (actually, I think that it's 10.4 Universal, which, with effort, can also be installed on a PPC Xserve, and which is a very different animal than 10.4 PPC). The bugs come and go with 10.4.x releases, appears that Apple's regression testing is not complete with each release because the bugs keep creeping back in. There is a special hacked version of Retrospect to avoid these bugs by not backing up ACLs. Details (and downloadable version, I believe it's 6.1.131) here:

Retrospect hack for ACL bug


Hope this helps,



Link to comment
Share on other sites

I've experienced this problem, but it appears to be down to damaged, old tapes, which I noted whilst rebuilding a backup set from tapes. The main problem this caused was that it crapped out the search and I wasn't given the option of skipping that tape and its contents. Is there a way around this? Unfortunately it's an older version of Retrospect - 5.1.177 - running on an OS 9.2.2 machine as my up-to-date version on an OS X machine is running the day-to-day backup with a DAT160, while this one is being used to retrieve work that went south on an external LaCie HD.

Link to comment
Share on other sites

Thanks rhwalker, the ATTO link you provided did the trick.


I updated the driver software to 4.2 and updated firmware to 2007_09_05 and all the messages have disapeared.


For completeness, the server is an Intel, which shipped with 10.4.10. The original ATTO driver installed was 4.1. There were no errors generated in any system log and only in Retrospect, hence my original posting here.


Thanks again for the help


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...