Jump to content

"new member" not asking for new tape

Recommended Posts

I have set up some backup scripts and I'm testing them via the "Run" menu. I have two scripts, which share the same Backup Set, which consists of two tapes. The two scripts are as follows:


script1: Recycle

script2: New member


Starting with both tapes blank, I run script1, it backs up some files to tape1, fine. Then I run script2. I'd expect script2 to ask me to put in the 2nd tape of the Backup Set, but it just appends to the tape already ion the drive. So why is it ignoring the "new member" option?




Link to comment
Share on other sites

p.s. the reason I'm doing this is that I want to do a full (recycle) backup at the weekend, then take that tape offsite, and do incremental ("normal") backups to another tape during the week.


So to achieve this, there are three 'rules' (or scripts):


script1: recycle (fri night) (goes to tape A)

script2: new member (mon night) (goes to tape B)

script3: normal backup (tue -> thur) (appended to tape B)


Does this sound sensible?

Link to comment
Share on other sites

Ok, now I know what the problem is. (It helps to draw an entity diagram featuring BackupSets, Scripts, and Schedules in order to see why.)

Problem is that the action I was configuring is associated with a schedule, whereas the Run->[scriptname] method has nothing to do with any schedule, only has to do with the backup set concerned. (And with a backup set, you can override the next action in the Options tab.)



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...