Jump to content

Won't refresh tape names...

Recommended Posts

Hello all,

Have been trying to get Retrospect up and running on a G4 after our G3 decided to tank. I have it mostly running, but have a new issue.

I can perform a backup, but Retrospect won't refresh the name of the tape it needs, so it keeps waiting for me to switch tapes. If I quit Retrospect and re-do the search/restore procedure, it detects the name of the tape just fine.

If I use the 'Eject' button on the tape drive, the name doesn't change, if I click on 'Eject' in Retrospect, I just get a 'Content Unrecognized' message...


Any help would be GREATLY appreciated... Am I missing some setting that fixes this...

Link to comment
Share on other sites

It's not clear what you mean by "Retrospect won't refresh the name of the tape it needs."


Could you explain better? Would it be possible to post a screen shot or describe the dialog that Retrospect has up, and exactly what it wants? What is the name of the backup set, and what is the name of the tape it wants? Do you have an autoloader or just a tape drive without autoloader?


I just don't understand what is happening.



Link to comment
Share on other sites


We have a single-tape drive currently hooked up, the autoloader is a story for another day... smile.gif


Anyway, what happens is that I go through the whole process to retreive files(Called 'Restore' in Retrospect, I believe), I search the catalogs, and it says 'Please Insert Set 8, Tape 7'(Or something similar), so I eject the tape that is currently in the drive, and put in the tape it asks for, after which, nothing happens. The tape drive loads up correctly, but Retrospect keeps sitting there, patiently waiting for me to put in a tape, no error, nothing at all, doesn't even register when I take the current tape out. If i use the 'Eject' button on the screen, then I get a 'Content unrecognized' error that doesn't go anywhere either.


IF I shut down Retrospect with the tape I need already in the drive, then when I restart the program, it reads just fine, and I redo the whole process over again, this time being able to retreive the files I need. Really a pain in the butt, but the good news is that I can at least get my files... This does NOT require a reboot, I just have to quit Retrospect and re-launch it.


Hope that was helpful...

Link to comment
Share on other sites

Ok. that's a bit more clear.


I understand that you are trying to do a restore. When you say you "search the catalogs" - what do you mean by that? Restore (Immediate mode) has three choices (with radio buttons, not numbers, but I use numbers here for clarity):


(1) Restore an entire disk

(2) Restore files from a backup

(3) Search for files and folders.


Which one are you choosing? If you are choosing #3, are you selecting multiple backup sets? (the catalogs have the same names as the backup sets).


What happens if you don't have any tape in the drive when a tape is requested?


Concerning the name of the requested tape, the tape requested should have a name of 1-backupsetname or 1-backupsetname [001]


What are you seeing?


The 1- or 2- or some number followed by a "-" is a member number of the backup set. the [001] or whatever is an incrementing number at the end of the backup set name that happens when you move to "new media".


When I try #3 and search across multiple catalogs (backup sets) (e.g., "VXA Set A [001]" and "VXA Set A [002]"), I get a dialog box that has a title bar of the name of the first catalog (backup set), e.g., "VXA Set A [001]", and a message that says:


Please insert the Backup Set member:

Name: 1-VXA Set A [001]

Barcode: 1-A 0001

If tape is unavailable, please click Choices.


Could you be a little more specific with the requested tape name, backup set (catalog) name and what you are doing? I'll try to reproduce if you can give better info.



Link to comment
Share on other sites

I use choice #3, and have chosen both multiple and single backup sets...


I took the tape out and tried to search, it still had the name from the last tape listed, so I closed Retro, relaunched it with no tape and tried again. THis time I got the 'content unrecognized' error...


The exact dialog is: please insert "16-Nichols Set 8"

if tape is unavailable, please click Choices



Our Backup sets are Nichols 5 thru Nichols 10, and it has always formatted the request with the tape nukber followed by the set number. This IS an instance where we transferred everything from a G3(OS 9) to a G4(OSX), as I mentioned earlier, but this doesn't seem to neccesarily be a result of that, since we CAN see the tape names when Retro launches with a tape in the drive.

Link to comment
Share on other sites

Hmm. I have seen our Exabyte VXA-2 with autoloader give "content unrecognized" if the tape is not at BOT when Retrospect tries to look at it. I have check the "rewind on quit" preference to cure that (with the exception of a power fail, even a graceful power fail on UPS graceful shutdown; I turned in a "feature request" to fix that with a "rewind on start" preference a couple of years ago...).


I assume that you have run a cleaning tape in the drive to eliminate that possibility.


What happens if you focus on just getting Retrospect to recognize the tapes?

In other words, don't go through the whole painful selection of backup sets, but instead bring up the "Configure > Devices" window and insert a tape. Does its name appear for the drive? What if you then eject the tape from the drive's eject button and insert another. Does its name appear for the drive?


Oh, and one more very important piece of information so that we are not chasing our tails:

What version of Retrospect do you have? and what RDU are you using? And what Mac OS version on the G4? and what tape drive?


I assume that you have updated the firmware in your tape drive....



Link to comment
Share on other sites

Retro is v

Device Access version is 1.0.107

Driver Update version is

Tape drive is a Sony SDX300C

OS is OS 10.4.9


'Configure>Devices' causes the same result...


Interestingly enough, I ejected the tape when I checked this, and it said 'Rewinding' when it was empty, and then the whole computer crashed...


They're right you know, Macs don't give cryptic error messages, they actually don't give ANY message at all, except the one that says, 'Your Mac just crashed. restart'... wink.gif


Let me try the 'rewind' options and see what I get...

Link to comment
Share on other sites

Sorry, forgot to add that Yes, I have updated the firmware, but can't figure out the cleaning thing... There are instructions, but I don't know if there is a separate utility, something built into Retro, or something built into the OS. Unfortunately, nobody here seems to know how to run the cleaning, and I am currently trying my best to get our backup system running, somehow I got elected to this post...


As for the "rewind on quit" and "rewind on start" settings, are those in Retro, or the OS settings?


Thanks to everyone for the help so far, I appreciate it!

Link to comment
Share on other sites

The RDU is causing problems for some people (though yours is the first I've heard of crashing).


I'd suggest reverting to RDU

The revision history is here, with links to prior versions:

RDU version history


You should not be seeing crashing. Sounds like a hardware or driver issue.


How is the Sony SDX300C connected to the G4?


There are some G4 models with bad SCSI, and Retrospect only supports one SCSI card with 10.4.x - the ATTO cards. Adaptec dropped support for their cards after 10.3.9.



Link to comment
Share on other sites

Rewind on quit is a hidden Retrospect option in Special, hold down "option" while clicking the "Preferences" button, choose "Tape".


Rewind on Start is only in my wishes - feature request submitted two years ago to Insignia/Dantz (or whatever the company name was back then).



Link to comment
Share on other sites

Found the hidden stuff, unfortunately rewind on quit is already set... frown.gif How silly is it to have 'hidden' settings anyway?

We DO have an Adaptec SCSI card in the comp, but it all worked on older Retrospect on the G3, so we're trying to make it work, especially since they just priced an ATTO card at $300, so of course they're balking at that. One of the options I was looking at is a firewire/SCSI adapter that specifically mentions Retro on its specs page, but that's just one more thing to have fail...


I will try the revert on the RDU and see if that helps at all...

Link to comment
Share on other sites

The Adaptec card may be the source of the crashing. The Adaptec driver does not work with 10.4.x. We have the ATTO card and all of our problems went away when we got it - we previously had the Apple BTO dual SCSI card in our Xserve (really, a rebranded LSI Logic 22320). Never worked right. Junk.


Stay away from firewire to scsi adapters.


Ask yourself whether your time and data is worth $300.



Link to comment
Share on other sites

LOL, I'll pass this on to the people who are scared to put out that money...


Since we are a large format printing company, and pull a good 10-15 jobs a day that were previously printed, I would think that they would focus on the backup being reliable, since the stuff that is backed up contains all of the color-corrected resized and approved artwork, thereby saving many man-hours. Also, customers order reprints, expecting a quicker turnaround, as well as consistent results.


Thanks for the tip on the adapter, too!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...