Jump to content

'Insufficient privileges' under Vista


Seraphim

Recommended Posts

I've just bought a Western Digital MyBook external drive, which comes with EMC Retrospect 7.5 Express.

I installed the drive as per the instructions (there was an error about 'no driver' under Vista, but the drive is being seen and I can transfer files to and from it).

Then I installed Retrospect and the recently released upgrades to it, which I d/loaded from the EMC site.

But whenever I start the program I get a message telling me that I don't have administrator privileges and any backups might not be complete.

My copy of Vista is a clean install on a brand new, empty drive. I am the only user and am listed as the administrator when I go into the 'users' settings.

Having searched for a possible solution, I found one suggesting I go into Retrospec'ts configure/preferences and select 'always run as the specified user'.

I did this, put in the password, and added the name of the PC (which was the PC's name under the system manager and not just the name of the C: drive).

This time I got 'you do not have sufficient privilegs to define the backup user'.

 

So I tried checking the box in the program's 'compatibility' tab, 'always run as administrator'. This time when I run the program, I got asked for a username and password, which I entered, and was told that I'm 'not in the administrator's group' and my password didn't correspond to an administrator's account!

I AM the administrator, as I said, so how come I can't run the program?

I've managed to do a backup, but there was a list of files that weren't backed up including the registry.

I'd like to get this working properly, and would appreciate some advice.

Link to comment
Share on other sites

  • 4 weeks later...

I am also having the exact same problem!

 

I purchased 2 WD MyBook hard drives - 1 for my XP machine and one for my new Vista machine. Everything works beautifully on the XP machine, but whenever I start the program on my Vista machine I get a message telling me that I don't have administrator privileges and any backups might not be complete. I have tried everything Seraphim (above) has tried.

 

Can someone please respond to this issue...I am now extremely frustrated with this software! Any advice would be greatly appreciated.

Link to comment
Share on other sites

Sorry for not replying sooner.

In the end, I disabled User Access Control. I now get dire warnings from Vista every time I start up, but at least the backup runs.

Or, at least, it runs up to a point: I'm now getting a message saying that the external drive doesn't have enough space after it is 'groomed'? I'm not sure what this means, but it asks me to point to another location to which to extend the backup. I've not yet investigated this further, but something is clearly wrong.

The drive is 500Gb capacity, and the two internal drives that I'm backing up currently have about 150Gb on between them.

I'm writing this at work and don't have the Retrospect Version number to hand. I'll try to remember to look it up and add it when I get home.

The version is 7.5.252

Driver and hotfix version: 7.5.4.105

Link to comment
Share on other sites

My first message I posted did not clarify that software automatically installed from the WD500 drive. I am also using the firewire connection. The manual stated that I had to use the USB connection to install the software then I could use the fireware connection after the software installed.

 

I finally decided to completely remove the retrospect express software that automatically installed. I rebooted and logged on as myself(administrator, same as before) I used the installation CD that came with the WD hard drive and reinstalled the software. I am now able to use the backup software without the "privileges" message.

 

Hopes this helps someone. I still have other issues with errors in the log file but this one seems to be solved for me.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...