Jump to content

Archive bit query


Naro

Recommended Posts

Still hope for some clues here.. though my original post had no response:

ver 7.5 I perform two different Normal Backups (i.e., to two different locations) daily, and two limited Duplications daily to two different locations. Does Retrospect use archive bit settings in this process? If so, I imagine I'm causing myself trouble by repeating processes on the same dataset. I can find reference in the Knowledgebase to the use of archive bit settings for file security data in progressive backup. I can't find any other clarification or reference to the use of archive bits, so perhaps my concerns are unfounded.

Thanks for your help.

Link to comment
Share on other sites

I have been using Retrospect for only a few weeks now and have set up a similar structure to you. I run a "Normal" backup every 12 hours. The first one which is during the day is to one Backup Set and the second one which is during the night is to another Backup Set.

 

From what I can see, it does not use the Archive Bit at all for determining what needs to be backed up. It seems to compare the last snapshot saved from the previous Backup on that Backup Set to the files that are currently on that computer. Any new files or changed files are then copied.

 

I could be wrong, as this is only my opinion based on the limited knowledge and experience I have of Retrospect, but I too would like to know the answer to this!

Link to comment
Share on other sites

I think you're correct about the snapshot vs. the archive bit.. but I wish I knew for sure without having to track down a particular file and check the bits. I have enough that I'm trying to figure out with this version. I'm getting frustrated with both the backup and the duplicate process in regard to being able to exclude files. Nothing I do in the selection process has any effect on one particular path I'm trying to exclude: I get attempts to copy those files anyway, with error messages anyway. Can't stop Ret.7.5 from messin' with those particular files. So.... I'm close to walking away from the product.

Link to comment
Share on other sites

Webroot is causing 80 to 100 files to be noted in the log as a problem... not backed up...not duplicated...usually with a "insufficient permissions" notation. I'm the only user, and admin, so I thought the "lock" is (understandably) Webroot's doing. So I've tried to set selectors file by file and not include Webroot or anything down it's path in Program Files or in Documents & Settings/////Application settings.. and anywhere else I see them in the directory. That custom selector still results in a log full of noted errors regarding Webroot Antispyware. Similarly, I've named Folders to exclude. Same unfortunate result. I also get the same result when I EXCLUDE by foldername TEMP files, TempFiles, and Temporary Internet Files. STILL show up in the log marked as errors. So I can't blame Webroot.

The only thing I'm left wondering is if perhaps the selections ARE working properly and these files are being ignored as directed.....and the errors noting files not copied really should be saying "files not copied...as you directed, stupid". Even when I DUPLICATE Replace Corresponding Files, and am certain I deleted the files and folders from the target drive prior to the DUPLICATE... I get the errors notated in the log. Perhaps the answer is to stop looking at the log.

I appreciate your offer to help, but please don't let my problem bug you too much.

Link to comment
Share on other sites

mmm that sounds like a tricky one.

 

All I can say is that I have used explicit Paths for excluding files/folders using the "Path" condition under Windows (FAT/NTFS). It shouldn't come up with any errors once they're excluded. It doesn't even report that it skipped the files. The only reason I know they are excluded is because they are not included in the snapshots when I look.

 

You could probably use the "Name" condition under Universal and just enter Folder does match pattern "*\Webroot" and tick Include enclosed folders.

 

This should mean that it will exclude any Webroot folder found on the drive.

 

Not sure if that will help you.

Link to comment
Share on other sites

Fixed. All I did to fix it was as follows:

 

I set my vss service to automatic.

I suspended Open File Backup in Retrospect.

 

Now things work as I need them to do. My fix may have been entirely irrelevant. The resolution may have just been magic. I don't want to know!

 

"Any sufficiently advanced technology is indistinguishable from magic" Arthur C. Clarke

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...