Jump to content

Exabyte LTO3 Magnum 224L, ATTO SCSI Issues

Recommended Posts

I've got an Exabyte LTO Magnum 224L SCSI tape library connected to a DP 1.8Ghz G5 w/ 6.5MB RAM. There is an ATTO ExpressPCI UL4S single channel Ultra320 SCSI in the G5. LTO device is properly terminated. The G5 is running the latest version of Retrospect server backup. G5 is connected via gigabit ethernet to the same switch as my xServes I am backup up data from. I'm trying to backup 2 xServes over a gigabit network. One xServe is running 10.4.7 and the other is running 10.4.8 (server). I've got the latest version of the Retrospect client on both machines.


I'll admit that for the past 2-3 years I have not been using Retrospect for my backups. I've been using a homegrown method involving tar, rsync, etc. I wanted a backup solution that would be hands free to handle both daily incrementals and weekly full images. Anyways, so far I've got nothing but problems and I'm not sure where to start to troubleshoot.


My Incremental script runs at 10pm M-F. Around 10:20pm the script will fail and the error message left on the screen says 'error 205 (lost access to storage medium)'. This happens every single time as far as I can tell. At this point I can manually run the script and it will work some of the times. I say some because quite often it will choke part way through the backups and just hang and not do anything. For example, I am looking at the server from last night's backup and it is just hanging at maybe 50% completion of the backups. I have to manually stop it and the logs don't give me any useful information. Most of the time when I stop the script I have to force quit Retrospect to use it again. Most of time by doing this I lose connection to the LTO so I must restart the G5 to see the LTO device again. This issue so far is the biggest and most annoying issue I have for obvious reasons. I've been running this system for maybe 10-12 days and have yet to have a single success. I haven't dealt with external SCSI devices on a Mac for many years so a part of me is wondering about the SCSI connection between the server and the LTO. I had thought about going to the fibre channel instead but it didn't seem worth the extra cost at the time. Any ideas on where to start to troubleshoot?


I'm going to be calling Exabyte support today and see what they know but my experience with Mac support forums as been good and I'm looking forward to seeing what responses I may get.

Link to comment
Share on other sites


The G5 is running the latest version of Retrospect server backup.



This is really not useful information for several reasons:


(1) These posts stay around for years due to the internet's infinite memory. Those who search the posts some time from now to try to solve their problem won't be able to figure out whether the solution for yours will help them. Version information is needed (Retrospect version, RDU version).


(2) We are not able to help you without any version information. Version information is needed (Retrospect version, RDU version).


(3) What does "the latest version" mean? There was an RDU issued yesterday, perhaps it might help solve your problem. Version information is needed (Retrospect version, RDU version).


Would it be possible to get some information about the version of Retrospect and RDU that you are using? You also don't say what OS version is on the Retrospect backup machine. That info would be helpful as well.


I've got the latest version of the Retrospect client on both machines.


Same issue here. Version information, please.

Link to comment
Share on other sites

Fair enough... I was being lazy.


G5 running 10.4.8 client

Retrospect 6.1.126

Retrospect mac os x clients running: 6.1.130, linux clients running 7.0.110

Driver update:

DAV: 1.0.107

Exabyte Library Firmware: C113

Exabyte IMB LTO3 drive firmware: 64D0

ATTO UL4S driver 3.6.0


According to Exabyte tech support they are saying its purely a SCSI related issue. I sent them over the system logs from the backup server and they claim to see SCSI bus resets in there. I am using the Exabyte supplied SCSI cable and terminator although I will try swapping these out as they could be faulty. I am using the ATT0 single channel SCSI card and the Exabyte Library is the only device I have on the SCSI chain.


In addition Retrospect always hangs when it tried to copies the 'InDesign SavedData' files from the source. I have to force quite Retrospect to get it to recover, then restart the machine for the G5 to see the LTO on the SCSI bus.

Link to comment
Share on other sites

Ok, looks like you are up to date (except for the RDU driver update earlier this week for some other LTO drives). I assume you have the ATTO 1.50 flash firmware, too (10/22/2005), but that shouldn't be an issue once you are past the booting.


Interesting that Retrospect always hangs on the same file. What happens if you do a selector to exclude the "InDesign SavedData" files?

Link to comment
Share on other sites

My flash version on the ATTO is 1.5.2.


The InDesign SavedData file is a secondary issue here really but I will add an exclude in my scripts for the file(s). Again, the biggest problem is the 'error 205 (lost access to storage medium)'.


A part of me wishes I spent the extra money for the fibre channel version so I don't have to deal w/ SCSI issues. Fibre either works or doesn't. SCSI has so many varying degrees of failure.

Link to comment
Share on other sites

Well, simply FYI, our Xserve G5 with ATTO UL4D and Exabyte VXA-2 1x10 1u PacketLoader (SCSI) has never had this problem. The Apple Dual-Channel BTO SCSI card (a rebranded LSI Logic 22320) never worked well with Retrospect, and we had some issues with Retrospect hanging on its initial device scan if a SoftRAID RAID 1 mirror drive was on the same SCSI channel as the Exabyte, but we have never seen the issue you have, and we have never seen a recurrence of our issue since we moved the Exabyte drive/autoloader to its own SCSI channel. Only difference I can see (other than different Exabyte drive/autoloader) with our configuration is that we are not using Exabyte's supplied cable or terminator. We use an LVD cable with ferrites from Cables to Go and also use their terminator.

Here is the terminator:

LVD terminator

and here is the cable:

VHDCI to MD68M LVD cable with ferrites


They also have 6 foot cables and MD68M to MD68M cables. We've never had a problem with their cables, and their customer service and turnaround have always been great.





Link to comment
Share on other sites

Thanks Russ. I talked again to Exabyte tech support (great people btw) and they've recommended I try a new SCSI cable. According to them about 60% of tech support calls for SCSI LTO devices are due to bad cables. I'll most likely bump up to the fibre channel version of this device for other reasons but for now I'll check out the link you sent me and try a new cable. Thanks for the info. I'll post back w/ results.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...