Jump to content

Selectors not functioning correctly


KevinC

Recommended Posts

I am using Retrospect Server Backup 5.5. I made a selector to exclude DHCP, WINS, and Exchange 5.5 files, which are kept open by the systems being backed up.

 

The selector is as follows:

 

Include everything, but always exclude:

 

folder name exactly matches !SOFTWARE LIBRARY (include subfolders)

OR MATCHING

file name matches pattern *.MP3

OR MATCHING

file name matches pattern *.TMP

OR MATCHING

file name exactly matches QUEUE.DAT

OR MATCHING

folder name exactly matches DSADATA (include subfolders)

OR MATCHING

folder name exactly matches MDBDATA (include subfolders)

OR MATCHING

folder name exactly matches DHCP (don't include subfolders)

OR MATCHING

folder name exactly matches WINS (doin't include subfolders)

 

"!Software Library" is our program storage location, and doesn't need to be backed up; the "*.MP3" and "*.TMP" exclusions are self-explanatory.

 

Checking the selector against the volume indicates that DHCP and WINS backups will be included, which is desired; not the live DB files. I am also running the Exchange Agent, and thus do not want to backup the live Exchange files.

 

I have checked this selector against the affected volumes, and everything looks fine. When I check the log in the morning, I get the following error for the Exchange, WINS, and DHCP DB files:

 

can't read security information, error -1020 (sharing violation)

 

Given how the selectors are configured, Retrospect should not even be attempting to access these files. Selectors for the "!Software Library", MP3, and TMP files work correctly.

 

I am at my wits end!!! Please, someone in the know...HELP!

 

Thanks in advance,

Kevin

 

 

Link to comment
Share on other sites

Quote:

can't read security information, error -1020 (sharing violation)

 


 

The error you are getting indicates that the file _permissions_ can't be read, not the files themselves. Your files are not getting backed up.

 

Permissions are backed up all or none on your entire source. If you want NTFS permissions backed up, you will continue to see these errors. The only way around it is to turn off permissions in your backup options.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...