Jump to content

File Not Found when scripts autorun


Recommended Posts

I am running Retrospect 5.15 under Windows 2000 Professional, and am backing up to a remote file server on a corporate private network.

 

 

 

When Retrospect launches automatically under the schedule I have set up, I invariably get the message "Can't access backup set 'name', error -1101 (file/directory not found)" for every script. When I lauch Retrospect and run scripts manually under the "Immediate" tab, the same scripts run perfectly.

 

The path to the backup location is of the form, myUserID on 'servername'(P:) with the backup folder specified.

 

 

 

It used to work well, but I am not sure what changed in the network or on my PC, but it was a sudden change. It may have been when I updated to Windows 2000 (previously was using Windows 95), but cannot be sure.

 

 

 

What could be causing this? Has anyone seen this before? Any ideas what I can do to restore my automatic backups?

 

 

 

Thanks.

Link to comment
Share on other sites

When you run "Immediate" Retrospect runs under *your* login userID (probably your network domain login), with all network permissions your ID probably has. When Retrospect is launched by the scheduler, it runs with whatever permissions the Retrospect Launcher service has--probably the "LocalSystem" account, which doesn't have any network domain permissions, which means it can't access the remote file server. Try changing the Retrospect Service (Settings/Control Panel/Admin Tools/Services/Retrospect Launcher) to use your network domain userID and password and restart the service.

Link to comment
Share on other sites

Thanks for the suggestions: both are essentially saying the same thing. I tried it, and it does seem to work. So I am definitely ahead.

 

 

 

However, it does seem strange that I need to configure Retrospect Launcher in the Services Control Panel as a network service, when everything else in that panel is set to LocalService, even items that are clearly network oriented - they seem to pick up my permissions locally somehow. And the disadvantage of following these procedures becomes evident when I have to carry out my periodic password change; every other service I access on the corporate network utilises a centralized password administration, which means I only change my password once in one place. This procedure now means I have to remember to do it in a second (obscure) location, because if I don't I won't be allowed access to the remote file server for backup purposes.

 

 

 

Any easy way to overcome this situation?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...