Jump to content

-515 (Piton protocol violation) & related errors

Recommended Posts

I have an error -515 (Piton protocol violation) and other related errors. Help Please. What should I do to get the backup to work properly.






I have Retrospect Workgroup V5.6 on computer (named) C10 with Seagate Tapestor 10/20 & 10/20 GB Seagate Travan tapes. Three other computers are on the LAN, each with Retro Client V 5.6. The 4 computers have Windows XP operating system. The four computers are backed up in this order: C10 (the backup server, backs up ok), C2 (has major errors described below), C8 (backs up ok), and C9 (Backs up ok):


The backup worked ok while running my Script, Backup Set F, used until Thursday 07-11-2002.






On Friday, 7-12-2002 the script called for changing to Backup Set D with a Recycle (full) backup. (The script rotates through backup sets D, E, and F, then repeats, over and over.) Prior to the backup, with Retro I did manual erase of three tapes and renamed them “1-Backup Set D”, “2-Backup Set D”, and “3-Backup Set D”. I left the tape “1 backup Set D” in the device.


The Recycle Backup to Set D began. C10 backed up OK; with a few explainable errors (1020 Sharing violation, 1101 file/directory not found, and compare errors for files that changed during the backup).


C2 backup began and ran ok for about 66% of the backup of that computer.


Tape “1-Backup Set D” got full after about 66% of C2 was backed up. Retro called for tape “2-Backup Set D”, and I inserted that tape. Then I left the backup to run unattended. After the backup completed I found the following errors on the log.




[Here is info about error during recycle backup Friday 020712:]




- 7/12/2002 5:52:55 AM: Copying Local Disk (C2C:) (C:) on C2


File "C:\Documents and Settings\All Users\Application Data\Microsoft\Network\Downloader\qmgr0.dat": can't read, error -1020 (sharing violation)


File "C:\Documents and Settings\All Users\Application Data\Microsoft\Network\Downloader\qmgr1.dat": can't read, error -1020 (sharing violation)


necoIncoming: unowned packet, tid 38


necoIncoming: non-stream packet too large: 433,679,


Trouble reading files, error -515 (Piton protocol violation


7/12/2002 9:13:57 AM: Execution incomplete


Remaining: 10281 files, 1.4 GB


Completed: 40395 files, 4.8 GB


Performance: 26.9 MB/minute


Duration: 03:21:01 (00:21:46 idle/loading/preparing)


[ End of info about error Friday 020712:]




The two 1020 sharing violation errors were explainable.


The remaining error lines sounded bad, but I was hopeful that the normal backup to occur the following Monday morning 7-12-02 would back up the missing files. (The next two backups did not solve the problem, as shown below.)




[Here is info about error during backup Monday 020715; this was the next backup after Fiday shown above: ]


[backup of C10 was ok and info is not shown here]


7/15/2002 1:18:42 AM: Connected to C2


- 7-15-2002 1:18:44 AM: Copying Local Disk (C2CJ (CJ on C2


necoIncoming: unowned packet, tid 43,963


necoIncoming: non-stream packet too large: -1,040,678,346


Trouble reading files, error -515 (Piton protocol violation)


7/15/2002 1:28:51 AM: Execution incomplete


Remaining: 11252 files, 1.7 GB


Completed: 39 files, 11.3 MB


Performance: 1.2 MB/minute


Duration: 00:10:06 (00:00:49 idle/loading/preparing)


7-15-2002 1:28:51 AM: Connected to C8 [C8 and C9 backed up ok]


[end of information copied from backup log for C2 on Monday 020715]




[Here is info about error during backup Tuesday 020716:]




[After a good backup of C10, Here is info about same error as on prior 2 backups of C2, with slightly different wording & new numbers:]


7/16/2002 1:11:51 AM: Connected to C2




- 7/16/2002 1:11:53 AM: Copying Local Disk (C2C:) (C:) on C2


File "C:\WINNT\Temp\ZLT15.tmp": can't read, error -1020 (sharing violation)


necoIncoming: unowned packet, tid 282


PitonPacket::netimport, unknown Piton packet type 0 [This is 1st time this line appeared.]


necoDispatch: unknown packet code from responder: 0


necoIncoming: non-stream packet too large: -2,063,597,556


Trouble reading files, error -515 (Piton protocol violation)


7/16/2002 2:15:13 AM: Snapshot stored, 46.1 MB


7/16/2002 2:17:57 AM: Comparing Local Disk (C2C:) (C:) on C2


Can't initialize source, error -515 (Piton protocol violation)


7/16/2002 2:17:57 AM: Execution incomplete


Remaining: 11573 files, 1.8 GB


Completed: 0 files, zero KB


Performance: 29.2 MB/minute (29.2 copy, 0.0 compare)


Duration: 01:06:04 (00:05:57 idle/loading/preparing)




7/16/2002 2:18:06 AM: Connected to C8 [and the backup proceeded normally in C8 and c9}.




[End of information copied to here from backup log of 020716:]






I have checked throughout Help and the knowledge base and I have considered everything I found there.


Here are details.


Re Manual page 221, column 2, -515 (piton protocol violation), usually caused by hardware failure, I have taken the following actions, observed the following, etc:


The Retro Manual says refer to page 207. That relates to network problems. At this point in writing this I thought the network was ok.


At the point of writing this document to this point, the only failure has been in backup of C2. I have had C10 running all the time, and have used it intermittently. I have used the computer C2 about 12 hours a day each day, mostly for MS Word XP and Internet Explorer. This indicates that the problem is not in C10 or in the LAN hub, unless it is bad connection to the C2 connector on LAN hub or possibly a bad circuit to that specific female connector on the LAN hub.


I have checked the connection of C2 cable to LAN hub, the connection was ok. I pushed it in firmly within 30 minutes before the backup of 020716 as I left the computers ready for backup, but the error occurred less than an hour later.


To check if there is a faulty circuit in the LAN hub, I have changed the C2 cable to a different female plug on the LAN hub. This change was at 020716, 1125, after the backup of 020716 and before the backup of 020717.


Other applications work ok from C2 to the LAN, to other computers, and to WWW: Explorer, Internet Explorer, MS Word. HERE IS A POSSIBLE EXCEPTION TO PRECEDING SENTENCE and a possible hint that this is a network or other equipment problem; this occurred later during preparation of this document:


As I was preparing this submittal to Dantz I was using MS Word XP in C2, and working on a large (1,383 KB) MS Word document saved on drive C in C10. Also running were Outlook (in my large email files), about 4 screens of Internet explorer, 1 or 2 Explorer (Folder) screens, and maybe more. As I was highlighting something in MS Word, C2 hung up. Ctrl-Alt-Del would not work to start Windows Task Manager, and I had to use reset button to reboot.


I rebooted, opened the same large MS Word document in C2 but stored in C10. I typed about 8 lines, and C2 hung up again. Ctrl-Alt-Del would not work to start Windows Task Manager, and I had to use reset button to reboot.


Working in C2, I then opened the same file in C10, but saved it immediately in C2, and continued working on it. I have prepared all of this posting without further errors.




I checked the network cable where it plugs into C2 to see if it is firmly in place; it was. At 020716, 1122, before the above crashes of C2, I moved that connection in and out a few times to remove any possible corrosion or other impairment to a good connection.




I checked Retro help. I checked: All Troubleshooting items, Index for Piton (nothing), Error No. 515 (same as manual).




I checked Dantz Knowledgebase for help. The following are the only items I see that appear at all applicable.


515 or -515 (piton protocol violation) = no help; same as Help.


Tech Note 415 Troubleshooting Error 519: = Until reading this, I did not think it was a networking problem; now I think it could be, especially with the two crashes described above while I was preparing this document. Study, consider, and follow this more if something else does not provide solution.


Tech Note 413 Retrospect Client for windows troubleshooting: I read it, do not think it applies. Consider again as last resort.






Possible causes of errors in C2: I very much doubt that this is the problem, but could the problem be caused by fact that Outlook email files are quite large? Could that be causing “necoIncoming: unowned packet, tid 43,963 necoIncoming: non-stream packet too large”?




At this point I have exhausted my reasonable resources, and I am submitting this request to Dantz Retro forum, and I ask, beg, plead, and implore you for help.


At Startup C2 has an error message that it has no paging file, and tells how to establish one. I establish a paging file, then message says reboot to change the settings. After I reboot, the message comes up again that no paging file. Actually there is a paging file of about 360 MB. The computer C2 has 384 MB of memory. I have concluded that the message of no paging file is in error.




Please tell me what to do to fix the above backup errors. Thank you, Doyle.







Link to comment
Share on other sites

The following is additional information since my prior posting on same topic and thread. My


request is at the end of this posting.






I got (computer named) C2 to back up by doing the following. I will welcome any suggestions as to what might have caused the problems, whether Retro caused the initial problems that first showed up near the end of the recycle backup on 7-12-02, and why I still have the problems listed below.






My prior post was 7-16-02 about 18:50 eastern or 1550 Pacific time.


I prepared most of the prior post in MS Word on C2 but with the file saved on C10. Internet Explorer would not run at same time as MS Word.


I moved the MS Word data file to on Hard drive in C2, but Internet explorer still would not run at the same time MS Word was open with that file. Also MS Word in C2 had a severe error and shut down several times. (When I tried to open my MS Word document, a dialog box said that file “caused a serious error the last time It was opened. Would you like to continue opening it?” I clicked no, and I deleted the file. In C2 I also did Start Settings, control panel, Add/remove, Repair of MS office XP. However, problems continued in C2 with MS Office and Internet Explorer running at the same time.




Then I prepared the MS Word document in C10, copied the text into Wordpad, saved the file as a *.rtf file in C10. (I used Wordpad instead of Notepad because I had headings in Red and


key words in bold; at that time I did not know Retro forum would not accept the red and bold.) Then I copied the *.rtf file to C2. Then I opened the *.rtf file with Wordpad in C2, I opened Internet Explorer and Retro Forum in C2, and copied and pasted the text into the Retro Forum form. That was my first posting on this thread.




Then I turned off C2 for about 3 hours. Then I disconnected the line incoming to LAN hub from Router, turned C2 back on, closed PC-cillin virus protection, closed ZoneAlarm Pro


Firewall, and ran only Task Manager. I used Task Manager to turn off all the processes that


I thought could be safely turned off (such as Web Trap, Email checking). I hoped this would ccause C2 to back up this time, and it did.




With C2 cleaned out, per above, backup worked as described here. The “normal” backup of C2 took about 44 minutes as compared to about 10 or 15 minutes for a usual incremental backup of C2. Apparently the extra time was working out shortcomings of the prior aborted backup of C2. Here is the log of the C2 portion of the backup:




7/17/2002 1:12:58 AM: Connected to C2




- 7/17/2002 1:13:00 AM: Copying Local Disk (C2C:) (C:) on C2


7/17/2002 1:39:57 AM: Snapshot stored, 59.2 MB


7/17/2002 1:42:09 AM: Comparing Local Disk (C2C:) (C:) on C2


File "C:\WINNT\Prefetch\RTHLPSVC.EXE-023BDCBC.pf": different modify date/time (set: 7/16/2002 2:13:04 AM, vol: 7/17/2002 1:24:34 AM)


7/17/2002 1:57:00 AM: 1 execution errors


Completed: 584 files, 401.0 MB


Performance: 34.5 MB/minute (38.3 copy, 31.4 compare)


Duration: 00:44:00 (00:20:46 idle/loading/preparing)




7/17/2002 1:57:01 AM: Connected to C8


Here are additional time breakdowns not shown in the Log. The times are very close to accurate unless noted.




1:12:58 AM: Connected to C2


Scanning the approximately 56,684 files went fast.


1:14 approx end of Scanning.


Copying the remaining 584 files (this indicates that the tape #1 had held far more then the 66% that I estimated and stated in prior posting. There were about 56,684 files on C2). The backup worked a long time scanning before at


1:24:00 it began


actual copying of files with filenames flashing on the screen


1:25:00 is about the time copying files ended


and “registry” appeared on screen”


1:26:00 is about when Retro began


Building snapshot.




Copying snapshot










“comparing” snapshot


1:56:00 the first and only error showed up, and it was an acceptable error in prefetch.


Still comparing snapshot


1:57:00 finished comparing shapshot. Finished the backup of C2 successfully!!!!




Then I rebooted C2 to reactivate virus protection and other things I had turned off. I connected incoming line to LAN from router. Internet Explorer opened ok and went to the Retro Forum. But with Internet Explorer running, when I opened MS Word document from on C10, I got an error and MS Word closed. Then I closed Internet Explorer. Then, with MS word screen in C2, I clicked to open the MS Word Document saved on drive C of C10. A MS Word dialog box said this file “caused a serious error last time opened, do you want to open it?”; I clicked no, and I deleted that bad file. I opened and saved another copy of the


same file that MS Word had “recovered” and “repaired”, and I used that file to prepare this posting. (I clicked choices and got a dialog box that said the errors repaired were errors


in styles 1 through 13. This indicates that part of the problem could be because C10 is running MS Word 2000 and C2 is running MS Word XP. That may have caused some errors in the use of styles. However, I have been moving files back and forth between the two versions of MS Word for several months, and these last two days are the first times I have had this problem.




I did not open Internet Explorer at same time MS Word was open. Instead, I transferred the text from MS Word to notepad, exited MS Word, opened Internet Explorer, and copied the text into the form for posting on the Dantz Forum.






I will appreciate receiving from Dantz staff or from other Forum members any explanations or




suggestions you can give me of what may be happening to cause me these problems and how to fix them. Also, Is the backup data likely to be correct under the circumstances I have described?




Thank you, Doyle



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...