Jump to content

Panther and Retrospect 5.1 Problem on Shutdown


Recommended Posts

I had an odd problem today which may not be unique to Retrospect althogh I sspect it may be. Last night I shutdown my Alum PowerBook G4 which I normally backup to several FW drives. Have OSX 10.3.6 and Retrospect 5.1.

 

Just as I shutdown Retrospect launched per a script which specifies the time of a backup. I'd forgotten about it. The shut down was delayed about five minutes.

 

When I booted the PowerBook this morning the Retrospect logo appeared at the top of the login screen! It was there only briefly but I soon had problems. I couldn't log into any account. Most attempts to type passwords for several accounts failed.

 

I finally got tired of attempts to type in passwords and tried to boot the Panther install disk to see what Apple's Disk Utility might find. It wouldn't boot. Holding the "c" key down failed three times. I was returned to the main login screen (where the strange appearance of the Retrospect logo) never appeared again. But I still couldn't type in passwords.

 

I then rebooted and held the shift key down, turning off "Extensions" (a rather broad term Apple uses for items that are more than "Extensions). This apparently disabled the Retrospect startup item located in /Library/Startup items. I removed it and put it on the desktop. A few minutes later Retrospect launched and created a new RetroRun in Startup items at /Library/Startup items. I quickly learned that RetroRun is not solely responsible for the timing of running scripts. I clicked on the Retrospect option to skip that backup, deleted the next few scheduled backups, then launched Retrospect (Desktop) again and the standard window appeared and it make so attempt to run.

 

What's unusual about this is that Retrospect had been completely launched prior to shutdown and clearly was interferring with my ability to login. No further problems were encountered and I ran the script manually to backup to one of my FW drives. I ran DiskWarrior 3.02 and there were no problems reported (I'd just run it last week because of some large installs (Office 2004 and several Adobe cs apps). Buut clearly no damage occurred as the result. As mentioned I ran the script manually. I also rescheduled another backup to begin in five minutes and it launched just as scheduled (I again instructed it to skip that backup).

 

Do other applications, perhaps accidentally launched at the time of shutdown, also create this problem? I can't imagine anyone doing this although I'm sure it occurs. The solution in the poor timing of my shutting down just as Retrospect was fully launched (and it had begun the count of whatever) was the obvious choice of rebooting with extensions off.

 

Weird. I've sed Retrospect in some form since 1995 and never had the good fortne (?) to have it launch just as I was shutting down. But if you have the bad luck I had just rebot with extensions off. wink.gif

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...